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1.1. Background 
The Warehouse Inventory Management System (WIMS) is a computer program initially developed 
by the USAID | DELIVER PROJECT and redesigned and maintained since 2015 by the Systems for 
Improved Access to Pharmaceuticals & Services (SIAPS) Program of Management Sciences for 
Health (MSH) for the Directorate General of Family Planning (DGFP). Based on users requirement 
and technological changes the WIMSV3 need to be updated and accordingly USAID Medicines, 
Technologies and Pharmaceutical Services (MTaPS) Program of MSH has taken this initiative and 
update the WMSV3 to WIMSV4.   
 

1.1.1. How it's used 
The Warehouse Inventory Management System (WIMS) is software to maintain inventory at 
family planning warehouses at district level. It enables warehouse staff to maintain stock of 
commodities, movement of stock & monthly Logistics Management Information System (LMIS) 
reporting. 
 

1.1.2. Advantages 
 Permits users to receive commodities from both Local & International shipments. 
 Has batch/lot and expiry date tracking for RH commodities. 
 Permits users to issue commodities maintaining First-Expiry-First-Out (FEFO). 
 Can be considered as a digital stock ledger for the warehouse. 

 

1.1.3. Limitations 
 Not web based, but uploads current stock status & monthly report to Supply Chain 

Management Portal (SCMP) automatically. 
 Requires training to operate. 
 Not a complete warehouse management system. 

 

1.1.4. Where it has been applied 
Directorate General of Family Planning (DGFP) under the Ministry of Health and Family Welfare 
(MOHFW) Bangladesh. 

 

1.1.5. Language availability 
English 

 

1.2. WIMSv4 Update Features 
1.2.1. General 

 Only to show/filter upazila names under the warehouse in every screen 
 Only active users will be able to login 
 Supply plan generation for contraceptives 
 Item Group & code unification, reduce unnecessary items 
 WIMS now uploads all data to central server (scmpbd.org) 
 Generate backup in .zip format 
 Receive invoice, Indent and F7B download 
 Warehouses can download Upazila INDENT and Upazila can download the IV. 
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1.2.2. Receive Invoice 
 National Receive report can be generated 
 Receive against Package#/Contract# of DGFP 
 Generate receive invoice from standing board 

 

1.2.3. Issue Voucher 
 Should not allow insertion of any item (lot) more than once in any issue voucher. If inserted, 

should show an alert 
 Invoice prepared, then while continuing updating, earlier prepared invoice shows old value. 

Should be updated 
 Should allow printing of invoice before stock updating. As this will allow ‘Issue Date’ to be 

updated before posting to stock (which is not possible now, so want to keep issue date 
empty). This will also ensure tracking of actual issue date 

 Auto generation of invoice 
 ‘Cancel’ flag in issue voucher 
 Issue voucher – insert a field "# of cartons", also print 
 During issue voucher posting to stock, shows error ‘Cannot Issue More Than Stock Quantity’ 

but does not mention which items are not available in stock. Should show clear message 
about the short quantity item(s) 

 Indent & Push invoice# can overlap and be duplicate, should not allow 
 After download indent to create indent Issue voucher. 
 

1.2.4. Adjustment Vouchers 
 Option of ‘Return to Higher Authority’ type adjustment 
 ‘Cancel’ flag in Adjustment voucher 
 Return to the Supplier from Provisional receive. 

 

1.2.5. Provisional Receive 
 Provisional receive against contract assign items 
 Standing Board Approval option 
 Return to the Supplier from Provisional receive. 

 

1.2.6. Reporting 
 Distribution report based on date, commodity, facility, district  (details & summary) 
 ‘Type of Adjustment’ not printed in report 
 Digital ICR – Supplier’s invoice# and Date should show 
 Receive report based on date range (details & summary) 
 Generate F7 report automatically & upload to SCMP 
 Digital ICR does not sort properly, should show receive, issue and adjustment records by 

date and invoice# 
 Receive report does not show item serial 

 

1.2.7. Bug Fixing 
1) BUG – Stock balance and stock details report mismatch 
2) BUG – Item lot shows/allows minus figure 
3) BUG - Cannot issue single item 
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1.3. What can & what cannot be in WIMSv4 (Cases) 
1.3.1. Item Group & Item List 

 User cannot add new Item in WIMSv4, need to download from Web 
 User also cannot add new Item Group, need to download from Web 
 User can add Employee and set Forms & Reports Edit & View access permission. 

 

1.3.2. Supply Plan 
 Create Supply Plan Master first then go for generation of supply plan items and Issue 

voucher without that it will not work; 
 After creating Supply Plan Master then create supply plan Items 

 Generate supply plan items 

 Generate Issue voucher 
 To delete supply plan items 

 Only can delete supply plan item for which issue vouchers are not generated 

 Delete supply plan item not possible if those Issue Vouchers are already generated 
 Select Facility and press generate issue voucher  

 This Month Issue voucher generate successfully 

 This Month un-updated issue would be regenerated 

 This Month update issue voucher would not be regenerated 
 Custom Supply plan for generating Issue voucher for other commodities. 

 

1.3.3. Form 7 
1. Create Form 7 master 

 Not Create Form 7 items 
2. Create Form 7 Items this Month Receive, issue and adjustment invoice Create & update 

status show after press post button  
3. This Month Receive, issue and adjustment invoice can’t be update 
4. User can be Unpost F7 report for regenerating F7 report. 
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2.1. How to Setup Data for a Warehouse 

 Step-1: After installed WIMSv4 double clicking the  icon from desktop. After pressing the 
WIMSv4 following screen will be appeared: 

 
 

 Step-2: Select User Id: XXX and type Password: XXX then press "OK". After pressing OK the 
following screen will be appeared: 

 
 

 Step-3: To select the software starting mode from the above screen click "Start with Fresh 
Database" radio button then press "Next" button. After pressing ‘Next’ the following screen will 
be appeared - 
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 Step-4: To select warehouse go to "Warehouse" combo list from the above screen and select a 
warehouse for whom the WIMSv4 has installed then press "Set Warehouse and Next" button 
as following screen: 

 
 

After completing progress the following screen will be appeared with a message box showing 
following message: 

“Meta data downloaded successfully. 
Please, Restart and Set Your Option Data Correctly.” 

 
 

 Step-5: After pressing “OK” in above "Completion Success" message box and the following 
screen will appear: 

 
 

After that the WIMSv4 software will ready to use. 
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2.2. How to configure WIMSv4 for respective Warehouse Users? 

 Double clicking the  icon from desktop and putting User ID and Password from the 
following window: 

 
 

 Select User Id: XXX & type Password: XXX then press OK. 

 
 

2.3. How to add an Employee in WIMSv4? 
 Go to Parameter > Employee menu 

 The following sub-menu will appear: 

 
 

 From the above sub-menu press "Employee" menu to Add/Edit an employee. After pressing 
"Employee" button the following screen will be appeared: 
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 Press add to create new Employee 

 After pressing add  the following screen will be appeared: 

 
 

 Type Name, Designation, User Id, Password then press Save  or press enter from keyboard 
(N.B. Make sure your User id would be at least 3 (three) digit and Password also at least 3(three) digits) 

 After pressing Save   button the following screen will be shown: 
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2.4. How do we set permission into Forms for each Employee? 
 Select respective employee from Employee List from the following screen: 

 
 

 Against each Employee you need to set following types of permission: 
1. Permit to View press  under view 
2. Permit to Entry/Edit press  under Edit 
3. Not  permit view or edit  check box empty  

 To set permission to each and every forms for an employee you have to click these manually as 
showing in following screen: 
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2.5. How do we set Options for WIMSV4? 
 Go to Administrator > Options 

 After pressing "Options" the following screen will be appeared: 

 
 

 To set “Prepared By, Approved By & Issued By” which will display when an Issue Invoice will be 
printed.  

 To select above 3 (three) combos the system must have required listed employees.  

 From the prelisted employee list you have to select employees as follows: 
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 If you need to cancel settings press  button before save. 

 After setting “Prepared By, Approved By & Issued By” then press  button. 

 Press  button. 
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Chapter-3: How to operate 
WIMSv4 
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3.1. How to start WIMSv4 

 Double click on  icon in your desktop or 

 Select Start > Programs > WIMSv4 > WIMSv4 from taskbar to run WIMSv4. 

 Following screen will appear: 

 
 

 Type in your User ID and Password in the boxes and press <Enter> or press "OK". 

 If your User ID and Password are correct and match then WIMSv4 landing screen will be visible. 

  

 At the bottom left of the landing screen you will see your User Name. 

 In the landing page displaying a dashboard for the warehouse’s status containing the following 
data: 
 Product in stock 
 Total facility 
 Supply of the warehouse last month of the year 
 Last F7 status 
 Last data upload status 
 Major contraceptives Chart report. 
 Expiring   product in 6 month. 

 Every block has transferring when the user click in this dashboard block. 
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3.2. How to exit WIMSv4 
 Select File > Exit from File menu bar. Or 

 
 Press the topmost right  button to exit from WIMSv4. 
Note: Before you exit, make sure that no forms are open. 
 

3.3. How to Logout 
 After your works are done and you temporarily want to suspend working with WIMSV4 but do 

not want to Exit then you should logout. This make sure that another person cannot use 
WIMSV4 with your permissions when you are out. To logout from WIMSV4, select File > Logout 
button from File menu. 

 
 

 After pressing logout then the following screen will appear: 

 
 

 If you want to resume your work after logging out, you have to log in again from File > Login 
menu. 

 
 

3.4. User Permission in Forms 
Based on the permission set by the Administrator, Users of WIMSV4 will be restricted to access 
certain parts of the software. The Administrator will set 3 (three) types of permissions to access the 
forms – 

 Edit – Users with edit permission on any form will be able to enter new data, edit data, delete 
and print in the specific form. 
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 View – Users with view permission will only be able to browse the data in the form but no 
editing will be possible by using his/her User ID. A typical form opened by a user with only 
“View” access: 

 
 

 No permission – If an user does not have Edit or View permission on any form and he/she tries to 
open the form, the following error message will be shown: 

 
 

3.5. How to Change Password 
Every user has a User ID and Password initially provided by the Administrator. For security reasons, 
user can change his/her password at any time by follow the below steps: 

 Select File > Change Password from File menu 

 Change Password Form will be visible 

 The User Id combo box will be shown your logged on user name 

 Provide your Current Password in Old Password box 

 After that enter the New Password that you would like to set in the New Password and 
Confirm Password box 
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 Press Update button to continue 

 To check that the New Password is in effect, Login again from File > Login… dialog box. 
 

3.6. WIMSv4 Menu(s) Operating Guidelines 

1. To open WIMSv4, user need to double clicking the  icon from desktop.  
 

2. The WIMSv4 have following Menu and Sub-Menu: 

 
 
 Menu: File, Parameters, Invoice, Stock, Reports and Administrators & Help. 
 Sub-Menu: Exit, Login, Logout, Change Password etc.  

 
3. At a time multiple forms can be opened and user can browse one to another just like switching 

Forms' Tabs. 

 
 

4. To Minimize, Maximize and Close a form, user need to click buttons from the following bar: 

 
The forms will be kept opened until user close the form. 
 

3.7. Form Elements 
A typical Entry Form can be divided into 4 (four) specific common blocks – 

 Block-A: This block generally consists of a list of IDs/Names/Dates from which one can select 
a specific record to view in following Block-B & C in details. 

 Block-B: The basic and common header data need to enter in this block. 
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 Block-C: The details items under a same header need to enter in this block. 

 Block-D: This block consists of a number of buttons to entry, edit, delete, and preview and 
print the records. 

 
 

3.8. Common Command Buttons 
A list of common command buttons with label name which will found in most of the forms: 

 To insert a new record of any type 

 To undo the current record 

 To save the current editing 

 To delete the current record in a form 

 To preview a report before printing 

 To print a report without previewing 

 To view print options before any print from Preview 

 To update of records to addition or deletion into stock data 

 To close a form 

 To cancel any action or task 

 To OK of any action or task 

 To search/filter of any records 

 To insert a new record in a form 

 To undo the current record 

 To save the current editing 

 

 

 

      A 

                                

                                   B 
                                

                                   C 

                                 D 
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 To delete the current record items in a form  

 Toggle button for expand and close of a form 
 

3.9. Common Features of a Form 

 
 

(1) Group/Un-group: Group/Un-group of a form just clicking Upper/Lower Arrow as follows: 

 
 
(2) Search a Record: Search a record of a form just write correct spelling of word or a portion of 
correct word as follows: 

 
  

1 

2 3 

4 

5 

6 
7 8 9 
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(3) Row Hide-Unhide: User can hide and unhide any number of Rows just clicking (+) or (-) button 
as follows: 

 
 

(4) Column Shifting: User can shift ether side (Left-Right) of any column of a form as follows: 

 
After Shifted: 

 
 
(5) Total Records Count: 

 
 
(6) Page Scrolling: User can see how many records are in the system as follows: 
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(7) Export Records: If user need to export any records from any forms, for this user click on 

 button and the system will asking for destination drive where to save and chose file 
format (Excel/PDF).  

 
 

After exporting the file if it is export to Excel, the file look like as follows: 

 
 

(8) Printing Option 

 Press button to preview the report/data. 

 Press for direct print into a printer without previewing the report/data 

  4 (four) icons using for Page set-up for printing. After pressing 

button these icons will appear in Status bar.  icon used for print,  icon used for Quick Print, 

 icon used for Page Setup and "Scale"  icon used for Scaling of "default set page" to 
"Adjust to" or "Fit in" page size to your desire Custom Page Size. 

 After printing, press the leftmost button to close the Preview window. 
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(9) Close a Form 

 Press  button to exit from a form. 

 User can also exit by pressing the  button at the top right of the form. 
 

3.10. Forms Data Uploading & Downloading Condition 
3.10.1. Data Downloaded from Web 
The following forms' basic data will be downloaded from web and user could not updated or enter 
any records: 

1. Item Group 10. Adjustment Type 

2. Item List Form List 11. Employee Designation 
3. Suppliers 12. Indent Designation 
4. Warehouse List 13. Division 
5. Upazila List 14. District 
6. Package Contract 15. Facility Groups 
7. Year 16. Forms Item Setting  
8. Indentor 17. Supply Plan Item Serial 
9. Unit 18. Month List 

 

3.10.2. Data Entry in and uploaded from WIMSv4 
User can enter new data in the following Forms data: 

1. Employee 8. Return to the Supplier Provisional Receive 

2. Option 9. Issue Voucher (Push) 

3. Others Facility List 10. Gate Pass 
4. Receive from Supplier 11. Adjustment Invoice 
5. Receive from Warehouse 12. Indent 
6. Provisional Receive Entry 10. Form 7 
7. Standing Board 11. Supply Plan 

 

3.10.3. Data download/Entry in and uploaded from WIMSv4 
User can download/enter new data in the following forms data: 

1. Receive from Warehouse 2. Issue Voucher (Indent) 

 

3.10.4. Common & No Effect Forms in WIMSv4 
The following Forms have both download and upload option from WIMSv4 to Web: 

1. Form 7B  

2. Backup Database  
3. Data Download  
4. Data Upload  
5. Reports  
6. Stock Balance  
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Chapter-4: Parameters 
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4.1. Item Groups 
Store commodities are classified into a number of groups. Each group is unique and has a group 
code and a descriptive group name. Normally group code is defined by 3 (three) characters in 
length and abbreviated from their descriptive name. 

 Run WIMSv4 

 Select Parameters > Item Groups from Parameters menu. 

 The Item Groups form will be displayed as following screen: 

 
 

This form is used to edit, create, delete, print item groups. The form are grouped into 2 (two) 
blocks: 
A. Fields Block: 

Group Code: 3 (three) digit alphanumeric code that can represent the group. 
Group Name: To describe a group, two fields are required. 
Total Count: Total number group show under view filed. 
 

 Users cannot add a new ‘Item Group’ by their own using WIMSv4. They only can view ‘Item 
Groups’. When WIMSv4 software will be installed into their computer these will be 
automatically downloaded from SCMP portal. In the web portal if any new group will update 
by Administrative Panel or if user will found an Item group in any receive invoice/challan 
which do not have in WIMSv4 while they try to enter in WIMSv4 which running in the 
warehouse then they need to download it first by clicking Administrator > Data Download 
form from Administrator menu. 
 

 From the Data download form user will found a Download button middle top side of the 
form. User need to click the Download button to sync from web if any new Items code, group 
code, suppliers etc. waiting for download. 
 

B. Export, Preview & Close Block: 
To export, preview, print and close the Item Groups user can do these by using this block. 
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Print Item Groups: 

 Press  button to view a printable list of item groups. 

 
 

 Press on the printer icon. The print dialog box will appear. 
 
Export Item Group:  
If user need export Item group list - Select export format then the Item group list will visible here in 
your chosen format.  
 
View Items under each Group 

 
 

 Select the group from item groups list on item list form. 

 Press button to see the items under the selected group. 
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4.2. Item List 
To view item list, user need to go to the following form: 

 
 

 Store commodities are classified into a number of groups.  

 Item code in the form of XXXYYY where XXX is the group code and YYY is a sequence number.  

 Every item has a distinct Item Name. 
 
View Item List 

 Run WIMSv4 

 Select Parameters > Item List… from Parameters menu. 

 The Item List form is displayed. 
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General Description of Item List Form 

 
 

This form is used to edit, create and print items. Controls in the form are grouped into 3 (three) 
blocks – 
A. Item Group: Shows a list of current Item groups in database. A label below shows the total 

number of items under the selected group. 
 
B. List of Items: Shows details about every item under the selected group. To describe an Item, 5 

(five) fields are required. 

 Item Code – A unique 6 (six) digit code that can be used to identify the item. The code is 
generated automatically. But you can change if you wish. 

 Item Name – A descriptive name for the item. 

 Initial Stock (Usable) – Initial stock which is available when we include the item in the 
inventory system. 

 Initial Stock (Unusable) – Initial unusable quantity of the item. 

 Unit – Unit of measurement of the item. 

 Item Code, Item Name and Unit fields are compulsory. Items can be sorted in the list by 
‘Item Code’ or ‘Item Name’, which is done through Sort By combo selection. 

 
C. Command Buttons: To use “Export” button to export manipulate the item list and “Preview” 
button use to print manipulate the item list. 

  

 

 

                       A 

 

 

                      B 

                                               C 
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Search and find an Item 

 
 

 Type Item name in search box Items which match with the search text will be shown in the list. 

 To see all of the items again, delete item name from search box. 
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View information about a specific Item 

 
 

 Select the group of the item from item group list. 

 All the items under the group will be shown in list. 

 Scroll through the list to find the Item you are looking for. 
 

View Lot-wise information about a specific Item 

 
 Select the item for which you want to view lot-wise information. 

 Select the item show lot-wise information in right side. 
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Entry Initial Stock 

 
 

 Select item from Item list and enter Initial Stock (Usable) and Initial Stock (Unusable) then 
press “Enter” from keyboard. 

 
 

 After pressing Enter, the putted initial stock will be save and select next item from item list. 
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Initial Lot QTY Entry 

 Press "Show Item Lot Details"  button 

 After pressing "Show Item Lot Details" button the following screen will be displayed: 

 
(N.B: After save Initial (Usable) or Initial Stock (Unusable) items Initial Lot Qty will be displayed item list right side) 
 

 First need to be updated initial stock then user can enter Lot entry; 

 If user need to be cancel this form press  button. 
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 If user need to give entry Mfg. Date, Expiry Date and Multiple Lot entered as shown in following 
screen: 

 
(N.B. The system could not allow Mfg. Date afterwards any date of System date & Expiry Date backwards 
any date of System date) 
 

 After pressing  the entry will be save and displayed the entered lot-wise stock 
items in right side as shown in the following screen: 
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Print Item List 
If user need to print Item List just press preview button then press printer icon the item list is to be 
printed as following preview will be appeared: 

 

 
4.3. Suppliers 

Commodities are received in the warehouse from different external suppliers. For reporting and 
future reference, a list of suppliers is maintained. To go to Suppliers form: 

 Run WIMSV4 

 Select Parameters > Suppliers… from Parameters menu. 

 The Suppliers form is displayed as follows: 

.  
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General Description of Suppliers Form 

 
The supplier list displayed with supplier Code, Supplier Name, Address, Phone, Fax and Email 
columns. 

 
Print Suppliers List 

 Press button to view a printable list of suppliers. 

 
 

 Press on the printer icon. The print dialog box will appear. 
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4.4. Employees 
The Employees Form contains the name of employees and their permissions in different data entry 
forms. Employees who are relevant to the WIMSv4 software should be listed using this form. Every 
user will have one User Id and Password with which they enter into the software. 
 Run WIMSv4 
 Select Parameter > Employees… from Parameters menu and  
 The Employees form is displayed. 

 
 

This form is used to entry, edit, delete, print list of employees. The form is grouped into 4 (four) 
blocks –  

A. List of Employees: Shows a list of current employees in database. A label shows the total 
number. 

B. Entry Fields: To describe an employee, 5 (five) fields are required. 
 Name – Name of the employee. 
 Designation – Designation of the employee. 
 User ID – Three character User ID for each employee, which will be used during logging 

into the software. 
 Password – Password of the employee which he/she will use during logging into the 

software. 
 Mobile No – Mobile number of the employee. 
 Email – Email address of the employee. 
All of the fields are compulsory. 

C. Forms Tab: List of form names. In each form, the user will be given permission to ‘View’ or 
‘Edit’ the entry form data.  

D. Command Buttons: A number of buttons to manipulate the employees. 
 

View information about a specific employee 

 Select the employee you want to view from the tree-like list in Block-A. Using the order by. 
Employees can be sorted in 2 (two) ways – by Employee ID or by Employee Name.     

 After an employee name is selected – all the Form list are shown in Block-B. 
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Enter a new Employee 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 

 Type Employee Name. 

 Select the Designation of the employee from list. 

 Enter a 3 (three) digit User ID. 

 Enter a Password for the employee. The Password will be shown as special (***) for security 
reasons as following screen:  

 
 Enter mobile number of the employee. 
 Enter email address of the employee. 

 Press or Enter button from keyboard. 
 Newly entered Employee name will be visible in the Employees list in Block-A. 
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 If the new User ID conflicts with an existing ID, then an error dialog will appear “Change the 

user id and try saving again”. 
 If you want to cancel the new employee entry, press ‘Esc' during editing to undo. 

 
Enter Permissions in Data Entry Forms 
 Select the employee for which you want to provide permissions to data entry forms. 
 If you do not want that the employee will access different forms, then do not give permissions. 

 
 

 If you want the employee to only see data but cannot change anything, then click under ‘View’ 

column. A  will appear beside the form name under View column.  
 If you want that the employee would do the data entry in the form, then click on View and Edit 

column beside the form name. A  will appear beside the form name under View and Edit 
column. 
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Edit an existing Employee 
 Select the employee you want to edit from the list of employees. 
 Change the Employee Name, Designation, User ID, Password fields as needed.    
 When done with editing, press Save. 

 If the new User ID conflicts with an existing employee, then an error dialog will appear. 
Change the User ID and try saving again. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 
Delete an existing Employee 
 Select the employee you want to remove from list of employees. 
 Press “Delete” button from Keyboard. 
 A confirmation dialog will be shown.  
 Press ‘Yes’ if you really want to delete the employee.   
 You will not be able to delete employees that have permissions in different forms. First remove 

the permissions in different forms first then remove the employee. 
 
Print Employee list 

 Press  button to view a printable list of Employee List. 

 
 Press on the printer icon. The print dialog box will appear. 

 
Close Employees Form 

 Press  button to exit from the employees form.  

 You can also exit by pressing the  button at the top right of the form.  
 If you have unsaved Employee data during exit, you will be informed that your changes will be 

lost if you exit. 
 Press ‘Yes’ if you do want to exit without saving. Press ‘No’ if you don’t want to close the form 

at this time. 
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4.5. Warehouse List  
 Run WIMSv4 

 Select Parameters > Warehouse List from Parameters menu. 

 The Warehouse List form is displayed. 

 
 
 This form is used to view and print warehouse list.  
 The form are 3 (Three) columns fields - Facility Code, Facility and Phone No. 
 The Warehouse List data need to download from web, user could not add data here. 

 
Print Facility List 

 Press   button to view a printable list of Facility. 
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4.6. Upazila List 
 Run WIMSV4 

 Select Parameters > Upazila List from Parameters menu. 

 The Upazila List form is displayed. 

 
 

 This form is used to view and print upazila list.  
 The form are 7 (Seven) columns fields - Facility Code, Facility, Geo Code, District, Supply From, 

Phone No, Receiving Facility. 
 The Upazila list data need to download from web, user could not add data here. 

 
Print Upazila List: 

 Press   button to view a printable list of upazila list. 
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4.7. Others Facility List 
 Run WIMSv4 

 Select Parameters > Others Facility List from Parameters menu. 

 The Others Facility List entry form is displayed. 

 
 

 This form is used to edit, create, delete, and print Facility List.  
 The form are grouped into 5 (Five) column entry fields - Facility Code, Facility, District, Phone No 

and Receiving Facility. 
 User can add new other facility List to using ‘+’ button. Here as follows: 

 
 

 Enter Facility Code, Facility, District, Phone No, Receiving Facility.  

 If this facility received from ware house by supply plan then press   box 

 If your new facility code matches with a facility code, an error screen will be shown.  
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 Change the facility code and press enter button again. The facility will be saved. 
 

Edit an existing Facility 

 Select the facility you want to edit from facility list. 

 Change the facility name field as needed. 

 When done with editing, enter button from keyboard  

 If your facility name matches with an existing facility name, then an error screen will be shown.  

 
 

 Change the Facility Name and press Enter button from keyboard again. 
 

Delete an existing Facility 

 Select the Facility you want to remove from Facility list. 

 Press "Delete" button from keyboard. 

 A confirmation dialog will be shown: 

 
 Press "Yes" if you really want to delete the facility. 

 You will not be able to delete facility that have under items it. 
 

Print Other Facility List: 
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4.8. Package Contract 
 Run WIMSv4 

 Select Parameters > Package Contract from Parameters menu. 

 The Package Contract form is displayed. 

 
 

 This form is used to view and print package contract.   
 The form 2 (two) block - 

 Package Contract information 

 Contract Item Information 
 The Package Contract information has 4 (Four) fields - Year, Package No, Procurement entry and 

Contract Name. 
 Contract item information: Contract item (Each item have under as contract name) with 3 

(three) fields: Item Code. Item Name and contract Qty. 
 The Package Contract data need to download from web, user could not add data here. 

 
Print Package Contract List 

 
 Press on the printer icon. The print dialog box will appear. 
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4.9. Year 
 Run WIMSv4 

 Select Parameters > Year from Parameters menu. 

 The Year form is displayed. 

 
 

 This form is used to view and print Year.  
 The form are grouped into 4 (four) field - Year Id, Dead line, Package year, Current year.  
 The Year list data need to download from web, user could not add data here. 

 
Print Year List: 

 Press  button to view a printable list of Year. 

 
 Press on the printer icon. The print dialog box will appear. 
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4.10. Indentor 
 Run WIMSV4 

 Select Parameters > Indentor from Parameters menu. 

 The Indentor entry form is displayed. 

 
 
 This form is used to view and print Indentor.  
 The form are grouped into 3 (three) Fields: Indentor Id, Indentor Name and OP Description.  
 The Indentor list data need to download from web, user could not add data here. 

 
Print Indentor List: 

 Press  button to view a printable list of Indentor. 

  
 Press on the printer icon. The print dialog box will appear. 
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Chapter-5: Invoice 
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5.1. Receive Invoice – Receive from Supplier 
After go to Invoice menu user will find two types of Received Invoice. The following screen shows 
the Receive from Supplier Invoice entry form: 

.  
The above form is used when items are received from supplier. Item quantities received from 
suppliers which entered into WIMSv4 trough this form and the quantities added up with items total 
stock. This form is used to create new receive invoice, edit, print or delete invoices. 

 

Open Receive Invoice Form 

 Run WIMSv4 

 Select Invoice > Receive From Supplier… from Invoice menu. 

 The Receive Invoice Form is displayed. 
 

General Description of Receive Invoice Form 

 
 

 

 

 

      A 

 

                              B 

 

                              C 

                             D 
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This form is used to edit, create, delete, and print the Receive Invoices. This form data entry 
automatically from provisional receive after standing board or manually data entry. The form is 
grouped into 4 (Four) blocks – 

A. Invoice List: Invoices can be listed grouped by  

 Invoice No. or  

 Invoice Date.  

 A label shows the total number. 
 

B. Invoice Entry Fields: To record an Invoice, 15 (fifteen) fields are required as follows: 

 Invoice No* – A unique sequence to represent the invoice. 

 Receive Date* – Date of receipt of goods. 

 Received By* – Name of receiving officer. 

 Supplier* – Name of supplier. 

 Supplier Invoice No* – Voucher No. of supplier. 

 Supplier Date* – Date of supplier voucher. 
All of the above fields are mandatory. 

 Bl No – BL No 

 BL Date – BL date 

 Procured By – procured by 

 Year – Package contract Year 

 Package No – Package no 

 Contract No – package contract no 

 Remarks – Remarks field are not mandatory 

 Update – If the invoice updated the update check set in the check box. 

 Cancel – If the invoice canceled the cancel check set in the check box. 
 

C. Invoice Items Entry Fields: Invoices consist of line items. There is one line for each item 
received and has the following 6 (six) fields: 

 Item* – Name of item received. 

 Unit – Unit of measurement of item. 

 Lot No – Lot no. of the received goods. 

 Mfg. Date – Manufacturing date of the received goods. 

 Received Qty* – Total quantity of good received. 

 Expiry Date – Date of expiry of the received goods. 
Item and Received Qty are mandatory. Unit field is shown automatically. Other fields are 
optional. 
 
D. Command buttons: A number of buttons to manipulate the Invoices. 
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View information about a specific Invoice 

 
 Select the invoice to view from the tree-like list in Block-A. Using the Group by any fields – 

Invoices can be grouped in ways – by Invoice No or by received date or by supplier 

 After an invoice no. is selected – corresponding information is shown in Block-B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press ‘Filter’ button 
to list less or more invoice. 

 
 

Enter a new Invoice 

 Press  button from the command buttons block. The form will look like as follows: 

 
 

 The Invoice No. will be generated automatically. 
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 Receive Date will be filled with current date. You can change if necessary. 

 Automatically select the Employee who is received the goods. You can change Receive By 
employee name. 

 If the supplier name is present in supplier list then select the name. 

 Provide invoice no. and date from supplier’s challan. 

 
 

 Press  button. 

 Your new Invoice no. will be visible in the Invoice list. 
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 If you want to cancel the new Invoice entry, press ‘Esc’ during editing to undo. 

 
Invoice Items Entry 

 Press button from the command buttons block. The form will look like the following screen: 

 
 

 Select an Item name from Item combo box. 

 Unit field will be filled automatically. 

 Enter Lot No, Mfg. Date, Received Qty and Expiry Date fields. 
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 Press “Enter” button from keyboard to save the line item and go for next line item entry. 

 
 

Updating the Stock 
Entry of a new Invoice does not update the current stock position automatically. After the Invoice 

entry is completed, press  button to recalculate the balance of Items from the current 
Invoice. 
Note: After the invoice quantities are updated to stock, the invoice will be locked, user will not be allowed 
to change any figure afterwards. 

 A confirmation dialog will appear. 
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 Press "Yes" if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of Items for which stock was updated. 
 

‘Unpost’ Existing Receive Invoice 
Only Central Warehouse can ‘Unpost’ updated receive invoice for lot wise receive quantity entry. 

 
If you want to ‘Unpost’ this updated received invoice press ‘Unpost’ button then show the following 
message: 

NB. User cannot ‘Unpost’ this invoice, if this receive item already issued. 
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Press “Yes” then unposted invoice items open to edit for this user. 
 
Edit an existing Invoice 

 Select the invoice you want to edit from the list of Invoices. 

 Change the fields as necessary. 

 When done with editing, press Save. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 
Delete an existing Invoice 

 Select the Invoice you want to remove from Invoices list. 

 Press  button. 

 A confirmation dialog will be shown - 

 
 Press "Yes" if you really want to delete the Invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 
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Edit an existing Invoice Item 

 
 

 Select the Invoice item you want to edit from the items list in Block-C. 

 
 

 Press F2 or click on any field to start editing. 

 
 

 Change the fields as necessary. 

 When done with editing, press Save. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an Invoice item 

 Select the Invoice item you want to edit from the items list in Block-C. 

 Press Delete button from keyboard. 

 A confirmation dialog will be shown as like below screen: 

 
 Press “Yes” if you really want to delete the Invoice item. 
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Search a Receive Invoice 

 Press  tab for expanding Receive Invoices form and to find a specific Invoice 

 
 

 To search go to row 
header just writing Invoice no. and following window will appear: 

 
 

 Enter the invoice no you want to find in "Receive Invoice No." box. 

 Automatically start searching. 

 If the invoice is found then it will be shown selected. 
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Print Receive Invoice 

 Press button to preview the Invoice. 

 Press on the printer icon. The print dialog box will appear. 

 You can print only one copy or all pages, choose as you want then just press OK. 

 After printing, press the leftmost button to close the Preview window. 
 
Close Receive Invoice Form 

 Press button to exit from the receive Invoice form. 

 You can also exit by pressing the button at the top right of the form. 

 
5.2. Receive Invoice – Receive From Warehouse 

When items are transferred among warehouses, i.e., Injectable moved from Chittagong RWH to 
Dhaka CWH – this form is used. Item quantities entered here add up to total stock. This form is 
used to download new receive invoice, enter new receive invoice, edit, print or delete old invoices. 

 
 

Open Receive Invoice Form 

 Run WIMSv4 

 Select Invoice > Receive From Warehouse… from Invoice menu. 

 The Receive Invoice form is displayed. 
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General Description of Receive from Warehouse Form 

 
 
This form is used to download, entry, edit, delete and print receive invoices. Controls in the form 
are grouped into 5 (five) blocks – 
A. Invoice List:  

Invoices are listed by item group. Invoice group filters the invoices according to their group. 
Invoices can also be listed grouped by Invoice No. or Invoice Date. A label shows the total 
number. 

B. Invoice Entry Fields:  
To describe an Invoice, 9 (Nine) fields are required. 

 Invoice No – A unique sequence to represent the invoice. 

 Receive Date – Date of receipt of goods. 

 Received By – Name of receiving officer. 

 Supplier – Name of warehouse from where goods were sent. 

 Supplier Invoice No – Voucher No. of supplier. 

 Supplier Date – Date of supplier voucher. 
 All of the fields are compulsory. 

 Remarks– Remarks field are not mandatory 

 Update – If the invoice updated the update check set in the check box. 

 Cancel – If the invoice canceled the cancel check set in the check box. 
C. Invoice Items Entry Fields:  

Invoices consist of line items. There is one line for every item received. Every line has the 
following 6 (six) fields: 

 Item – Name of item received. 

 Unit – unit of measurement of item. 

 Lot No – Lot no. of the received goods. 

 Mfg. Date – Manufacturing date of the received goods. 

 Received Qty – Total quantity of good received. 

 Expiry Date – date of expiry of the received goods. 

 

 

 

        A 

 

                               B 

 

                               

                                C 

                                 D        E 
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 Item and Received Qty are compulsory. Unit field is shown automatically. Other fields are 
 optional. 
D. Command Buttons: A number of buttons to manipulate the Invoices. 
E. Download Invoice Button: Download receive invoice which are supplied from warehouse with 
Issue Push/Indent voucher. 
View information about a specific Invoice 
 

 
 

 
 

 Select the Invoice to view from the tree-like list in Block-A. Using the group by– invoices can be 
grouped any field– by Invoice No or by Receive Date. 

 After an Invoice no. is selected – corresponding information is shown in Block-B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed.  

 You can change the dates and press "Filter" button to list less or more invoice. 
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 You can chose Invoices of Today, Yesterday, Last Week, This Month, Last Month, Last 3 Month, 
Last Year and Custom Range of choosing any date range as shown in the above screen.  

 
 

Download a Receive Invoice 

 Press  button from the command buttons block. The form will look like 
this: 
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 Select Warehouse and enter the Inv No: (Push/Indent) like following screen - 

 
 

 Press on ‘Download’ button. After pressing the receive voucher will be downloaded and 
message displaying 1 invoice(s) download successfully. Like following screen - 

 
 Now you can check and update the downloaded invoice. 
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Enter a new Invoice 

 Press  button from the command buttons block. The form will look like this: 

 
 

The Invoice No. will be generated automatically. 

 Receive Date will be filled with current date. You can change if necessary. 

 Select the employee who is receiving the goods. 

 If the Supplier name is present in Supplier list then select the name. 

 Provide Invoice no. and date from Supplier’s challan. 

 
 

 Press  button. 

 Your new Invoice no. will be visible in the Invoice list. 



WIMSv4 User’s Guide 

Page 66 of 206 
 

 
 

 If you want to cancel the new Invoice entry, press Esc during editing to undo. 
 

Invoice Items Entry 

 Press button from the command buttons block. The form will look like the following screen: 

 
 

 After select an Item press <Enter> and type Receive Qty, Lot No, Mfg Date and Expire Date. 
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 Press <Enter> button from keyboard. After pressing <Enter> the item will save as showing in 
following screen: 

 
 
Updating the Stock 
Entry of a new Invoice does not update current stock position automatically. After the Invoice entry 
is complete, press "Update" button to recalculate the balance of items from the current invoice. 
Note: After the invoice figures are updated to stock, the invoice will be locked – you will not be allowed to 
change any figure. 

 Press "Update" button. 

 A confirmation dialog will appear. 
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 Press “Yes” if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of items for which stock was updated. 
 

Edit an existing Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press “Save”. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an existing Invoice 

 Select the invoice you want to remove from Invoices list. 

 Press “Delete” button. 

 A confirmation dialog will be shown. 

  
 Press “Yes” if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and 
then delete the invoice. 

 
Edit an existing Invoice Item 

 
 

 Select the Invoice Item you want to edit from the Items list in Block-C. 
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 Press F2 or click on any field to start editing. 

 
 Change the fields as necessary. 

 When done with editing, press “Save”. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an Invoice Item 

 Select the Invoice item you want to edit from the items list in Block-C. 

 Press “Delete” button. 

 A confirmation dialog will be shown. 

  
 Press “Yes” if you really want to delete the invoice item. 
 
Search a Receive Invoice 

 Press  tab for expanding Receive Invoices form and to find a specific Invoice 
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 To search go to row 
header just writing Invoice no. and following window will appear: 

 
 

 Enter the Invoice no you want to find in "Receive Invoice No." box. 

 Press <Enter> button to start searching. 

 If the Invoice is found then it will be shown selected. 
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5.3. Issue Voucher (Push) 

 
This form is used to distribute items to facilities without any indent. Item quantities issued through 
this invoice are deducted from the total stock. This form is used to enter new Issue Voucher (Push), 
edit, and print or delete old invoices. 

 
Open Issue Voucher (Push) Form 

 Run WIMSV4 

 Select Invoice > Issue Voucher (Push)… from Invoice menu. 

 The Issue Voucher (Push) form is displayed. 
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General Description of Issue Voucher (Push) Form 
This form is used to edit, create, delete, and print Issue Voucher (Push). Controls in the form are 
grouped into 4 (four) blocks – 

 
 
A. Invoice List:  

Invoices can be listed grouped by Invoice No., Indentor or Invoice Date. A label shows the total 
number. 

B. Invoice Entry Fields:  
To describe an invoice, following fields are required. 

 Invoice No* – A unique sequence to represent the invoice. 

 Facility* – Facility receiving the items. 

 Prepared By, Approved By, Supplied By* – Name of employees who are responsible for issue 
of items. There are three date fields related to the names. 

 Prepared By Date, Approved By Date, Supplied By Date* – Dates in which invoice 
preparation, approval and supply are made. 

 Remarks – Any comments about the supply. 
 Invoice No, Facility, Prepared by, Approved by, Supplied by and their related date fields are 
 compulsory. 
C. Invoice Items Entry Fields:  

Invoices consist of line items. There is one line for every item received. Every line has the 
following eight fields: 

 Item* – Name of item requested. 

 Unit – unit of measurement of item. 

 Stock Qty – Current stock quantity in issuing facility. 

 Issued Qty* – Quantity issued to facility. 

 Lot No – Lot no. of the item issued 

 Mfg. Date – Manufacturing date of the item lot issued 

 Expiry Date – Expiry date of goods in the lot. 
Item and Issued Qty fields are compulsory. Unit, Stock Qty, Lot No, Mfg. Date and Expiry date 
are automatically picked from item’s lot information. 

 

 

 

        A 

 

                               B 

                               

                                C 

                                 D 
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D. Command buttons:  
A number of buttons to manipulate the Invoices. 

 
View information about a specific Issue Invoice: 

 Select the invoice to view from the tree-like list in block A. Using the Group By combo box – 
invoices can be grouped in three ways – by Invoice No, Facility or by Invoice Date. 

 After an invoice no. is selected – corresponding information is shown in block B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press ‘Filter’ button 
to list less or more invoice. 

 
Enter a new Issue Invoice 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 The Invoice No. will be generated automatically. 

 Date fields will be filled with current date. You can change if necessary. 

 Select the employee names who is preparing, approving and supplying the goods. 

 Optionally provide other fields. 
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 Press  button. 

 Your new invoice no. will be visible in the invoice list. 

 If you want to cancel the new invoice entry, press ‘Esc’ during editing to undo. 
 

Issue Invoice Items Entry 

 Press  button from the command buttons block. The form will look like the following screen:  

 Select an item name from Item combo box. 

 
 Unit field will be filled automatically. 

 Enter Issued Qty. 

 The Stock Qty, Lot No, Mfg Date and Expiry Date will be picked from the lot information, if 
available. 
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 Press <Enter> to save Invoice line items. 

 
 

Updating the Stock 
Entry of a new invoice does not update current stock position automatically. After the invoice entry 
is complete, press "Update" button to recalculate the balance of items from the current invoice. 
Note: After the invoice figures are updated to stock, the invoice will be locked – you will not be allowed to 
change any figure. 
 

 Press  button. 

 A confirmation dialog will appear. 
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 If you want update on date of previous month press “Yes” or you want update on Issue date 

press “No” then update issue date in invoice. 

 
 If the invoice issue date in current month, after pressing update will see the above screen. Press 

“OK” and you will see the following screen. 

 
 Press "Yes" if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of items for which stock was updated. 
 
Edit an existing Issue Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press "Save". 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an existing Invoice 

 Select the invoice you want to remove from invoices list. 

 Press "Delete" button. 

 A confirmation dialog will be shown. 

 
 Press “Yes” if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 
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Edit an existing Issue Invoice Item 

 
 

 Select the invoice item you want to edit from the items list in block C. 

 
 

 Press F2 or click on any field to start editing. 

 
 When done with editing, press Save. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an Issue Invoice Item 

 Select the invoice item you want to edit from the items list in Block-C. 

 Press "Delete" button. 

 A confirmation dialog will be shown. 
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Press “Yes” if you really want to delete the Invoice item. 
 

Search an Issue Voucher (Push) 

 Press  tab for expanding Receive Invoices Form and to find a specific Invoice 

 
 

 To search go to row 
header just writing Invoice no. and following window will appear: 
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 Enter the invoice no you want to find in "Invoice No." box. 

 Press <Enter> from keyboard to start searching. 

 If the Invoice is found then it will be shown selected. 
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Preview Issue Voucher (Push) 

 Press button to preview the invoice. The following dialog will come. 

 
 

 Press Show button then the following screen will appeared 

 
 

Print Issue Voucher (Push) 

 Press button to preview the invoice. The following dialog will come. 

 
 If you want to print the full set of invoice, press on the Print button. 

 To reprint or preview only a single copy from any of the 1-5 copies, select one of the other 
option buttons, then press Print button. 
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Close Issue Voucher (Push) Form 

 Press button to exit from the Issue Voucher (Push) form. 

 You can also exit by pressing the  button at the top right of the form. 

 If you have unsaved invoice during exit, you will be informed that your changes will be lost if 
you exit. 

 Press "Yes" if you do want to exit without saving. Press "No", if you don’t want to close the 
form at this time. 
 

5.4. Issue Voucher (Indent) 

 
This form is used to issue items based on indent received from facilities. Item quantities issued 
through this invoice are deducted from the total stock. This form is used to enter new Issue 
Voucher (Indent) or after downloaded indent from facility, edit, and print or delete old invoices. 

 Run WIMSv4 

 Select Invoice > Issue Voucher (Indent)… from Invoice menu. 

 The Issue Voucher (Indent) form is displayed. 
  



WIMSv4 User’s Guide 

Page 82 of 206 
 

General Description of Issue Voucher (Indent) Form 

 
 
This form is used to edit, create, delete, and print Issue Voucher (Indent)s. Controls in the form are 
grouped into 4 (four) blocks – 
A. Invoice List:  

Invoices can be listed grouped by Invoice No., Indentor or Invoice Date. A label shows the 
total number. 
 

B. Invoice Entry Fields:  
To describe an invoice, following fields are required. 

 Invoice No* – A unique sequence to represent the invoice. 

 Indentor* – Facility requesting the items. 

 Indent No* – Indent no. of the facility. 

 Prepared By, Designation & Date – Name, designation and preparation date of the indent. 

 Approved By, Designation & Date – Name, designation and approval date of indent. 

 Prepared By, Approved By, Supplied By* – Name of employees who are responsible for issue 
of items. There are three date fields related to the names. 

 Prepared By Date, Approved By Date, Supplied By Date* – Dates in which invoice 
preparation, approval and supply are made. 

 Remarks – Any comments about the supply. 

 Carrier name – Driver/ Representative name. 
 Invoice No, Indentor, Indent No., Prepared By, Approved By, Supplied by and their related date 
 fields are compulsory (*). 
 
C. Invoice Items Entry Fields:  

Invoices consist of line items. There is one line for every item issued. Every line has the 
following eight fields: 

 Item* – Name of item requested. 

 Unit – Unit of measurement of item. 

 Stock Qty – Current stock quantity in issuing facility. 

 

 

 

        A 

 

                               B 

 

                               

                                C 

                                 D        E 
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 Indent Qty* – Quantity of item requested. 

 Issued Qty* – Quantity issued to facility. 

 Lot No – Lot no. of the item issued 

 Mfg. Date – Manufacturing date of the item lot issued 

 Expiry Date – Expiry date of goods in the lot. 
Item, Indent Qty and Issued Qty fields are compulsory. Unit, Stock Qty, Lot No, Mfg. Date and 
Expiry date are automatically picked from item’s lot information. 
 

D. Command Buttons:  
A number of buttons to manipulate the Invoices. 
 

E. Download Invoice Button: Download Indent which has created from warehouse/Upazila. 
 

View information about a specific Invoice 

 
 

Select the Invoice to view from the tree-like list in Block-A. Using the List of Invoice. Invoices can be 
grouped in three ways – by Invoice No, Indentor or by Invoice Date. 

 After an Invoice no. is selected – corresponding information is show in Block-B and C. 
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 At any time a partial list of invoices are shown based on the Filter Criteria. Only Invoices that fall 
between Start Date and End Date are listed. You can change the dates and press "Filter" button 
to list less or more invoice. 
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Download an Indent Invoice 

 Press  button from the command buttons block. The form will look like 
this: 

 
 

 Select a (Warehouse/Upazila) and enter the Indent No. like following screen - 
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 Press on ‘Download’ button. After pressing the receive voucher will be downloaded. Like 
following screen - 

 
 Now you can check and update the downloaded invoice. 

 
Enter a new Invoice 

 Press  button from the command buttons block and the following screen will come: 

 
 

 The Invoice No. will be generated automatically. 

 Date fields will be filled with current date. You can change if necessary. 

 Provide the Indentor name and Indent No. 

 Select the Employee name who is preparing, approving and supplying the goods. 

 Optionally you can provide other fields. 
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 Press  button to save the Invoice header. 

 Your new Invoice no. will be visible in the Invoice list. 

 
 If you want to cancel the new Invoice entry, press Esc during editing to undo. 
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Invoice Items Entry 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 

 Select an Item name from Item combo box. 

 Unit field will be filled automatically. 

 Enter Indent Qty and Issued Qty. 

 The Stock Qty, Lot No, Mfg Date and Expiry Date will be picked from the lot information, if 
available. 

 
 

 Press <Enter> to save Invoice line items. 
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Updating the Stock 
Entry of a new Invoice does not update current stock position automatically. After the Invoice entry 
is complete, press "Update" button to recalculate the balance of items from the current invoice. 
Note: After the invoice figures are updated to stock, the invoice will be locked– you will not be allowed to 
change any figure. 

 Press "Update" button. 

 A confirmation dialog will appear. 
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 Press “Yes” if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of items for which stock was updated. 
 

Edit an existing Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press Save. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an existing Invoice 

 Select the invoice you want to remove from invoices list. 

 Press "Delete" button. 

 A confirmation dialog will be shown. 

 
 Press “Yes” if you really want to delete the Invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 
 

Edit an existing Invoice Item 

 
 Select the Invoice Item you want to edit from the items list in Block-C. 
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 Press F2 or click on any field to start editing. 

 
 When done with editing, press ‘Save’. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes. 
 

Delete an Invoice Item 

 Select the invoice item you want to edit from the items list in Block-C. 

 Press ‘Delete’ button. 

 A confirmation dialog will be shown. 

 
 Press ‘Yes’ if you really want to delete the Invoice item. 

 
Search an Issue Voucher (Indent) 

 Press  tab for expanding Receive Invoices form and to find a specific Invoice 
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 To search go to filter row 
header just writing Invoice no. and following window will appear: 

 
 Enter the Invoice no you want to find in ‘Indent Invoice No.’ box. 

 Press ‘Enter’ button or while start writing words the system automatically start searching. 

 If the Invoice is found then it will be shown selected. 

               
 

Print Issue Voucher (Indent) 

 Press button to preview the Invoice. The following dialog will come. 

 If you want to print the full set of invoice, press on the Print button. 

 To reprint or preview only a single copy from any of the 1-5 copies, select one of the other 
option buttons, then press Print button. 
 

Close Issue Voucher (Indent) form 

 Press button to exit from the Issue Voucher (Indent) form. 

 You can also exit by pressing the button at the top right of the form. 

 If you have any unsaved invoice during exit, you will be informed that your changes will be lost 
if you exit. 

 Press ‘Yes’ if you do want to exit without saving. Press ‘No’, if you don’t want to close the form 
at this time. 
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5.5. Gate Pass 
This form is used to prepare ‘Gate Pass’ for Invoices. 

 
 

Open Gate Pass Form 

 Run WIMSv4 

 Select Invoice > Gate Pass… from Invoice menu. 

 The Gate Pass form is displayed. 

 
 

This form is used to edit, create, delete, and print Gate Passes. Controls in the form are grouped 
into 4 (four) blocks – 
 
A. Gate Pass List:  
Invoices can be listed grouped by Gate Pass No., Gate Pass Date. A label shows the total number. 

 

 

 

          A 

 

                                                           B 
 

                                                           C 

                                                            D 
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B. Gate Pass Entry Fields:  
To describe a Gate Pass, following fields are required - 

 Gate Pass No* – A unique sequence to represent the Gate Pass. 

 Date* – Date of issuing gate pass. 

 Driver Name & Vehicle No – Name of Driver and Vehicle used to deliver the goods in the Gate 
Pass. 

 Prepared By, Approved By* – Name of employees who are responsible for issuing of Gate Pass. 
Gate Pass No, Date, Prepared By and Approved By fields are compulsory. 

 
C. Gate Pass Items Entry Fields:  
There is one line for every Gate Pass Item. Every line has the following three fields: 

 Type* – Two possible values –PUSH & INDENT – based on the type of invoice. 

 Invoice No* – An invoice no. linked to the gate pass. 
All the fields are compulsory. 

 
D. Command buttons:  
A number of buttons to manipulate the Invoices. 
 
View information about a specific a Gate Pass 

 
 

 Select the gate pass to view from the tree-like list in Block-A. Using the Group By combo box – 
gate passes can be grouped in three ways – by Gate pass No or by Gate pass Date. 

 After a Gate Pass No. is selected – corresponding information is shown in Block-B and C. 

 At any time a partial list of Gate Passes are shown based on the Filter Criteria. 
 
Only Gate Passes that fall between Start Date and End Date are listed. You can change the dates 
and press "Filter" button to list less or more Gate Pass. 
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Enter a new Gate Pass 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 The ‘Select Invoice’ form is displayed. 

 Select the invoices that you want to deliver and press Select button. 

 A new gate pass will be created where the “Gate Pass No.” and Date will be generated 
automatically. 

 The gate pass items Block-C will be filled with the selected invoice numbers.  

 Optionally provide other fields. 
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 Press  button. 

 Your new “Gate Pass No.” will be visible in the gate pass list. 

 
  



WIMSv4 User’s Guide 

Page 97 of 206 
 

Gate Pass Items Entry 

 
 

 Press  button from the command buttons block. 

 The ‘Select Invoice’ form is displayed 

 Select the invoices that you want to deliver and press ‘Select button’. 
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Edit an existing Gate Pass 

 Select the Gate Pass you want to edit from the list of Gate Pass. 

 Change the fields as necessary. 

 When done with editing, press ‘Save’. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes. 
 

Delete an existing Gate Pass 

 Select the Gate Pass you want to remove from gate pass list. 

 Press  button. 

 A confirmation dialog will be shown. 

 
 Press ‘Yes’ if you really want to delete the gate pass. 

 You will not be able to delete a gate pass that has items under it. First delete the items and 
then delete the gate pass. 
 

Delete a Gate Pass Item 

 Select the Gate Pass item you want to edit from the items list in Block-C. 

  Press  button. 
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 Press ‘Yes’ if you really want to delete the gate pass item. 

 
Search a Gate Pass 

 Press  tab for expanding Receive Invoices form and to find a gate pass  

 
 

 
 Enter the gate pass no you want to find in ‘Gate pass No.’ box. 

 Enter the Gate Pass No. you want to find  

in filter row header just  
writing Gate Pass no. and following window will appear: 
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 If the Gate Pass is found then it will be shown selected. 

 
 
Print Gate Pass 
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5.6. Adjustment Invoice 

 
This form is used for various stock adjustments, like – adjustment after physical stock, item expiry, 
destruction of expired items and return from facility. This form is used to enter Adjustment 
Invoices, edit, print and delete old invoices. 
 
Open Adjustment Invoice form 

 Run WIMSv4 

 Select Invoice > Adjustment Invoice… from Invoice menu. 

 The Adjustment Invoice form is displayed. 
 
General Description of Adjustment Invoice Form 

 
 

 

 

 

          A 

 

                                                           B 

 

                                                           C 

                                                            D 
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This form is used to edit, create, delete, and print Adjustment Invoices. The form are grouped into 4 
(four) blocks – 
A. Invoice List:  

Invoices can be listed grouped by Invoice No., Adjustment Type or Invoice Date. A label shows 
the total number. 
 

B. Invoice Entry Fields:  
To describe an invoice, following fields are required. 

 Invoice No* – A unique sequence to represent the invoice. 

 Facility* – Facility dealing the items. 

  Adjustment Type* – a list of adjustment types to select from. Possible adjustment types are: 
1. Add to Stock: If after physical inventory or any instance, it is found that an item is shown 

less than actual qty in stock 
2. Deduct from Stock: If after physical inventory or any instance, it is found that an item is 

shown excess than actual qty in stock 
3. Return from Facility (Usable): When an usable item is returned from a facility 
4. Return from Facility (Unusable): When an unusable item is returned from a facility 
5. Transfer to Unusable: Expired or Damage items transfer to Usable to Unusable Stock 
6. Unusable Destroy: Expired items are destroyed 
7. Return to Supply Source: When item is returned to Supply Source 
8. Transfer to Other Warehouses: When an item is transferred to Other Warehouses 
9. Return to supplier: When item is returned to a supplier 

 Remarks – Comments about the adjustment reasons, outcome etc. 

 Prepared By, Approved By and Supplied By* – Name of employees who are responsible for 
adjustment of items. 

 Prepared by Date, Approved by Date and Issued by Date* – Relevant dates of the preparation, 
approval and issue of adjustment invoice. 

Invoice No, Adjustment Type, Facility, Prepared By, Approved By and their related date fields are 
compulsory. 
 
C. Invoice Items Entry Fields:  
Invoices consist of line items. There is one line for every item received. Every line has the following 
seven fields: 

 Item* – Name of item adjusted. 

 Unit – unit of measurement of item. 

 Stock Qty – Current stock quantity in facility performing the adjustment. 

 Qty* – Quantity of goods adjusted. 

 Lot No – Lot no. of the item adjusted. 

 Mfg. Date – Manufacturing date of the item lot adjusted. 

 Expiry Date – Expiry date of goods in the lot. 
Item and Qty fields are compulsory. Other fields are optional. 
 
D. Command buttons:  
A number of buttons to manipulate the Invoices. 
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View information about a specific Adjustment Invoice 

 
 

 Select the invoice to view from the tree-like list in block A. Using the Group By combo box – 
invoices can be grouped in three ways – by Invoice No, Adj. Type or by Invoice Date. 

 After an invoice no. is selected – corresponding information is shown in Block-B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press "Filter" button 
to list less or more invoice. 
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Enter a new Adjustment Invoice 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 The Invoice No. will be generated automatically. 

 Date fields will be filled with current date. You can change if necessary. 

 Select any Adjustment Type from list. 

 If available, select the Facility. 

 Select the name of employees preparing and approving the invoice. Also mention preparation 
and approval dates. 

 
 

 Press  button. 

 Your new Invoice no. will be visible in the Invoice list. 
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 If you want to cancel the new invoice entry, press Esc during editing to undo. 
 
Adjustment Invoice Items Entry 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 Select an item name from Item combo box. 

 Unit field will be filled automatically. 

 Enter Qty. 

 Unit and Stock Qty will be filled in automatically. 

 The Lot No., Mfg. Date and Expiry Date fields may be available for editing. If available fill up 
these fields if necessary. 
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 Press <Enter> button to save Adjustment line items. 

 
 
Updating the Stock 
Entry of a new invoice does not update current stock position automatically. After the invoice entry 
is complete, press "Update" button to recalculate the balance of items from the current invoice. 
Note: After the invoice figures are updated to stock, the invoice will be locked – you will not be allowed to 
change any figure. 
 

 Press "Update" button. 

 A confirmation dialog will appear. 
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 Press ‘Yes’ if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of items for which stock was updated. 
 

Edit an existing Adjustment Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press Save. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes. 
 

Edit an existing Adjustment Invoice Item 
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 Select the Adjustment Invoice item you want to edit from the items list in Block-C. 

 
 Press F2 or click on any field to start editing. 

 Change the fields as necessary. 

 When done with editing, press Save. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes. 
 

Delete an existing Adjustment Invoice 

 Select the invoice you want to remove from invoices list. 

 Press ‘Delete’ button. 

 A confirmation dialog will be shown. 
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 Press ‘Yes’ if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 
 

Delete an Adjustment Invoice Item 

 Select the invoice item you want to edit from the items list in Block-C. 

 Press ‘Delete’ button. 

 A confirmation dialog will be shown. 

 
 

 Press ‘Yes’ if you really want to delete the Adjustment Invoice item. 
 

Search an Adjustment Invoice 

 Press  tab for expanding Receive Invoices form and to find an Adjustment Invoice  
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 Enter the Invoice no. you want to find in ‘Adj. Invoice No, date, adj. type’ in search box 

filter row header just  
writing Invoice no. and following window will appear: 

 If the Invoice is found then it will be shown selected. 

 
 
Print Adjustment Invoice 

 Press button to preview the invoice. 

 Press on the printer icon. The print dialog box will appear. 
 

5.7. Indent 
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This form is used for various product indent, like – indent before physical stock items not in available in 
warehouses stock. This form is used to enter Indent Invoices, edit, update and print or delete not 
updated invoice invoices. 
 
Open Indent Form 

 Run WIMSv4 

 Select Invoice > Indent… from Invoice menu. 

 The Indent form is displayed. 
 

General Description of Indent Form 

 
 
This form is used to edit, create, delete, and print Adjustment Invoices. The form are grouped into 4 
(four) blocks – 
 
A. Invoice List:  

Invoices can be listed grouped by  

 Invoice No. 

 Invoice Date. 

 Prepared By 
 

B. Invoice Entry Fields:  
To describe an invoice, following fields are required. 

 Indent No* – A unique sequence to represent the invoice. 

 Warehouse*– Select a warehouse which will send to indent. 

 Prepared By* and Approved By*– Name of employees who are responsible for indent of items. 

 Prepared By Designation* and Approved By Designation*– Relevant designation of the 
preparation, approval and issue of indent. 

 Prepared by Date and Approved by Date– Relevant dates of the preparation, approval and issue 
of indent. 

 Remarks – Comments about the adjustment reasons, outcome etc. 

 

 

 

          A 

 

                                                           B 

 

                                                           C 

                                                            D 
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 Update - Check box to update an Invoice which filled automatically. 

 Cancel - Check box to cancel any Invoice. 
 

C. Invoice Items Entry Fields:  
Invoices consist of line items. There is one line for every item received. Every line has the following 
fields: 

 Item* – Name of item adjusted. 

 Stock Qty – Current stock quantity in facility. 

 Indent Qty* – Quantity of goods indent. 

 Unit – unit of measurement of item. 
 
D. Command buttons:  
A number of buttons to manipulate the Invoices. 

 
View information about a specific Indent Invoice 

 
 

 Select the indent to view from the tree list in Block A. Using the Group By combo box – invoices 
can be grouped in four ways – Invoice No, Invoice Date, and Indent Prepared by. 

 After an Invoice no. is selected – corresponding information is shown in Block B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press "Filter" button 
to list less or more invoice. 
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Enter a new Indent 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 The indent No. will be generated automatically. 

 Warehouse automatically selected which supply to you. 

 Select the name of employees preparing and approving the indent. Also mention preparation 
approval and issued dates. 

 Select designation of prepared by and approve by. 

 Date fields will be filled with current date. You can change if necessary. 
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 Press  button. 

 Your new Invoice no. will be visible in the Invoice list. 

 
 If you want to cancel the new invoice entry, press ‘Esc’ during editing to undo. 
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Indent Items Entry 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 

 Select an item from Item Name combo box. 

 Unit and Stock Qty will be filled in automatically. 

 Enter ‘Indent Qty’. 

 
 

 Press <Enter> button to save indent line items. 
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Updating  
Entry of a new invoice does not upload to web automatically. After the invoice entry is complete, press 
"Update" button to upload to SCMBD for warehouse download in available internet. 
Note: After the invoice figures are updated, the invoice will be locked – you will not be allowed to change any 
figure. 

 Press "Update" button. 

 A confirmation dialog will appear. 

  
 Press ‘Yes’ if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of items for which stock was updated. 

 
Press on ‘OK’ 
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Edit an existing indent  

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press ‘Save’ button. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes. 
 

Edit an existing Indent Item 

 
 Select the Indent item you want to edit from the items list in Block C. 
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 Press F2 or click on any field to start editing. 

 Change the fields as necessary. 

 When done with editing, press ‘Save’ button. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes. 
 

Delete an existing Indent 

 Select the invoice you want to remove from invoices list. 

 Press ‘Delete’ button. 

 A confirmation dialog will be shown. 

  
 Press ‘Yes’ if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 
 

Delete an Indent Item 

 Select the invoice item you want to edit from the items list in Block-C. 

 Press ‘Delete’ button. 

 A confirmation dialog will be shown. 
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 Press ‘Yes’ if you really want to delete the Adjustment Invoice item. 
 

Search an Indent Invoice 

 Press  tab for expanding Receive Invoices form and to find an indent Invoice  

 
 

 Enter the Invoice no. you want to find in Invoice No, date, in search box  

 filter row header just  
writing Invoice no. and following window will appear: 

 If the Invoice is found then it will be shown selected. 
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Print Indent  

 Press  button to preview the invoice. 

 Press on the printer icon. The print dialog box will appear. 
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5.8. Provisional Receive 

 
 

This form is used for Provisional receive in available contracted with supplier in SCMP. This form is used 
to enter provisional receive Invoices, edit, update and print or delete not updated invoice invoices. 
 
Open Provisional Receive Invoice Form 

 Run WIMSv4 

 Select Invoice > Provisional Receive… from Invoice menu. 

 The Provisional Receive form is displayed. 
 

General Description of Provisional Receive Form 
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This form is used to edit, create, delete, and print Adjustment Invoices. The form are grouped into 4 
(four) blocks – 
 
A. Invoice List:  

Invoices can be listed grouped by  

 Invoice No. 

 Entry Date. 

 Receive By. 
 

B. Invoice Entry Fields: To record an Invoice, 8 (eight) fields are required as follows: 

 Invoice No* – A unique sequence to represent the invoice. 

 Entry Date* – Date of receipt of goods. 

 Received By* – Name of receiving officer. 

 Supplier* – Name of supplier. 

 Procured By –Name of procuring entity  

 Year –Package contract year. 

 Contract No –Package contract number. 

 Package No –selected contact package. 
All of the above fields are mandatory. 

 
C. Invoice Items Entry Fields: Invoices consist of line items. There is one line for each item received 
and has the following 8 (eight) fields: 

 Sup Inv No* – Voucher No. of supplier. 

 Sup Date* – Date of supplier voucher. 

 Receive Date* – Date of receipt of goods. 

 Item Name* – Name of item received. 

 Contract Qty – Name of item received. 

 Provisional Qty* – Total quantity of good provisional received. 

 Unit – Unit of measurement of item. 

 Lot No – Lot no. of the received goods. 

 Mfg. Date – Manufacturing date of the received goods. 

 Expiry Date – date of expiry of the received goods. 
 Sup Inv No, Sup Date, Receive Date, Item name, Contract Qty, and Received Qty are 
mandatory. Unit field is shown automatically. Other fields are optional. 
 

D. Command buttons: A number of buttons to manipulate the Invoices. 
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View information about a specific Indent Invoice 

 
 

 Select the Provision Invoice to view from the tree list in Block A. Using the Group– invoices can 
be grouped in four ways – Invoice No, Entry Date, and Receive by. 

 After an Invoice no. is selected – corresponding information is shown in Block B and C. 

 At any time a partial list of invoices are shown based on the ‘Filter Criteria’. Only invoices that 
fall between ‘Start Date’ and ‘End Date’ are listed. You can change the dates and press ‘Filter’ 
button to list less or more invoice. 
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Enter a new Provisional Receive Invoice 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 

 The Provisional Receive “Invoice No.” will be generated automatically. 

 Select a Supplier from “Suppliers” combo who supply to you. 

 Automatically selected the name of employee “Received By” the Provisional Receive. Also 
mention “Entry Date”. 

 Select Procured by, Year and Contract No. after selecting contract no the package no will be 
selected automatically. 

 Date fields will be filled with current date. You can change if necessary. 
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 Press  button. 

 Your new Invoice no. will be visible in the Invoice list like following screen - 

 
 If you want to cancel the new invoice entry, press ‘Esc’ during editing to undo. 

 
Provisional Receive Items Entry 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 

 Enter Supplier Invoice No in ‘Sup Inv’ column. 

 Enter supplied date in ‘Sup Date’ column. 

 Enter receive date in ‘Receive Date’ column 

 Select an item from Item Name combo box. Like above screen. 

 After selecting Item In contract quantity column data displayed automatically. 
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 Enter Provisional Qty. 

 Unit and Stock Qty. will be filled in automatically. 

 Enter Lot/Description 

 Enter Manufacture date 

 Enter Expire date.  

 
 

 Press <Enter> button to save provisional receive items. 

 
 

Edit an existing Provisional Receive Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press ‘Save’ button. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes.  
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Edit an existing Provisional Receive Item 

 
 

 Select the provisional receive item you want to edit from the items list in Block C. 

 
 

 Click on any field to start editing. 

 Change the fields as necessary. 

 When done with editing, press ‘Save’ button. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes. 
 

Delete an existing Provisional Receive 

 Select the invoice you want to remove from invoices list. 

 Press "Delete" button. 

 A confirmation dialog will be shown. 
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 Press ‘Yes’ if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 
 

Delete an Provisional Receive Invoice Item 

 Select the invoice item you want to edit from the items list in Block-C. 

 Press ‘Delete’ button. 

 A confirmation dialog will be shown. 

  
 

 Press ‘Yes’ if you really want to delete the provisional receive invoice item. 
 

Search a Provisional Receive Invoice 

 Press  tab for expanding Receive Invoices form and to find an invoice  
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 Enter the Invoice no. you want to find in Invoice no, date, in search box  

 Filter row header just 
writing Invoice no. and following window will appear: 
 

 If the Invoice is found then it will be shown selected. 

 
 

Print Provisional Receive Invoice 

 Press  button to preview the invoice. 

 Press on the printer icon and the print dialog box will appear. 
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5.9. Standing Board 

 
 

This form is used for Standing Board approval of a provisional receipt stock available in provisional 
receive list in WIMS. This form is used to enter stock from provisional receive, before generate receive 
invoice you can update approve/disapprove quantity, update and print or delete not updated invoice 
invoices. 
 
Open Standing Board Form 

 Run WIMSv4 

 Select Invoice > Standing Board… from Invoice menu. 

 The Standing Board form is displayed. 
 

General Description of Standing Board Form 
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   C 
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This form is used to Approve/Disapprove stock from provisional receive. The form are grouped into 
4 (Four) blocks – 
 
A. Standing Board information:  

Standing Board has the following information - 

 Meeting Date 

 Year 

 Package No 

 Contract No 
 

B. Approve product list: Approve product list consist of line items. There is one line for each item 
approve and has the following 6 (six) fields: 

 Item Name* – Name of product form provisional receive. 

 Provisional Receive Qty* – Quantity provisional receipt of goods. 

 Approve Qty* – Approved quantity from provisional received. 

 Lot No – Lot no. of the received goods. 

 Mfg. Date – Manufacturing date of the received goods. 

 Expiry Date – Date of expiry of the received goods. 
 

C. Disapprove product list: Disapprove product list consist of line items. There is one line for each 
item disapprove and has the following 6 (six) fields: 

 Item Name* – Name of product form provisional receive. 

 Provisional Receive Qty* – Quantity provisional receipt of goods. 

 Disapprove Qty* – Product disapprove quantity from provisional receive. 

 Lot No – Lot no. of the received goods. 

 Mfg. Date – Manufacturing date of the received goods. 

 Expiry Date – Date of expiry of the received goods. 
 

 D. Generate Received Invoice: A number of buttons to generate receive Invoice. And disapprove 
for return to supplier. 
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View information about a specific Standing Board. 

 
 
Create a new Standing Board 

 
 

 Enter meeting date to entering Standing Board. 

 Select Contract No. after selecting contract no, the package no will select automatically. 

 Press ‘Select Approved Item’ button to entering selected contact items with quantity for 
Approving items like following screen - 
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 Press ‘Select Disapproved Item’ button to entering selected contact items with quantity for 
disapproving items like following screen - 
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 After selected approved and disapproved button will see the following screen - 

 
 
Now press on ‘Generate Receive button’ after pressing see the following pop-up message -

 
 
Press ‘Yes’ after pressing the receive invoice will be generated with standing board approved 
quantity and disapproved quantity waiting for return to the supplier from provisional receive. 
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5.10. Return to the Supplier from Provisional Receive 

 
 

This form is used for return to the supplier from provisional receive in, like – standing board 
disapproved product. This form is used to enter return to the supplier from provisional receive invoice 
Invoices, edit and print or delete invoices. 
 
Open Indent Form 

 Run WIMSv4 

 Select Invoice > Return to the Supplier from Provisional Receive … from Invoice menu. 

 The Return to the Supplier from Provisional Receive form is displayed. 
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General Description of Indent Form 

 
 
This form is used to entry, edit, delete, and print Return to the Supplier from Provisional Receive 
Invoices. The form are grouped into 4 (four) blocks – 
 
A. Invoice List:  

Invoices can be listed grouped by  

 Invoice No. 

 Invoice Date. 

 Returned By 
 

B. Invoice Entry Fields:  
To describe an invoice, following fields are required. 

 Invoice No* – A unique sequence to represent the invoice. 

 Supplier* – Select supplier who receive return items in this contact. 

 Year – select the package contract Year 

 Prepared By, Approved By, Supplied By* – Name of employees who are responsible for issue 
of items. There are three date fields related to the names. 

 Prepared By Date, Approved By Date, Supplied By Date* – Dates in which invoice 
preparation, approval and supply are made. 

 Contract No* – select the contract no  

 Remarks – Any comments about the supply. 
 Invoice No, Supplier, Prepared by, Approved by, Issued by and their related date fields are 
 compulsory. 
 
C. Invoice Items Entry Fields:  

 Sup Inv No* – Voucher No. of supplier. 

 Sup Date* – Date of supplier voucher. 

 Return Date* – Date of receipt of goods. 

 Item Name* – Name of item received. 
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 Returnable Qty – Name of item received. 

 Return Qty* – Total quantity of good provisional received. 

 Unit – Unit of measurement of item. 

 Lot No – Lot no. of the received goods. 

 Mfg. Date – Manufacturing date of the received goods. 

 Expiry Date – date of expiry of the received goods. 
 Sup Inv No, Sup Date, Return Date, Item name, Returnable Qty, and Return Qty are mandatory. 
Unit field is shown automatically. Other fields are optional. 
 

D. Command buttons: A number of buttons to manipulate the Invoices. 
 
View information about a specific Issue Invoice: 

 Select the invoice to view from the tree-like list in block A. Using the Group– invoices can be 
grouped in three ways – by Invoice No, Return Date or Return By. 

 After an invoice no. is selected – corresponding information is shown in block B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press ‘Filter’ button 
to list less or more invoice. 

 
View information about a specific Return to the Supplier from Provisional Receive Invoice 

 
 

 Select the Invoice to view from the tree list in Block A. Using the Group By– invoices can be 
grouped in four ways – Invoice No, Return Date, and Return by. 

 After an Invoice no. is selected – corresponding information is shown in Block B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press "Filter" button 
to list less or more invoice. 
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Enter a new return to the Supplier from Provisional Receive 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 The Invoice No. will be generated automatically. 

 Select supplier which supply to you against contract. 

 Automatically selected the employee names who is preparing, approving and issuing the goods. 
you can change preparing, approving and Issuing  

 Date fields will be filled with current date. You can change if necessary. 

 Select Package contract year. 

 Select contract no which contact item you return to the supplier from provisional receive. 
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 Press  button. 

 Your new Invoice no. will be visible in the Invoice list. 

 
 If you want to cancel the new invoice entry, press Esc during editing to undo. 
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Return to the Supplier from Provisional Receive Items Entry 

 Press  button from the B block. The form will look like the following 
screen: 

 
 

 Select an item from Item Name from list 

 Items all information will be filled in automatically. 

 Change Return Qty If need. 

 
 
Edit an existing Return to the Supplier from Provisional Receive Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press ‘Save’ button. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes. 
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Edit an existing Return to the Supplier from Provisional Receive Invoice Item 

 
 

 Select the item you want to edit from the items list in Block C. 

 
 

 Press F2 or click on any field to start editing. 

 Change the fields as necessary. 

 When done with editing, press ‘Save’ button. 

 If you want to cancel the current editing, press ‘Esc’ to undo the changes. 
 

Delete an existing Return to the Supplier from Provisional Receive 

 Select the invoice you want to remove from invoices list. 

 Press ‘Delete’ button. 

 A confirmation dialog will be shown. 
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 Press ‘Yes’ if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 
 

Delete a Return to the Supplier from Provisional Receive Invoice Item 

 Select the invoice item you want to edit from the items list in Block-C. 

 Press "Delete" button. 

 A confirmation dialog will be shown. 

  
 

 Press ‘Yes’ if you really want to delete the Adjustment Invoice item. 
 

Search a Return to the Supplier from Provisional Receive Invoice 

 Press  tab for expanding Receive Invoices form and to find an indent Invoice  
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 Enter the Invoice no. you want to find in ‘ Invoice No, date, in search box  

 Filter row header just 
writing Invoice no. and following window will appear: 

 If the Invoice is found then it will be shown selected. 

 
 
Print Return to the Supplier from Provisional Receive Invoice  

 Press  button to preview the invoice. 

 Press on the printer icon. The print dialog box will appear. 
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Chapter-6: Stock 
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6.1. Supply Plan 
Based on the inputs given by various Upazilas, a Supply Plan will be generated automatically by 
using this module. 

 
 

Open Supply Plan 

 Run WIMSv4 

 Select Stock > Supply Plan… from Stock menu. 

 The Supply Plan screen is displayed. 
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General Description of Supply Plan Form 
The form is grouped into 5 (five) blocks – 
A. List of Months:  

Shows the months for which Supply Plan will be generated. 
 

B. Supply Plan Entry Option: 
Shows options for selecting "Month" and "Year" for which Supply Plan will be generated. 
 

C. Details of Facilities:  
Details of facility (Upazila) i.e. how much they have distributed last month, their closing balance, 
what should be the allotted quantity, etc. will be shown here. 
 

D. Commodity Selection & Rationing:  

 Normally Supply Plan is done at the start of every month to calculate issue quantity.  

 This block contains the items which are normally issued based on Supply Plan –  
1. Condom (pcs),  
2. Shukhi (cycles), 
3. IUD CT-380A (pcs), 
4. Injectables (vials), 
5. AD Syringe (1ML), 
6. Implant (nos), 
7. DDS Kit 

 Under every item tab, total planned quantity and current stock quantity of the current date 
of current month is shown.  

 When the plan quantity is less than or equal to current stock quantity – the Supply Quantity 
box is GREEN. When the supply quantity is more than stock quantity, it shows as RED.  

 There are 4 (four) boxes below every item.  

 When there is scarcity of items, then putting a certain percentage in any box – then pressing 
the "Recalculate" button will reduce that item’s Actual Supply Quantity for all upazilas. 
 

E. Command Buttons:  
A number of buttons to manipulate the Supply Plan. 
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Generate a new Supply Plan 

Press  button from the command buttons block. The form will look like the following 
screen: 

 
 The ID will be generated automatically. 

 Select the ‘Month’ and ‘Year’ for which Supply Plan will be generated. 
 

 Press button. The form will look like the following screen: 
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Generation of Supply Plan Details 

 Press  button from the command buttons block. A dialogue box will appear as like the 
following screen: 

 
 

Click ‘Yes’ to continue and the following form will appear. 

 All data will be generated and shown automatically. 

 
 

 Only ‘Actual Supply Quantity’ can be edited. 

 Enter the actual quantity which has been supplied to the Upazila. 

 As you go forward by pressing Tab button data will be saved automatically. 
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Preview and Print the Supply Plan 

 Press button to preview the supply plan which will be like the following screen - 

 
 Press on the printer icon. The print dialog box will appear. 

 
Generate Supply Plan to Issue Voucher 
After completing Supply Plan generation, need to generate Issue Voucher automatically from 
created Supply Plan.  

 Press  against Upazila 

 
 

 Press ‘Generate Issue Voucher’ button on Supply Plan. 



WIMSv4 User’s Guide 

Page 150 of 206 
 

 
 

 After pressing ‘Yes’ the message will show - 

 
 

 Press ‘OK’ 

 
 

 Then you will see the Voucher No. will be shown on ‘Supply Plan’ and voucher will be shown on 
‘Issue Voucher’ entry form. 

 From Supply Plan generated issue vouchers when these are updated the “Updated”status will 
also be shown on supply plan. 
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N.B: Updated upazila’s Issue voucher cannot be re-generated but Un-updated Upazila’s Issue voucher can 
be re-generated. 

 
6.2. Custom Supply Plan 

To access Custom Supply Plan follow the following steps- 

 Run WIMSv4 

 Select Stock > Custom Supply Plan from Stock menu. 

 The Custom Supply Plan form is displayed. 
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 To using custom supply plans for providing specific items to specific facility can be 
created Issue vouchers to supplying goods. 
 

Generate Custom Supply Plan 

 
 

 Select products from left side product list and press on “>>” button to creating Custom Supply 
Plan 

 
 

 Enter your custom supply plan profile name and press on ‘Save’ button. After pressing see the 
following screen - 
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 Enter the product quantity which will be issued against Facility’s 

 
 

  Press on ‘Next’ after pressing will see the following message. 
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 Press on ‘Yes’. After pressing custom supply plan products will saved and displaying following 
screen for select facility.  

 
 

 Select Facility from left side facility list and press on ‘>>’ button to transfer right side for 
creating custom supply plan. See the following screen - 

 
 

 Press on ‘Next’. After pressing will see the following message - 
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 Press on ‘Yes’. After pressing will see the following screen - 

 
 

 Press on ‘Next’. After pressing will see the following message - 

 
  



WIMSv4 User’s Guide 

Page 156 of 206 
 

 Press on ‘Yes’. After pressing message displayed ‘Issue voucher Generate successfully’ like 
following screen - 

 
 

 Press on ‘Ok’. After pressing generated issue voucher form will be displayed like following 
screen - 
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6.3. Stock Balance 
Stock Balance form presents the current status of stock items at any time. Initially the form shows 
stock balance of all the stock items up o current date. Stock balance of any date can be viewed by 
changing the Balance Date. 

 
 

View Stock Balance 

 Run WIMSv4 

 Select Stock > Stock Balance… from Stock menu. 

 The Stock Balance form is displayed. 

 
 

This form presents current stock position of all the items. Controls in the form are grouped into 3 
(three) blocks – 
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A. Item Group & Balance Date:  
Shows a list of current item groups in database. A label below shows the total number of items 
under the selected group. Balance Date is used to give a filter date for which stock position is 
shown. 
 
B. List of Items:  
Shows status of every item under the selected group. To describe an item, 5 (five) fields are 
required. 

 Item Code – Unique Item Code. 

 Item Name – Name of the item. 

 Usable Qty – Usable stock quantity of the item on balance data. 

 Unusable Qty – Unusable quantity of item on balance date. 

 Unit – Unit of measurement of the item. 
 
C. Command buttons:  
A number of buttons to manipulate the stock status. 
 
View Stock Balance of a specific Date 

 If you want to view stock status of all items, select ‘(All)’ from Item Group combo in block A. If 
you want to view a specific group, select the group name from the combo. 

 Initially Balance Date is filled with today’s date and stock status for that date is presented. 

 Type in the desired date in Balance Date field and press <Enter> to get the stock status of that 
date. 

 To exclude the items that are out of stock, select ‘Show Only Non-Zero Stock’. 
 

Search and find an Item 

 Type you provide the item name in search box. 

 Items which match with the search text will be shown in the list. 

 
 To see all of the items again, remove you provide the item name from search box. 
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View detail information about a specific item 

 Select the item for which you want to view lot-wise information. 

 Press Lot-wise button from the command button block 

 A dialog like the following screen will appear: 

 
 
 

 

Print Stock Balance 

 Press button to view a printable list of Stock Balance. 

 
 

 Press on the printer icon. The report will be print. 
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Chapter-7: Reports 
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7.1. Form 7B 
Based on the inputs given by various SDPs and items received and issued by the Upazila MIS Form 
7B will be generated automatically by this module. 

 Run WIMSv4 

 Select Report > Form 7B… from Report menu. 

 The Form 7B Screen is displayed. 

 
 

General Description of 7B Form 
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Controls in the form are grouped into 5 (five) blocks – 
A. List of Months:  

Shows the months for which Form 7B will be downloaded. 
 

B. Form 7B Entry Option:  
Shows options for selecting Month and Year for which Form 7B will be downloaded. 
 

C. Details of Items:  
Details of all 28 commodities i.e. Opening balance, how much have been received, issued and 
adjusted, Closing Balance, MOS, etc. will be shown here. 
 

D. Command buttons:  
A number of buttons to manipulate the Form 7B. 
 

E. download Form 7B:  
It’s a new feature. By connecting into internet Warehouse now can download their monthly 
Form7B report directly into LMIS web site. 
 

Download Form 7B from Web 

 
 

 Press ‘Download F7B’ button then the following screen will be appeared - 

 Select reported month and reported year 

 Then press ‘Download’ button. 
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 After pressing ‘Download’ see the following screen - 
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 After completing download F7B report see the following screen - 

 
 

Preview and Print the Form 7B 

 Select an upazila to view F7B report. 

 Press button to preview the supply plan which will be like the following screen: 

 
 

 If printer on then Press on the printer icon the select Upazila’s F7B report will print. 
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7.2. Form 7 
 Based on the inputs given by various Upazila and items received and issued by the Warehouse 

MIS Form 7 will be generated automatically by this module. 

 
 

Open Form 7 

 Run WIMSv4 

 Select Stock > Form 7… from Report menu.  

 The Form 7 Screen is displayed. 
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General description of Form 7  
Controls in the form are grouped into 5 (Five) blocks – 
A. List of Months: Shows the months for which Form 7 will be generated. 
 
B. Form 7 Entry Option: Shows options for selecting Month and Year for which Form 7 will be 
generated 
 
C. Details of Items: Details of all 28 commodities i.e. Opening balance, how much have been 
received, issued and adjusted, Closing Balance, MOS, etc. will be shown here 
 
D. Command Buttons: A number of buttons to manipulate the Form 7. 
 
E. Upload Form 7: By connecting to internet, Warehouse need to upload their monthly Form 7 
Report directly generated from WIMSV4 and uploaded automatically into LIMS website. 
 
Upload Form 7 

 
 After Generate form 7 then connect internet then Press Upload Form 7 button  

 Uploading complete then the message shows form 7 uploads successfully. 
 

Generate a new Form 7 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 Each option except ‘Month’ and ‘Year’ will be generated automatically. 

 Select the Month and Year for which ‘Form 7’ will be generated. 

 Press  button.  
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The form will look like the following screen: 

 
 
Generation of Form 7 Details 

 Press button from the command buttons block. A dialogue box will appear if Receive or Issue or 
adjustment voucher is not updated in the reported month  as like the following screen: 

 
 

 Press button from the command buttons block. A dialogue box will appear if all Receive or Issue 
or adjustment voucher is updated in the reported month  as like the following screen: 
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Click ‘Yes’ to continue and the following form will appear. Click ‘OK’. 

 
 

 All data will be generated automatically. 
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Preview and Print the Form 7 

 Press button to preview the supply plan which will be like the following screen:  

 
 

 If printer is on Press on the printer icon. The F7 report will print. 

 Optionally provide Print Range, Copies and press OK. If you want to print only one copy of the 
whole report, then just press OK. 

 After printing, press the leftmost  button to close the preview window. 
  



WIMSv4 User’s Guide 

Page 170 of 206 
 

Post LMIS Form 7 Report 

 After generating F7 Report correctly then press Post button. 
 NB. Before post F7 report check correctly. Posted F7 could not regenerate. 
 After pressing “Post” the following screen will appear: 

 
 

 Press ‘Yes’, After post the following screen will appeared: 
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 Press ‘OK’ and following window will appear: 

 
 

Upload LMIS Form 7 Report 

 After posting F7 then press "Upload Form 7" button. 

 
(Note: Make sure your computer have internet connected) 
 

Message shown (Do you really want to Upload form 7 Data to SCMP Report) 
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 Press ‘Yes’ button then after uploading look like following screen: 

 
 

 Press on ‘Ok’ then data upload and download start automatically. 
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 After uploaded F7 report want to update of F7 report need to press ‘Unpost’ button then you 
will update the F7 report data. 

 

7.3. Stock Reports 
The Stock Reports Form is used to view stock reports based on specific criteria. Both summary and 
detailed stock information can be viewed and printed. A typical view of the Form shown in below: 

 
 

The controls in the Stock Reports Form is grouped in 4 (four) blocks – 
A. Tab of Reports: Currently there are 10 (Ten) reports – first one is a summary report and others 

are transaction details. 
 
B. Filter Dates: Provide the date(s) which will be used to filter the report data. 
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C. Group/Item and Facility Criteria: A number of optional filter criteria that control the output of 
the report. 

 
D. Command Buttons: A Preview and Close button. 
 
How to Print a Report 

 Select a report from the "List of Reports" menu. 

 Provide date(s) in the "Filter Date(s)" block. 

 Optionally select options from "Group/Item and Facility Criteria" block. 

 Press button to preview the Invoice. 

 Press on the printer icon. The print dialog box will appear. 

 Optionally provide Print Range, Copies and press OK. If you want to print only one copy of 
the whole report, then just press OK. 

 After printing, press the leftmost  button to close the preview window. 
 

How to Export a Report 

 If you need to export select export format and press  button  

 After pressing windows dialog will be shown save the export document. 
 
7.3.1. Stock Summary 

This report shows the stock status at a certain date. To print the report follow the following steps: 

 Select 'Stock Summary' tab from ‘Stock Reports’ menu. 

 
The ‘Summary Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on button now, stock summary of all the items on current date will be printed. 

 If you want to know the stock status of a previous date, type in the date in ‘Summary Date’ box. 

 To print stock status of a specific group select the group from ’Item Group’ box. The form 
appear as follows: 



WIMSv4 User’s Guide 

Page 175 of 206 
 

 
 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button. 
 

7.3.2. Stock Summary by Lot 
This report shows the lot-wise stock status at a certain date. To print the report, follow the 
following steps:  

 Select ‘Stock Summary by Lot’ tab from ‘Stock Reports’ block. The form will look like the 
following screen: 
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 The ‘Summary Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ 

box. If you click on  button now, stock summary of all the items on current date will 
be printed. 

 If you want to know the stock status of a previous date, type in the date in ‘Summary Date’ box. 

 To print stock status of a specific group select the group from ’Item Group’ box. The form 
appear as follows: 

 
 

 Press button to continue. 

 

 If you need to export select export format and press  button. 



WIMSv4 User’s Guide 

Page 177 of 206 
 

7.3.3. Digital ICR 
This report shows the details transaction of items between specific dates. To print the report, 
follow the following steps: 

 Select ‘Digital ICR tab from ‘List of Reports’ block. The form will look like the following screen: 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on button now, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select Item Group, Item Name and the form appear as follows: 

 
 

 Press  button to continue. 

 

 If you need to export select export format and press  button. 
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7.3.4. Receive Report: 
This report shows the details of issued items by facility between the specific dates. To print the 
report, follow the steps - 

 Select ‘Stock Details by Facility’ option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on button now, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group and then an Item Name & Facility (optional).  

 The form have extra 3 (three) radio button 1) All, 2) National Receive and 3) Receive from 
Warehouse. Details are given below: 
 

All Receive: 
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National Receive: 

 
 

Receive From Warehouse: 

 
 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button. 
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7.3.5. Issue Details by Item 

 
This report shows the details of issued items by Item between the specific date ranges. To print the 
report, follow the steps - 

 Select ‘Stock Details by Item’ option in ‘List of Reports’ block.  

 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button now, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select Item Group, Item Name & Facility (all are optional). The form appear as follows: 

 
 

 Press  button to continue 

 

 If you need to export select export format and press  button. 
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7.3.6. Issue Details by Facility 

 
 

This report shows the details of issued items by facility between the specific dates. To print the 
report, follow the following steps:  

 Select ‘Stock Details by Facility’ option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button now, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group, Item Name & Facility (all are optional). The form appear as follows: 

 Press  button to continue. 
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7.3.7. Stock Expiry by Lot 

 
 

This report shows the details of Stock expiry by lot between specific dates. To print the report, 
follow the steps: 

 Select ‘Stock Expiry by Lot’ option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group and then an Item Name & Facility (Optional). The form may appear as 
follows: 

 Press  button to continue. 

 

 If you need to export select export format and press  button 
 



WIMSv4 User’s Guide 

Page 183 of 206 
 

7.3.8. Adjustments Report 

 
 

This report shows the details of stock adjustments report between specific dates. To print the 
report, follow the steps: 

 Select Group, Item and Adjustment Type or All 

 Select ‘Start Date’ option in ‘End Date’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group and then an Item Name and adjustment Type (Optional). The form may 
appear as follows: 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button 
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7.2.9. Stock Transaction by Lot 

 
 

This report shows the details of Stock Transaction by lot between specific dates. To print the report, 
follow the steps: 

 Select ‘Stock transaction by Lot’ option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group and then an Item Name & Lot No or Exp Date The form may appear as 
follows: 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button 
 



WIMSv4 User’s Guide 

Page 185 of 206 
 

7.2.10. Physical Inventory 

 
This report shows the details of Physical Inventory between specific dates. To print the report, 
follow the steps: 

 Select ‘Physical Inventory’ option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group. The form may appear as follows: 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button  
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7.4. Slow Moving Item list 
This report shows the details of Slow Moving item List specific dates. To print the report, follow the 
steps: 

 Select ‘Slow Moving item List’ option in ‘List of Reports’ block. The form will look like the 
following screen: 

 
 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button  
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7.5. Provisional Receive Register 
This report shows the details of Provisional Receive register. To print the report, follow the steps: 

 Select ‘Provisional Receive register’ option in ‘List of Reports’ block. The form will look like the 
following screen: 

 
 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button 
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7.6. Provisional Receive summary 
This report shows the details of Provisional receive summary specific dates. To print the report, 
follow the steps: 

 Select ‘Provisional receive summary’ option in ‘List of Reports’ block. The form will look like the 
following screen: 

 
 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button  
 
 
 
 
 
 
 
 
 
 
 



WIMSv4 User’s Guide 

Page 189 of 206 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Chapter-8: Administrator 
  



WIMSv4 User’s Guide 

Page 190 of 206 
 

8.1. Options 
 Run WIMSv4 

 Go to Administrator > Options from Administration menu 

 The Options form is displayed. 

 
 

 After pressing "Options" the following screen will be appeared: 

 
When an employee transfer or join in a store keeper/Supply officer who signatories in the 
WIMS software then you have to add his/her name in WIMS software. For this you need to 
update options for signatory assign. 

 
Update Options 

 The set of “Prepared By, Approved By & Issued By” of Issue Invoice are come from Options 
menu. When any of these three signatories will change you need to edit.  

 
 From the prelisted Employee list you have to select/edit the name for Prepared By, Approved 

By and Issued By if any change require.  
  

 If you need to cancel settings Press  button before save. 
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 After setting “Prepared By, Approved By & Issued By” and “Store type” then press  
button. 

 
 

 Press  button. 

 
8.2. Data Download 

 Run WIMSv4 

 Select Administrator > Data Download from Administrator menu. 

 The Data Download form is displayed. 

 
 After showing data download press "Start Data Download" button.  

(N.B. Make sure your computer have internet connected) 
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8.3. Data Upload 
 Run WIMSv4 

 Select Administrator > Data Upload from Administrator menu. 

 The Data Upload form is displayed. 

 
 After showing Data Upload press "Start Data Upload" button. 

(N.B. Make sure your computer have internet connected) 
 

8.4. Unit 
 Run WIMSv4 

 Select Administrator > Unit from Administrator menu. 

 The Unit form is displayed. 

 
This form is used to edit, create, delete, print Unit. The form are grouped into one blocks – 
View Fields: Unit Id and Unit 



WIMSv4 User’s Guide 

Page 193 of 206 
 

Print Unit List: 

 Press  button to view a printable list of Item Groups. 

 

 
8.5. Adjustment Type 

 Run WIMSv4 

 Select Administrator > Adjustment Type from Administrator menu. 

 The Adjustment Type form is displayed. 

 
View Fields: Adjustment type, Adjustment name, Usable In, Usable Out, Unusable In and Unusable 
Out.  
 
Print Adjustment Type list: 

 Press  button to view a printable list of Adjustment Type: 

 
 Press on the printer icon. The print dialog box will appear. 
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8.6. Employee Designation 
Store Commodities are used by designated Employee into Every Store as like (Store Keeper, Store 
Manager) 

 Run WIMSv4 

 Select Administrator > Employee Designation from Administrator menu. 

 The Employee Designation entry form is displayed. 

 
 
This form is used to edit, create, delete, export and print Designation. The form are grouped into 2 
blocks – 
View Fields: Designation Code and Designation  
 
Print Designation list: 

 Press  button to view a printable list of Designation. 

 
 Press on the printer icon. The print dialog box will appear. 
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8.7. Indentor Designation 
 Run WIMSv4 

 Select Administrator > Indentor Designation from Administrator menu. 

 The Indentor Designation is displayed. 

 
 

 This form is used to edit, create, delete and print Indentor Designation.  

 The form are grouped into 2 fields: Designation Code and Designation. 

 Press  button to view a printable list of Indentor Designation. 

 
 Press on the printer icon. The print dialog box will appear. 

 
8.8. District 

 Run WIMSv4 

 Select Administrator > District from Administrator menu. 

 The District entry form is displayed. 
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 This form is used to edit, create, delete, and print District List.  

 The form are grouped into 3 View Fields: District Code, District Name and Division.  

 Press  button to view a printable list of District List. 

 
 Press on the printer icon. The print dialog box will appear. 

 

8.9. Facility Group 
 Run WIMSv4 

 Select Administrator > Facility Group from Administrator menu. 

 The Facility Group Entry form is displayed. 
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 This form is used to edit, create, delete, export and Print Facility Group Unit.  

 The form is grouped into 2 View Fields: Facility Group Code and Facility Group Name.  

 Press  button to view a printable list of Facility Group. 

 
 Press on the printer icon. The print dialog box will appear. 

 

8.10. Form Item Settings 
If you need change and entry form F7B and Form F7 then open Form Item Settings form. 

 Run WIMSv4 

 Select Administrator > Form Item Settings from Administrator menu. 

 The Form Item Settings form is displayed as follows: 
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 This form is used to edit, create, delete, and print Month List.  

 Two Tabs: 
 Forn7 and  
 Form7B 

 The form is grouped into 4 fields – 
 Set 
 From Date 
 To Date 
 Set Items (Item Code, Item Name, Linked Item, Print) 

 

8.11. Supply Plan Item Serial 
 Run WIMSv4 

 Select Administrator > Supply Plan Item Serial from Administrator menu. 

 The Supply Plan Item Serial form is displayed. 
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 This form is used to edit, create, delete and print Supply Plan item serial.  

 The form is grouped into 2 View Fields: Item Code, Item Name, Rounding Factor and Mul Factor.  

 Press  button to view a printable list of Supply Plan Item Serial. 

 
 Press on the printer icon. The print dialog box will appear. 

 

8.12. Backup Database 
From this form, you can make backup of the entire database. The backup will be generated as a 
computer-generated file in a pre-defined directory. The file can be copied or moved to another 
folder in the same computer, another computer or e-mail to CWH. If the computer crashes or data 
becomes corrupt this backup can be used to get all data backup. 
How Backup database: 

 Run WIMSv4 

 Select Administrator > Backup Database from Administrator menu. 

 The Backup Database form is displayed. 
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 Press button  from the command buttons block. The form will look like following: 

 
 

After completing the Backup Generation the following screen will appear: 
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 To make a copy of the file or email it, you have to find the file from its location which is 

normally the Backup folder under the software installation folder. 

 To make a copy of the file to pen drive, locate the file from its location, and then copy to pen 
drive. 

 After backup is complete, you can close the form using  button. 
 

8.13. How to change WIMSv4 Themes 
 Run WIMSv4 

 Select Administrator >  from Administrator menu. 

 Click on the available “Themes” icon and select your favorite theme for displaying WIMS screen. 
Look like the following screen: 

 
 The “DevExpress Style” theme has changed to “Office 2010 Black” theme - 
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Chapter-9: Help 
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9.1 Audit Log 
Audit Log keeps track of all the User Actions of Data Entry (i.e., Insert, Update and Delete) in a 
specific Table of the WIMSv4 Database. If a user adds a new record into the system, each field value 
of this record treated as new value to the system. In this case the old value of that field is empty. If 
user removes a record then the audit log will record the old value only. Because already existing 
value i.e., old value can be deleted or removed. Otherwise if user edit a record and save it, the old 
and new values are saved to the audit log at that time. In other words, all the changes made by a 
user to the system are logged automatically to avoid the unauthorized changes to the system. 

 Run WIMSv4 

 Select Help > Audit Log from Help menu. 

 
There are two panels in this page: a left panel and a right panel. The left panel shows the user 
action of insert, update and delete command. The fields in the left side table -  

 Log Seq: It is the serial number of the records viewing in the page, latest records first. 

 User: Name of the user who is responsible to execute a command. 

 Create Time: It is the date and time of a command executed by the user. 

 Terminal: IP address of the user PC in the network. 

 Table: Name of the table on which the user command is being executed. 

 Query Type: Command type executing by the user – INSERT/UPDATE/DELETE. 

 SQL Text: Standard query language text that is being executed to the database but this a short 
notation of the command. When you click on the ‘more’ button you will be able to see the full 
text of the command.  
 

When you select a record from the left side table, the right side table will show the list of values 
based on command executed. The fields are - field name, old value and new value. If the command 
is INSERT, it will show only new values. The old values are empty in this case. If the command is 
DELETE, it will show only old values new values are empty. It is only the case where both the old 
and new values are encountered when user edit a record. These are the changes the system will 
keep track.  
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9.2. Error Log 
When a user tries to Add, Edit and Remove a record and if any error occurs during database 
operations, i.e., a user is trying to add a record that alreay exists in the database, that will raise an 
error. Again, if a user is trying to delete a record that has a relavent record(s) or reference with 
other table(s) may raise an error. For clarification to the System Administrator an Error Log is 
implemented as per previous user experience. 

 Run WIMSv4 

 Select Help > Error Log from Help menu. 

 
The above image shows the errors which occurred during data entry in WIMSv4. The columns in the 
table are – 

 Remote IP: IP address of the computer where the error initiated 

 User: WIMSv4 User ID 

 Date: It is the date and time of a command executed by the user. 

 Type: Command type executing by the user – INSERT/UPDATE/DELETE. 

 Query: The SQL command which is the source of error 

 Error No: SQL Error number if available 

 Error Message: Error message that explains more about the error. 
 

This error messages can be used by the Administrators to find out what exact errors that happens 
in WIMSv4 and try to solve those. 

  



WIMSv4 User’s Guide 

Page 205 of 206 
 

9.3. Data Upload Information 
 Run WIMSv4 

 To view data upload information Select Help > Data upload Information from Help menu. See 
the following screen. 

 
 

 User Id, Terminal, Start Time, End Time, Facility Code, Time to Sync, Status of success. 
 
 
 
 
 

 

- END - 


