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1.1. Background 
The Upazila Inventory Management System (UIMS) is a computer program for the management 
of upazila family store of Directorate General of Family Planning (DGFP) initially developed by the 
USAID | DELIVER PROJECT and upto version 3 has been redesigned and maintained by the 
Systems for Improved Access to Pharmaceuticals & Services (SIAPS) Program/Management 
Sciences for Health (MSH). Based users feedback on last four years of successful operations on 
UIMSv3.6, The Medicines, Technologies, and Pharmaceutical Services (MTaPS) of MSH has 
initiated to updates the UIMSv3.6 which is herein after called UIMSv4.    

1.1.1. How it's used 
The Upazila Inventory Management System (UIMS) is software to maintain inventory at family 
planning store at sub-district (Upazila) level. It enables upazila store staff to maintain stock of 
commodities & monthly Logistics Management Information System (LMIS) reporting. 

1.1.2. Advantages 
 Permits users to receive commodities from both local purchase & warehouses. 
 Have batch-lot management and expiry date tracking for RH commodities. 
 Permits users to issue commodities maintaining First-Expiry-First-Out (FEFO). 
 Can be considered as a digital stock ledger for the upazila store. 

1.1.3. Limitations 
 Not web based, but uploads stock status & monthly report to Supply Chain Management 

Portal (SCMP) as when require upon depend on internet connectivity availability. 
 Requires training to operate. 
 Not a complete store management system. 

 

1.1.4. Where it has been applied 
Directorate General of Family Planning (DGFP) under the Ministry of Health and Family Welfare 
(MOHFW) Bangladesh. 

 

1.1.5. Language availability 
English and Unicode Bangla supported to the most of the forms' text fields. 

 

1.2. UIMSv4 Features 
1.2.1. General 

 Only active users will be able to login 

 Item group & Code unification, reduce unnecessary items 

 All basic data need to be downloaded from SCMP portal 

 UIMSv4 now capable of uploads/downloads all data to/from web server (www.scmpbd.org) 

 Generate backup in .zip format 

 Can download upazila back-up data from web upto latest synced available data 

 New supplier information need to enter in UIMSv4 and upload to SCMP portal. 
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1.2.2. Lot Management 
 In UMISv4 need to maintain Item Lot management with Item Code, Lot No, Exp date, Mfg date 

fields combination. For useable lot "Exp date" must be greater than "Current date" and "Mfg 

date" smaller than "Current date". 

 

1.2.3. SDP Entry 
 No change can be made the facility group after entered. 

 Linking of Union field is mandatory for FWAs & FWVs. 

 Birth date smaller than Current date and Joining date must be greater than birth date. 

 SDP cannot be inactive for a month if already created Supply Plan for that SDP for that month. 

 

1.2.4. Receive Invoice 
 Remarks field allow to write Unicode Bangla text. 

 In UIMSv4 need to maintain Lot management when goods received. 

 Receive Invoice cannot be created and updated for a specific Month if Form 7B for that Month 

already posted in the system. 

 

1.2.5. Issue Invoice 
 Remarks field allow to write Unicode Bangla text. 

 Issue Voucher cannot be prepared with more than item quantity available on Stock balance. 

 Issue Voucher cannot be created and updated for a specific Month if Form 7B for that Month 

already posted in the system. 

 

1.2.6. Adjustment Invoice 
 Remarks field allow to write Unicode Bangla text. 

 Adjustment Voucher cannot be created and updated for a specific Month if Form 7B for that 

Month already posted in the system. 

 

1.2.7. Form 3 & Form 2 Entry 
 Only Active SDPs are allowed to give Form 3 & Form 2 entry. 

 No change can be made in master data (SDP Group, SDP, Reported Month, Reported Year, Entry 

Date etc.) if the Form 3 or Form 2 have any child records i.e. commodities' opening, receive, 

distribution, adjustment, closing data exists. 

 SDP Product Map Activate and Deactivate options with reason need to set for each 

commodities for each SDP. User need to set this to eliminating to show Stock-out in Form 7B 

and SCMP. For only first month it require to set and afterword it will automatically come to next 

month and if any change require (Activate/Deactivate) user can change accordingly. 

 Validation on closing balance has setup. User are not allowed to give entry (-) Negative and 

showing Red color if user try to enter negative figure. 

 MOS calculation on AMD on basis of last 6 Months Non-zero Average Distribution. 
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 If any SDP non eligible for receive product in that case need to un-tick on “Eligible” checkbox. 

Only who have ticked on Eligible can entry Form 3 & Form 2.  

 If any SDP have stock in hand (closing balance) cannot be un-tick the Eligible checkbox. 

 

1.2.8. Form 7B Entry 
 No change can be made in master data (Upazila, District, Reported Month, and Reported Year) 

if that form have many records (Upazila Stock, Field Stock) exists. 

 Message showing how many invoices not yet updated for a specific month. User cannot 

Generate Form 7B if any non-updated vouchers (Receive, Issue/Adjustment) and any pending 

entry of Form 2 & 3 for that month. After updating all vouchers and entered all SDP’s reports 

user only can be generate Form 7B for that month. 

 Validation on last month's closing with current month's opening balance mismatch and store 

issue and field receive mismatch showing Red color, in that case not possible to post Form 7B. 

 Not possible to enter (-) Negative value and showing Red color if user try to enter negative 

entry. 

 If there any mismatch in Form 7B user could not post the Form 7B 

 After Posted Form 7B no update/create/edit any Invoices for that month. 

 Only allowed to upload Posted Form 7B data in SCMP portal. 

 MOS calculation on Average Month Distribution (AMD) on basis of last 6 Months Non Zero 

Distribution. 

 

1.2.9. Supply Plan Entry 
 No change can be made in master data (Upazila, District, Reported Month, and Reported Year) 

if that form have many records (Condom, Shukhi, IUD and Injectable) exists. 

 To generating Issue Vouchers for all SDPs from Supply Plan of a specific item will be generated 

based on that item's stock balance availability i.e. Issue Vouchers for SDPs (start from serially 

FWA to FWV) will be generated until available Stock in hand of that item and Supply Plan will 

not generate Issue Vouchers for rest of the SDPs.  

 Only Active SDPs allowed to create Supply Plan with Max 6 months AMD. 

 No blank Issue Vouchers will not be generated from Supply Plan. User can view Issue Vouchers 

Number and Update status in Supply Plan which auto generated from Supply Plan. 

 After updating any Issue Voucher which generated from Supply Plan cannot be regenerated or 

deleted. Only previously generated non-updated Issue Vouchers can be regenerated/deleted 

and recreated keeping earlier generated same Issue Invoice Number. 

 

1.2.10. DDS Kits Entry 
 Only Active SDPs are allowed to give DDS Kits entry. 

 For first month user will be allowed to give entry for opening balance only then for next month 

opening balance will automatically came from previous month closing balance. 

 Validation on closing balance not possible to entry (-) Negative and showing Red color if user 

try to enter negative entry. 



UIMSv4 User’s Guide 

Page 9 of 195 
 

 DDS Kit (28) items entry on SCMP with multiple factor downloaded in UIMSv4. User can not 

add/edit any DDS Kit items in UIMSv4. 

 

1.2.11. Stock Reports 
 "Stock Expiry by Lot" Report added in UIMSv4 with within next 6 months and also facility to 

view data on custom date. 

 "Receive Report" added in UIMSv4 for "Local" as well as "Receive from Warehouses". 

 

1.2.12. Slow Moving Reports 
 Add new "Slow Moving Reports" showing those items have not been distributed within next 6 

months with the details information like last date of received, issued and how many days does 

not moved. 

 

1.2.13. Data Download/Upload 
 Auto Sync of data (download & upload) after a certain period (default 30 minutes) when get 

internet available. 

 

1.3. What can & what cannot be in UIMSv4 (Cases) 
1.3.1. Union 

 Union cannot be entered in UIMSv4 need to download from web. 

1.3.2. Item Group & Item List 
 User cannot add new Item in UIMSv4 need to download from web; 
 User also cannot add new Item Group need to download from web; 
 User can add Employee and set Forms & Reports Edit & View access permission. 

1.3.3. Supply Plan 
 Create Supply Plan Master first then go for generation of Supply Plan Items and auto generation 

of Issue Voucher without that it will not work; 

 To edit/update/delete Supply Plan Items+ 

 Only can update Supply Plan item for which Issue Vouchers yet not update. 

 Update of Supply Plan items are not possible if those Issue Vouchers already updated. 

 Only can delete Supply Plan items for which are not yet generate Issue Vouchers. 

1.3.4. Form 7B 
 Create Form 7B Master: Not create Form 7B items. 

 Create Form 7B Items for that Month's Receive, Issue and Adjustment invoice create & update 

status show. 

 After press "Post" button for this month receive, issue and adjustment invoice can’t be update. 

 

1.4. UIMSv4 Update Features 
1.4.1. Options 

 Include store type in Options form. 



UIMSv4 User’s Guide 

Page 10 of 195 
 

1.4.2. SDP List 
 Update SDP information with National ID, HRIS ID, Unit, and Facility. 

1.4.3. Receive Invoice 
 Receive from warehouse receive invoice (Push/Indent) download from SCMP. 

 Download receive invoice and all update data download automatically. 

1.4.4. Issue Voucher 
 Negative transection should be omitted (regarding receive and supply) 

 Auto page generation according to the quantity of items in preparing Issue Voucher.  

1.4.5. Indent 
 Create indent in UIMSv4 and upload to SCMP. 

 When upload indent then data upload automatically. 

1.4.6. Adjustment 
 Included cancel check box in Adjustment Invoice 

 Included and adjustment type of adjustment and signatory in Adjustment invoice print.  

1.4.7. F7B Report 
 Include new set for F7B report generate with 28 items. 

 Form 2 or 3 if someone distributed Injection and do not show any Syringe, or show less or 

mistake report generate showing massage. 

 MIS Form 2 or 3 but on mistake no distribution entered in distribution column report generate 

showing massage. 

 When upload F7B then data upload and download automatically. 

1.4.8. Supply Plan 
 AD Syringe closing balance should be in Supply Plan, and based on current stock, 10% additional 

added with Depo quantity and checked with closing balance. 

1.4.9. Reports 
 Stock details by product report convert to Digital ICR. 

 Included new reports Adjustment report, Stock transaction by lot and Physical inventory report. 

 Included new reports SDP Ledger report under SDP reports menu. 
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2.1. How to setup data for a Upazila 

 Step-1: After installed UIMSv4 software, double clicking the  icon from desktop the 
following screen will be appeared: 

 
 

 Step-2: Select User Id: XXX and type Password: XXX then press "OK". After pressing OK the 
following screen will be appeared: 

 
(Note that User must Logged In as Admin user). 

 

 Step-3: To select the software starting mode from the above screen click "Start with fresh 
Database" radio button then press "Next" button. After pressing "Next" the following screen 
will be appeared: 
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 Step-4: To select Upazila, go to "Upazila" combo list from the above screen for which the 
UIMSv4 has installed then press "Set Upazila and Next" button as following screen: 

 
 

After completing progress the following screen will be appeared with a message box showing 
following message: 

 
 

“Meta data downloaded successfully. 
  Please, Restart and Set Your Option Data Correctly.” 

 

 Step-5: After pressing “OK” in above "Completion Success" message box and the following 
login screen will be appeared: 

 
 

After that the UIMSv4 software will be ready to use. 
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2.2. How to configure UIMSv4 for respective Upazila Users? 

 Double clicking the  icon from desktop and putting User ID and Password from the 
following login screen: 

 
 

 Select User Id: XXX & type Password: XXX then press OK and if the User ID & Password is match 
then following software landing screen will be appeared: 

 
 

2.3. How to add an Employee in UIMSv4? 
 Go to Parameter > Employee from Parameter menu. 

 The following sub-menu will be appeared: 

 
 

 From the above Sub-menu press "Employee" menu to Add/Edit an employee. After pressing 
"Employee" button the following screen will be appeared: 
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 Press add  button to create new employee. 

 After pressing add  the following screen will be appeared: 

 
 

 Type Name, Designation, User Id, Password then press Save  or press enter from keyboard 
(N.B. Make sure your User id would be at least 3 (three) digit, Password also at least 3 (three) digits), 
Mobile No and Email. 
 

 To make an Employee “Active” or “Inactive”, press the check box  tick and untick (empty) the 
check box  to make inactive. 
 

 After pressing Save   button the following screen will be shown: 
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2.4. How do we Set Permission into Forms for each Employee 
 Select respective employee from Employee List from the following screen: 

 
 

 Against each Employee you need to set following types of permission: 
1. Permit to View press  under view 
2. Permit to Entry/Edit press  under Edit 
3. Not permit view or edit check box empty  

 

 To set permission to each and every forms for an employee you have to click these manually as 
showing in following screen: 
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2.5. How do we set Options for UIMSv4? 
 Go to Administrator > Options from Administration menu 

 
 

 After pressing "Options" the following screen will be appeared: 

 
 

 To set “Prepared By, Approved By & Issued By” which will display when an Issue Invoice will be 
printed.  

 To select above 3 (three) combos the system must have required listed employees in the 
Employee list.  

 From the prelisted Employee list you have to select one for "Prepared By", 0ne for "Approved 
By" and one for "Issued By" as follows: 
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 If you need to cancel settings Press  button before save. 

 After setting “Prepared By, Approved By & Issued By” and Store type then press  
button. 

 Press  button. 
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3.1. How to start UIMSv4 

 Double click on  icon in your desktop or 

 Select Start > Programs > UIMSv4 > UIMSv4 from taskbar to run UIMSv4. 

 Following login screen will appear: 

 
 

 Type your User ID and Password in the boxes and press <Enter> or press "OK". 

 If your User ID and Password are correct – then UIMSv4 landing screen will visible. 

 
 At the bottom left of the landing screen you will see your User Name. 

3.2. How to exit UIMSv4 
 Select File > Exit from File menu bar. Or 

 
 

 Press the topmost right button to exit from UIMSv4. 
Note: Before you exit, make sure that no forms are open. 
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3.3. How to Logout 
After your works are done and you temporarily want to suspend working with UIMSv4 but do not 
want to Exit then you should logout. This make sure that another person cannot use UIMSv4 with 
your permissions when you are out. To logout from UIMSv4, select File > Logout button from File 
menu. 

 
 

 After pressing Logout button then the following screen will appear: 

 
 

 If you want to resume your work after logging out, you have to log in again from File > Login 
menu. 

 
 

3.4. User Permission in Forms 
Based on the permission set by the Administrator, Users of UIMSv4 will be restricted to access 
certain parts of the software. The Administrator will set 3 (three) types of permissions to access the 
forms – 

 Edit – Users with edit permission on any Form will be able to enter new data, edit data, delete 
and print in the specific form. 

 View – Users with view permission will only be able to browse the data in the Form but no 
editing will be possible by using their User Id. A typical Form opened by a user with only “View” 
access: 
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 No permission – If an User does not have Edit or View permission on any form and he/she tries 
to open the form, the following error message will be shown: 

 
 

3.5. How to Change Password 
Every user has a User Id and Password initially provided by the Administrator. For security 
reasons, user should change their password at any time by follow the below steps: 

 Select File > Change Password from File menu. 

 Change Password Form will be visible. 

 The User Id combo box will be shown your logged on user name. 

 Provide your Current Password in Old Password box. 

 After that enter the New Password that you would like to set in the New Password and 
Confirm Password box. 
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 Press Update button to continue. 

 To check that the New Password is in effect, login again from File > Login… dialog box. 
 

3.6. UIMSv4 Menu(s) Operating Guidelines 

1. To open UIMSv4, user need to double clicking the  icon from desktop. 
2. The UIMSv4 have following Menu and Sub-Menu: 

 

 Menu: File, Parameters, Invoice, Stock, Reports, and Administrators & Help. 
 Sub-Menu: Exit, Login, Logout, Change Password etc.  

 
3. At a time multiple Forms can be opened and user can browse one to another just like switching 

Forms' Tabs: 

 
 

4. To Minimize, Maximize and Close a Form, user need to click buttons from the following Bar: 

 
The forms will be kept opened until user close the form. 
 

3.7. Form Elements 
A typical Entry Form can be divided into 5(five) major common blocks – 

 Block-A: This block generally consists of a list of IDs/Names/Dates from which one can select 
a specific record to view in following Block-B & C in details. 

 Block-B: The basic and common header or master data need to enter in this block. 

 Block-C: The details items under a same header or master need to enter in this block. 
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 Block-D: This block consists of a number of buttons to entry, edit, delete, and preview and 
print the records. 

 Block-E: To generate vouchers/reports, upload/download this block is used.  

 
 

3.8. Common Command Buttons 
A list of common command buttons with label name which will found in most of the forms: 

 To Insert a new record of any type 

 To Undo the current record 

 To Save the current editing 

 To Delete the current record in a form 

 To Preview a report before printing 

 To Print a report without previewing 

 To View print options before any print from Preview 

 To Update of records to addition or deletion into stock data 

 To Close a Form 

 To Cancel any action or task 

 To OK of any action or task 

 To Search/Filter of any records 

 To Insert a new record in a form 

 

 

 

          A 

                                                           B 

 

                                                           C 

          E                             

E 

                                                         D  
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 To Undo the current record 

 To Save the current editing 

 To Delete the current record items in a form  

 Toggle button for expand and close of a form  
 

3.9. Common Features of a Form 

 
 

(1) Group/Un-group: Group/Un-group of a Form just clicking Upper/Lower Arrow as follows: 

 
 
(2) Search a Record:  

 To search a record of a Form just write correct spelling of word or a portion of correct word. 

 To search an item if you start with (*) before write word the system will show all the words 
which contain searchable part even Before, Middle, After. The searchable option show as 
follows: 

1 

2 3 
4 

5 6 

7 8 9 

 

10 
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(3) Row Hide-Unhide: User can hide and unhide any number of Rows just clicking (+) or (-) button 
as follows: 

 
 

(4) Column Shifting: User can shift ether side (Left-Right) of any column of a Form as follows: 

 
 

After Shifting: 
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(5) Total Records Count: 

 
 
(6) Page Scrolling: User can see how many records are in a Form as follows: 

 
 
(7) Export Records: If user need to export any records from any Form, for this user click on 

 button and the system will asking for destination drive where to save and chose 
file format (Excel/PDF).  

 
 

After exporting the file if it is export to Excel, the file look like as follows: 
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(8) Printing Option 

 Press  button to preview the report/data. 

 Press  for direct print into a printer without previewing the report/data. 

  4 (four) icons using for Page set-up for printing. After pressing 

button these icons will appear in Status bar.  icon used for print,   icon 

used for Quick Print,  icon used for Page Setup and "Scale"  icon used for Scaling 
of "default set page" to "Adjust to" or "Fit in" page size to your desire Custom Page Size. 

 After printing, press the leftmost  button to close the Preview window. 
 
(9) Close a Form 

 Press  button to exit from a Form. 

 User can also exit by pressing the button at the top right of the form. 
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3.10. Forms Data Uploading & Downloading Condition 
3.10.1. Data downloaded from Web 

The following forms' basic data will be downloaded from SCMP portal (www.scmpbd.org) and 
user could not update or enter any records: 
Under Parameters Menu Under Administrator Menu 

1. Item Group 9. Unit 
2. Item List 10. Adjustment Type 
3. Warehouse List  11. Employee Designation 
4. District 12. Indentors Designation 
5. Upazila List 13. Facility Groups 
6. Unions List 14. Form Item Settings 
7. SDP Unit 15. Supply Plan Item Serial 
8. Health Facility 16. DDT Kit Item Serial 

  

 
3.10.2. Data Entry in and uploaded from UIMSv4 

User can enter new data in the following forms data: 
Under Parameter Menu:  

1. Suppliers 8. Adjustment Invoice 
2. Employee 9. Indent 
3. SDP List Under Field Menu: 

Under Administrator Menu: 10. Form 3 
       4. Options 11. Form 2 

Under Invoice Menu: 12. Form 7B 
5. local Purchase 13. Supply Plan 
6. Receive from Warehouse 14. Custom Supply plan profile 
7. Issue Voucher 15. DDS Kits Reporting 

 
3.10.3. Common & No Effect Forms in UIMSv4 

The following forms have both download and upload option from UIMSv4 to SCMP web portal 
(www.scmpbd.org): 

1. Backup Database 4. Reports 

2. Data Download 5. Stock Balance 
3. Data Upload  
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Chapter-4: Parameters 
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4.1. Item Groups 
Store commodities are classified into a number of Groups. Each Group is unique and has a Group 
Code and a descriptive Group Name. Normally, Group Code is defined by 3 (three) characters in 
length and abbreviated from their descriptive name. 

 Run UIMSv4 

 Select Parameters > Item Groups from Parameters menu. 

 The Item Groups Form will be displayed as following screen: 

 
 
This form is used to edit, create, delete, print item groups. The form are grouped into 2 (two) 
blocks: 
A. Fields Block: 

Group Code: 3 (three) digit alphanumeric code that can represent the group. 
Group Name: To describe a group, two fields are required. 
Total Count: Total number Group show under view filed. 
 

 Users cannot add a new Item Group by their own using UIMSv4. They only can view Item 
Groups. When UIMSv4 software will be installed into their computer these will be 
automatically downloaded from SCMP web portal (www.scmpbd.org). In the web portal if 
any new group will update by Administrative Panel or if user will found an Item Group in any 
Receive Invoice/Challan which do not have in UIMSv4 while they try to enter in UIMSv4 which 
running in the upazila store then they need to download it first by clicking Administrator > 
Meta Data form from Administrator menu. 
 

 From the Meta Data Form user will found a Download button lower right side of the form. 
User need to click the Download button to sync from SCMP web portal (www.scmpbd.org) if 
any new Items code, Group code, Suppliers etc. waiting for download. 
 

B. Export, Preview & Close Block: 
To export, preview, print and close the Item Group user can do these by using this block. 
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Print Item Groups: 

 Press  button to view a printable list of Item Groups. 

 
 

 Press on the printer icon. The print dialog box will appear. 
 
Export Item Group:  
If user need export Item Group list- Select export format then the Item Group list will visible here in 
your chosen format.  
 
View Items under Group 

 
 

 Select the group from Item Groups list on Item List Form. 

 Press Preview button to see the items under the selected Group. 
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4.2. Item List 
To view Item List User need to go to the following form: 

 
 Store commodities are classified into a number of groups.  

 Item Code in the form of XXXYYY where XXX is the Group Code and YYY is a sequence number.  

 Every item has a distinct Item Name. 
 
View Item List 

 Run UIMSv4 

 Select Parameters > Item List… from Parameters menu. 

 The Item List form is displayed. 
 
General Description of Item List Form 

 
This form is used to edit, create, delete, print items. Controls in the form are grouped into 3 (three) 
blocks – 
A. Item Group: Shows a list of current Item groups in database. A label below shows the total 

number of items under the selected group. 

 

 

                       A 

 

 

                      B 

                                               C 
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B. List of Items: Shows details about every item under the selected group. To describe an Item, 5 

(five) fields are required. 

 Item Code – A unique 6 (six) digit code that can be used to identify the item. The code is 
generated automatically. But you can change if you wish. 

 Item Name – A descriptive name for the item. 

 Initial Stock (Usable) – Initial stock which is available when we include the item in the 
inventory system. 

 Initial Stock (Unusable) – Initial unusable quantity of the item. 

 Unit – Unit of measurement of the item. 

 Item Code, Item Name and Unit fields are compulsory. Items can be sorted in the list by 
‘Item Code’ or ‘Item Name’, which is done through Sort By combo selection. 
 

C. Command Buttons: A number of buttons to manipulate the item list. 
 
Search and Find an Item 

 
 

 Type Item name in search box Items which match with the search text will be shown in the list. 

 To see all of the items again, clear item name from the search box. 
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View information about a specific Item 

 
 

 Select the group of the item from Item Group list. 

 All the items under the group will be shown in list. 

 Scroll through the list to find the Item you are looking for. 
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View Lot-wise information about a specific Item 

 
 

 Select the item for which you want to view lot-wise information. 

 Select the item show lot-wise information in right side. 
 
Entry Initial Stock 

 
 

 Select item from Item list and enter Initial Stock (Usable) and Initial Stock (Unusable) then 
press “Enter” from keyboard. 
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 After pressing Enter, the putted initial stock will be saved and select next item from item list. 

 
 

Initial Lot QTY Entry 

 Press "Show Item Lot Details"  button 

 After pressing "Show Item Lot Details" button the following screen will be displayed: 
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(N.B: After save Initial (Usable) or Initial Stock (Unusable) items Initial Lot Qty will be displayed item list right side) 

 

 First need to be updated initial stock then user can enter Lot entry; 

 If user need to be cancel this form press  button. 

 If user need to give entry Mfg. Date, Expiry Date and Multiple Lot entered as shown in following 
screen: 

 
(N.B. The system could not allow Mfg. Date afterwards any date of System date & Expiry Date 
backwards any date of System date) 

 

 After pressing  the entry will be saved and displayed the entered lot-wise stock 
items in right side as shown in the following screen: 
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Print Item List 

If user need to print Item List just press “Preview” button then press printer icon the item list is to 
be printed as following preview will appeared: 

 
 

4.3. Suppliers 
Commodities are procured in the upazila from different external suppliers. For reporting and future 
reference, a list of suppliers is maintained. To go to Suppliers form: 

 Run UIMSv4. 

 Select Parameters > Suppliers… from Parameters menu. 

 The Suppliers form is displayed as follows: 
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General Description of Suppliers Form 

 
 

Enter a new Supplier: 
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Print Suppliers List 

 Press  button to view a printable list of suppliers. 

 
 Press on the Printer icon. The print dialog box will appear. 

 

4.4. Employees 
The Employees Form contains the name of employee and their permissions in different data entry 
forms. Employees who are relevant to the UIMS software should be listed using this form. Every 
user will have one User Id and Password with which they enter into the software. 
 Run UIMSv4. 
 Select Parameters > Employees… from Parameters menu and  
 The Employees form is displayed. 

 
 

This form is used to edit, create, delete, print list of employees. The form is grouped into 4 (four) 
blocks –  

A. List of Employees: Shows a list of current employees in database. A label shows the total 
number. 

B. Entry Fields: To describe an employee, 5 (five) fields are required. 
 Employee ID – Auto generated ID for each employee. 
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 Name – Name of the employee. 
 Designation – Designation of the employee. 
 User ID – Three character User ID for each employee, which will be used during logging 

into the software. 
 Password – Password of the employee which he will use during logging into the 

software. 
 Mobile No: Employee Mobile number. 
 Email- Employee email address. 
All of the fields are compulsory. 

C. Forms Tab: List of form names. In each form, the user will be given permission to View or 
Edit the data.  

D. Command Buttons: A number of buttons to manipulate the employees. 
 

View information about a specific employee 

 Select the employee you want to view from the tree-like list in Block-A. Using the Order by 
Combo box - Employees can be sorted in 2 (two) ways – by Employee ID or by Employee 
Name.     

 After an employee name is selected – all the fields are shown in Block-B. 
Enter a new Employee 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 

 The Employee ID will be given automatically. 

 Type Employee Name. 

 Select the Designation of the employee from list. 

 Enter a 3 (three) digit User ID. 

 Enter a Password for the employee. The Password will be shown as special (***) for security 
reasons as following screen:  

 Enter employee Mobile No. 

 Enter employee Email Address. 
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 Press or Enter button from keyboard. 
 Newly entered Employee name will be visible in the Employees list in Block-A. 

 
 If the new User ID conflicts with an existing ID, then an error dialog will appear. Change the User 

ID and try saving again. 
 If you want to cancel the new employee entry, press Esc during editing to undo. 

 
Enter Permissions in Data Entry Forms 
 Select the employee for which you want to provide permissions to data entry forms. 
 If you do not want that the employee will access different Forms, then do not give permissions. 
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 If you want the employee to only see data but cannot change anything, then click under View 

column. A  will appear beside the form name under View column.  
 If you want that the employee would do the data entry in the form, then click on View and Edit 

column beside the form name. A  will appear beside the form name under View and Edit 
column. 

 
Edit an existing Employee 
 Select the employee you want to edit from the list of employees. 
 Change the Employee Name, Designation, User ID, Password fields as needed.    
 When done with editing, press “Save”. 

 If the new User ID conflicts with an existing employee, then an error dialog will appear. 
"Change the User ID and try saving again". 

 If you want to cancel the current editing, press Esc to undo the changes. 
 
Delete an existing Employee 
 Select the employee you want to remove from list of employees. 
 Press “Delete” button from your keyboard. 
 A confirmation dialog will be shown.  
 Press “Yes” if you really want to delete the employee.   
 You will not be able to delete employees that have permissions in different forms. First remove 

the permissions in different forms first then remove the employee. 
 
Print Employee list 

 Press  button to view a printable list of Employee List. 
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 Press on the printer icon. The print dialog box will appear. 

 
Close Employees Form  

 Press  button to exit from the Employees form.  

 You can also exit by pressing the  button at the top right of the form.  
 If you have unsaved Employee data during exit, you will be informed that your changes will be 

lost if you exit. 
 Press yes if you do want to exit without saving. Press No if you don’t want to close the form at 

this time. 
 

4.5. Warehouse List  
 Run UIMSv4 

 Select Parameters > Warehouse List from Parameters menu. 

 The Warehouse List form is displayed. 

 
 This form is used to edit, create, delete, and print Facility List.  
 The form are grouped into 5 (five) columns Fields: Facility Code, Facility, District, Phone No and 

Receiving Facility. 
 The Warehouse List data need to download from web, user could not add data here. 

 
Print Warehouse List 

 Press   button to view a printable list of Warehouse. 
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4.6. District  
 Run UIMSv4 

 Select Parameters > District from Parameters menu. 

 The District form is displayed. 

 
 

 This form is used to edit, create, delete, and print District List.  
 The form are grouped into 4 (four) columns Fields: District Code, District Name, Division, Geo 

Code. 
 The District data need to download from web, user could not add data here. 

 
Print District List 

 Press   button to view a printable list of District. 
 

4.7. Upazila List  
 Run UIMSv4. 

 Select Parameters > Upazila List from Parameters menu. 

 The Upazila List form is displayed. 
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 This form is used to edit, create, delete, and print Facility List.  
 The form are grouped into 7 (seven) columns fields: Facility Code, Facility, Geo Code, District, 

Supply From, Phone No, Receiving Facility. 
 The Upazila List data need to download from web, user could not add data here. 

 
Print Upazila List: 

 Press   button to view a printable list of Upazila List. 

 
 

4.8. Unions  
 Run UIMSv4. 

 Select Parameters > Unions from Parameters menu. 

 The Unions form is displayed. 
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 This form is used to edit, create, delete, and print Facility List.  
 The form are grouped into 2 (two) columns Fields: Union Code, Union Name. 
 The Unions data need to download from web, user could not add data here. 

 Press   button to view a printable list of Unions List. 
 

4.9. SDP List 
 Run UIMSv4. 

 Select Parameters > SDP List from Parameters menu. 

 The SDP List entry form is displayed. 

 
 
 The SDP List contains the names of different field workers to whom commodities are issued.  
 Names from this list are picked during invoice preparation. 
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General Description of SDP List Form 

 
 

This form is used to edit, create, delete, print list of SDPs. Controls in the form are grouped into 3 
(three) blocks – A, B & C 
A. List of SDPs: Shows a list of current SDPs in database. A label shows the Total number of SDPs 
and Non-SDPs. 
B. Entry Fields: To describe a SDP, three fields are required:  

 SDP Group – Facilities are classified into different groups.  

 SDP Code – A unique sequence to represent the SDP under the group. It is generated 
automatically  

 Name – Actual name for the SDP.  

 Phone No: SDP Phone number (11 digit) 

 Designation: Designation of SDP 

 Birth Date: SDP’s date of birth 

 Joining Date: SDP’s joining date 

 National ID#: National ID number of SDP 

 HRIS ID #: HRIS ID number of SDP 

 Unit: Unit of SDP 

 Union: Union of SDP 

 Facility: Facility of SDP for( FWV and NGO) 

  In-charge: selected in-charge of SDP. 

  Active: Is Active SDP’s 
SDP Name: Name of SDP with unit, Designation, Union and if in-charge. It is generated automatically       
C. Command buttons: A number of buttons to manipulate the facilities. 
  

 

 

 

      A 

 

                              B 

                             C 
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Enter a new SDP  

 Press  button from the command buttons block. The form will look like the following 
figure. 

 
 

 Select a SDP Group from the combo.  

 The SDP Code will be taken automatically.  

 Enter the Name of the SDP and Union (only for FWA and FWV group). 

 Enter the Birth date and Joining date, National Id, HRIS ID #, Unit, Unit , facility of this SDP 

 
 Press Save button 

 Your new SDP name will be visible in the SDP list in block A. 
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 If the new SDP name conflicts with an existing SDP, then an error dialog will appear.  

Change the SDP name and try saving again.  

 If you want to cancel the new district entry, press Esc during editing to undo. 
 
Edit an existing SDP  

 Select the SDP you want to edit from the list of SDPs then click on ‘Edit’ button. After clicking 
see the following screen. 

 
 Change the SDP Name, phone no, designation, birth date, joining date, national id#, HRIS Id #, 

Unit, Union and facility fields as needed.  

 When done with editing, press “Save”.  

 If the new SDP name conflicts with an existing SDP, then an error dialog will appear "Change the 
SDP name and try saving again".  

 If you want to cancel the current editing, press Esc to undo the changes. 
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 SDP Serial Change for existing active SDP 

 Press on “SDP Serial” button for changing SDP serial. After pressing will be seen the following 
screen. 

 
 Select a SDP then drug and drop SDP name in the actual serial. 

 Press “SAVE” button then you will see the SDP in actula serial. 
 
Delete an existing SDP  

 Select the SDP you want to remove from list of SDPs.  

 Press ‘Delete’ button.  

  A confirmation dialog will be shown.  

 Press “Yes” if you really want to delete the SDP.  

 You will not be able to delete SDPs that have invoices linked. 
 
Print SDPs  

  Press “Preview” button to view a printable list of SDPs. 

 
 Press on the ‘Printer’ icon. The print dialog box will appear.  

 Optionally provide Print Range, Copies and press OK. If you want to print only one copy of the 
whole report, then just press OK.  

 After printing, press the leftmost  button to close the preview window. 
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4.10. SDP Active/Inactive Report 

 
 The SDP List contains the names of different workers to whom commodities are issued.  
 Names from this list are picked during invoice preparation.  
 

View SDP Active/Inactive Report  

 Run UIMSv4. 

 Select Parameters > SDP Active/Inactive Report from Parameters menu. 

 The SDP Active/Inactive Report form is displayed. 

 

If you need to show “Active SDP” press "Active SDP" Radio button else "Inactive SDP" Radio button. 
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Print SDPs  

 Press “Preview” button to view a printable list of Active/Inactive SDP Report. 

 
 

 

 Press on the Printer icon. The print dialog box will appear.  

 Optionally provide Print Range, Copies and press OK. If you want to print only one copy of the 
whole report, then just press OK.  

 After printing, press the leftmost  button to close the preview window. 
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Chapter-5: Invoice 
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5.1. Receive Invoice – Local Purchase 
After go to Invoice menu user will find two types of Received Invoice. The following screen shows 
the Local Purchase Invoice: 

 
The above form is used when items are received from external supplier and to create new receive 
invoice, edit, print or delete invoices. 
 

Open Receive Invoice Form 

 Run UIMSv4. 

 Select Invoice > Local Purchase... from Invoice menu. 

 The Receive Invoice form is displayed. 
 

 
General Description of Receive Invoice Form 

 
 

This form is used to edit, create, delete, and print Receive Invoices. The form is grouped into 4 
(four) blocks – 

 

 

 

      A 

 

                              B 

 

                              C 

                             D 
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A. Invoice List: Invoices are listed under grouped by:  

 Invoice No.   

 Receipt Date or  

 Received By  
 

B. Invoice Entry Fields: To record an Invoice entry header which have following fields: 

 Invoice No* – A unique sequence to represent the invoice. 

 Receive Date* – Date of receipt of goods. 

 Received By* – Name of receiving officer. 

 Supplier* – Name of supplier. 

 Local Purchase Invoice No* – Voucher No. of Local Purchase. 

 Local Purchase Invoice Date* – Date of Local Purchase Challan. 

 Remarks - Text box to write anything. 

 Update - Check box to update a Invoice which filled automatically. 

 Cancel - Check box to cancel any Invoice. 
 

C. Invoice Items Entry Fields: Invoices consist of line items. There is one line for each item 
received and has the following 6 (six) fields: 

 Item Name* – Name of goods received. 

 Qty* – Total quantity of goods received. 

 Unit – Unit of measurement of item. 

 Lot No/Description – Lot no. of the received goods. 

 Mfg. Date – Manufacturing date of the received goods. 

 Expiry Date – date of expiry of the received goods. 
 

D. Command buttons: A number of buttons to manipulate the Invoices. 
 

View Information about a specific Invoice 

 
 

 Select the invoice to view from the tree list in Block-A. Using the Group by any fields – Invoices 
can be grouped in ways – by Invoice No or by received date or by supplier 

 After an invoice no. is selected – corresponding information is shown in Block-B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press ‘Filter’ button 
to list less or more invoice. 
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Enter a new Invoice 

 Press  button from the command buttons block. The form will look like as follows: 

 
 

 The Invoice No. will be generated automatically. 

 
 

 Receive Date will be filled with current date. You can change if necessary. 

 Select the Employee who is received the goods. 
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 If the supplier name is present in Supplier list then select the name. 

 Provide invoice no. and date from supplier’s challan. 

 
 

 Press  button. 

 Your new Invoice no. will be visible in the Invoice list. 

 
 If you want to cancel the new Invoice entry, press Esc during editing to undo. 
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Invoice Items Entry 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 

 Select an Item name from Item Name combo box. 

 Enter the received quantity in Qty box. 

 Unit field will be filled automatically. 

 Enter Lot No/Description, Mfg. Date and Expiry Date fields. 

 
 

 Press “Enter” button from keyboard to save the line item and go for next line item entry. 
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Updating the Stock 

 Entry of a new Invoice does not update the current stock position automatically. After the 

Invoice entry is completed, press  button to recalculate the balance of Items from 
the current Invoice. 

 A confirmation dialog will appear. 

 
Note: After the invoice quantities are updated to stock, the invoice will be locked, user will not be allowed 
to change any figure afterwards. 

 Press "Yes" if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of Items for which stock was updated. 

 If you want to update invoice on back date pressing “Update” button a confirmation dialog will 
appear. 

 
 If you want update on current date press “Yes” or you want update on Receive date press “No”. 

Edit an existing Invoice 

 Select the invoice you want to edit from the list of Invoices. 

 Change the fields as necessary. 

 When done with editing, press Save. 

 If you want to cancel the current editing, press Esc to undo the changes. 
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Delete an existing Invoice 

 Select the Invoice you want to remove from Invoices list. 

 Press  button. 

 A confirmation dialog will be shown 

 
 Press "Yes" if you really want to delete the Invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 

 
Edit an existing Invoice Item 

 
 

 Select the Invoice item you want to edit from the items list in Block-C. 

 
 

 Press F2 or click on any field to start editing. 
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 Change the fields as necessary. 

 When done with editing, press Save. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an Invoice item 

 Select the Invoice item you want to edit from the items list in Block-C. 

 Press "Delete" button from keyboard. 

 A confirmation dialog will be shown as like below screen: 

 
 Press “Yes” if you really want to delete the Invoice item. 
 

Search a Receive Invoice 

 Press  tab for expanding Receive Invoice form and to find a specific Invoice. 

 
 

 To search go to   
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Row header just writing Invoice no. and following window will appear: 

 
 

 Enter the invoice no you want to find in "Receive Invoice No." box. 

 Automatically start searching. 

 If the invoice is found then it will be shown selected. 
 
Print Receive Invoice 

 Press  button to preview the Invoice. 

 Press on the Printer icon. The print dialog box will appear. 

 You can print only one copy or all pages, choose as you want then just press OK. 

 After printing, press the leftmost  button to close the Preview window. 
 

Close Receive Invoice Form 

 Press  button to exit from the receive Invoice form. 

 You can also exit by pressing the  button at the top right of the form. 
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5.2. Receive Invoice – Receive From Warehouse 
When commodities are issued/transferred from RWH to Upazila Family Planning Store – this form is 
used. Item quantities entered here add up to total stock. This form is used to enter new receive 
invoice, edit, print or delete old invoices. 

 
 

Open Receive From Warehouse Invoice Form 

 Run UIMSv4. 

 Select Invoice > Receive From Warehouse… from Invoice menu. 

 The Receive from Warehouse Invoice form is displayed. 
 

General Description of Receive from Warehouse Invoice Form 

 
 
This form is used to edit, create, delete, and print Receive Invoices. Controls in the form are 
grouped into 4 (four) blocks – 
 

 

 

 

        A 

 

                               B 

 

                               

                                C 

                                 D        E 
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A. Invoice List:  
Invoices are listed by item group. Invoice Group combo filter the invoices according to their 
group. Invoices can also be listed grouped by - 

 Invoice No.  

 Invoice Date or 

 Prepared by. 
A label shows the total number. 
 

B. Invoice Entry Fields:  
To describe an Invoice entry header for which have following fields - 

 Invoice No* – A unique sequence to represent the invoice. 

 Receive From* - Warehouse name automatically selected from where goods were sent. 

 Receive Date* – Date of receipt of goods. 

 Received By* – Name of receiving officer. 

 Warehouse's Invoice No* – Issue Voucher no. of Warehouse. 

 Warehouse's Invoice Date* – Date of Warehouse Invoice voucher. 

 Remarks – Text box to write any comments about the supply. 

 Update – Check box to update an Invoice which filled automatically. 

 Cancel – Check box to cancel any Invoice. 
 

C. Invoice Items Entry Fields:  
Invoices consist of line items. There is one line for every item received. Every line has the 
following fields: 

 Item Name* – Name of item received from RWH. 

 Qty* – Total quantity of good received from RWH. 

 Unit – Unit of measurement of item. 

 Lot No/Description – Lot no. of the received goods. 

 Mfg. Date – Manufacturing date of the received goods. 

 Expiry Date – Date of expiry of the received goods. 
D. Command Buttons: A number of buttons to manipulate the Invoices. 

E. Download Invoice Button: Download receive invoice which are supplied from warehouse with 
Push/Indent voucher. 

View information about a specific Invoice 
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 Select the Invoice to view from the tree list in Block-A. Using the Group by combo box – invoices 
can be grouped in two ways – by Invoice No or by Receive Date or Received by. 

 After an Invoice no. is selected – corresponding information is shown in Block-B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed.  

 You can change the dates and press "Filter" button to list less or more invoice. 

 
 

 You can chose Invoices of Today, Yesterday, Last Week, This Month, Last Month, Last 3 Month, 
Last Year and Custom Range of choosing any Date as shown in the above screen.  
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Download a receive Invoice 

 Press  button from the command buttons block. The form will look like 
this: 
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 Enter the Inv No: (Push/Indent) like following screen. 

 

 Press on ‘Download’ button. After pressing the receive voucher will be downloaded. Like 
following screen. 

 
 Now you can check and update the downloaded invoice. 
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Enter a new Invoice 

 Press  button from the command buttons block. The form will look like this: 

 
 

The Invoice No. will be generated automatically. 

 Receive Date will be filled with current date. You can change if necessary. 

 Select the Employee who is receiving the goods. 

 Provide Warehouse's Invoice No. and  

 Provide Warehouse's Invoice Date. 

 
 

 Press  button. 

 Your new Invoice no. will be visible in the Invoice list. 
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 If you want to cancel the new Invoice entry, press Esc during editing to undo. 
 

Invoice Items Entry 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 

 After select an Item from Item Name combo press <Enter> and type received Qty, Lot 
No/Description, Mfg Date, and Expire Date. 
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 Press <Enter> button from Keyboard. After pressing Enter the item will save as showing in 
following screen: 

 
 

Updating the Stock 
Entry of a new Invoice does not update current stock position automatically. After the Invoice entry 
is completed, press "Update" button to recalculate the balance of items from the current invoice. 
Note: After the invoice figures are updated to stock, the invoice will be locked – you will not be allowed to 
change any figure. 
 

 Press "Update" button. 

 A confirmation dialog will appear. 
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 Press “Yes” if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of items for which stock was updated. 

 If you want to update invoice on back date pressing Update button a confirmation dialog will 
appear. 
 

 
 If you want update on current date press “Yes” or you want update on Receive date press “No”. 

 
Edit an existing Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press “Save” button. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an existing Invoice 

 Select the invoice you want to remove from Invoices list. 

 Press “Delete” button. 

 A confirmation dialog will be shown. 

 
 Press “Yes” if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and 
then delete the invoice. 
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Edit an existing Invoice Item 

 
 

 Select the Invoice Item you want to edit from the Items list in Block-C. 

 
 

 Press F2 or click on any field to start editing. 

 
 Change the fields as necessary. 

 When done with editing, press “Save”. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an invoice item 

 Select the Invoice item you want to delete from the items list in Block-C. 

 Press “Delete” button. 

 A confirmation dialog will be shown. 
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 Press “Yes” if you really want to delete the invoice item. 
 

Search a Receive Invoice 

 Press  tab for expanding Receive Invoices form and to find a specific Invoice. 

 
 

 To search go to  row 
header just writing Invoice no. and following window will appear: 

 
 

 Enter the Invoice no you want to find in "Receive Invoice No." box. 
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 Press <Enter> button to start searching. 

 If the Invoice is found then it will be shown selected. 
 

Print Receive Invoice  

 Press "Preview" button to preview the invoice. 

 Press on the printer icon. The print dialog box will appear.  

 Optionally provide Print Range, Copies and press OK. If you want to print only one copy of the 
whole report, then just press OK.  

 After printing, press the leftmost  button to close the preview window.  

 Press Close button to exit from the receive Invoice form.  

 You can also exit by pressing the button at the top right of the form.  

 If you have unsaved invoice during exit, you will be informed that your changes will be lost if 
you exit. 

 Press Yes if you do want to exit without saving. Press No, if you don’t want to close the form at 
this time. 
 

5.3. Issue Voucher  

 
 

This form is used to distribute items to facilities. Item quantities issued through this invoice are 
deducted from the total stock. This form is used to enter new Issue Voucher, edit and print or 
delete old invoices. 

 
Open Issue Voucher Form 

 Run UIMSv4. 

 Select Invoice > Issue Voucher … from Invoice menu. 

 The Issue Voucher form is displayed. 



UIMSv4 User’s Guide 

Page 77 of 195 
 

 
 
General Description of Issue Voucher Form 

This form is used to edit, create, delete, and print Issue Voucher. Controls in the form are grouped 
into 4 (four) blocks – 

 
 
A. Invoice List:  

Invoices can be listed grouped by  

 Invoice No. 

 Invoice Date or  

 Prepared by 
A label shows the total number. 
 

B. Invoice Entry Fields:  
To describe an Issue Invoice the following fields are required - 

 Invoice No* – A unique sequence to represent the invoice. 

 SDP Group* – Select SDP group from SDP combo. 

 

 

 

        A 

 

                               B 

                               

                                C 

                                 D 
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 Union* – Union of the SDP who receive the items.   

 SDP* – SDP who receiving the items. 

 Prepared By, Approved By, Issued By* – Name of employees who are responsible for issue 
of items. There are three date fields related to the names. 

 Prepared Date, Approved Date, issued Date* – Dates in which invoice preparation, approval 
and supply are made. 

 Remarks – Any comments about the supply. 

 Update - Check box to update an Invoice which filled automatically. 

 Cancel - Check box to cancel any Invoice. 
 

 Invoice No, SDP Group, Union, SDP, Prepared by, Approved by, Supplied by and their related 
date fields are compulsory. 

 
C. Invoice Items Entry Fields:  

Invoices consist of line items. There is one line for every item received. Every line has the 
following eight fields: 

 Item* – Name of item requested (Cannot issue facility items to other facility specified in 
F7B item settings) 

 Issued Qty* – Quantity issued to facility  

 Unit – Unit of measurement of item 

 Stock Qty - To show available stock in hand and this field fill-up automatically 

 No. of Cartons - To write no. of packaging units 

 Lot No/Description – Lot no. of the item issued 

 Mfg. Date – Manufacturing date of the item lot issued 

 Expiry Date – Expiry date of goods in the lot 
Item and Issued Qty fields are compulsory. Unit, Stock Qty, Lot No, Mfg. Date and Expiry date 
are automatically picked from item’s lot information 
 

D. Command buttons:  
A number of buttons to manipulate the Invoices. 

 
View information about a specific Issue Invoice: 

 Select the invoice to view from the tree list in Block A. Using the Group By combo box – invoices 
can be grouped in three ways – by Invoice No, Invoice Date or Prepared by. 

 After an invoice no. is selected – corresponding information is shown in Block B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press ‘Filter’ button 
to list less or more invoice. 
 

Enter a new Issue Invoice 

 Press  button from the command buttons block. The form will look like the following 
screen: 
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 The Invoice No. will be generated automatically. 

 Date fields will be filled with current date. You can change if necessary. 

 Select the employee names who is preparing, approving and supplying the goods. 

 Optionally provide other fields. 

 
 

 Press  button. 

 Your new invoice no. will be visible in the invoice list. 

 If you want to cancel the new invoice entry, press Esc during editing to undo. 
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Issue Invoice Items Entry 

 Press  button from the command buttons block. The form will look like the following screen:  

 Select an Item from Item Name combo box. (Cannot issue facility items to other facility specified 
in F7B item settings) 

 Enter Issued Qty. 

 Unit field will be filled automatically. 

 
 The Stock Qty, Lot No, Mfg Date and Expiry Date will be picked from the lot information, if 

available. 

 Issue Voucher cannot be prepared with more than Item quantity available on Stock balance. 
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 Press <Enter> to save Invoice line items. 

 
 

Updating the Stock 
Entry of a new invoice does not update current stock position automatically. After the invoice entry 
is complete, press "Update" button to recalculate the balance of items from the current invoice. 
Note: After the invoice figures are updated to stock, the invoice will be locked – you will not be allowed to 
change any figure. 
 

 Press  button. 

 A confirmation dialog will appear. 
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 If you want update on current date press “Yes” or you want update on Issue date press “No” 

 
 

 
 

 Press "Yes" if you are sure that the invoice figures are correct. 

 
 

 A confirmation dialog will show the number of items for which stock was updated. 
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Edit an existing Issue Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press "Save" button. 

 If you want to cancel the current editing, press Esc to undo the changes. 

 

Edit an existing Issue Invoice Item 

 Select the invoice item you want to edit from the items list in Block C. 

 
 

 Press F2 or click on any field to start editing. 

 
 

 When done with editing, press “Save” button. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Delete an existing Invoice 

 Select the invoice you want to remove from invoices list. 

 Press "Delete" button and a confirmation dialog will be shown. 
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 Press “Yes” if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 

 
Delete an Issue Invoice Item 

 Select the invoice item you want to edit from the items list in Block-C. 

 Press "Delete" button and a confirmation dialog will be shown. 

 
 

Press “Yes” if you really want to delete the Invoice item. 
 

Search an Issue Voucher  

 Press  tab for expanding Receive Invoices Form and to find a specific Invoice. 

 
 

 To search go to  row 
header just writing Invoice no. and following window will appear: 
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 Enter the invoice no you want to find in "Invoice No." box. 

 Press <Enter> from keyboard to start searching. 

 If the Invoice is found then it will be shown selected. 

 
 

Print Issue Voucher 

 Press Preview button to preview the Issue Voucher. The follow windows will appear. 
N.B More than 13 product in Issue voucher print preview will be displayed two pages. One 
office copy and other recipient copy. 
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 In the above preview screen there will two parts, first part is Office Copy and second part is 
Recipient Copy. In between two parts there are dotted lines for separation by cutting to make it 
two parts. 

 Press “Print” button to preview the invoice. The following dialog will come. 

 
 To print all Issue Vouchers at a time or print a range of Vouchers by putting the range into the 

above “FROM” and “TO” boxes.  

 In the mentioning range if there are any blank vouchers, those will not printed even generated. 
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Close Issue Voucher Form 

 Press  button to exit from the Issue Voucher form. 

 You can also exit by pressing the  button at the top right of the form. 

 If you have unsaved invoice during exit, you will be informed that your changes will be lost if 
you exit. 

 Press "Yes" if you do want to exit without saving. Press "No", if you don’t want to close the 
form at this time. 

 

5.4. Adjustment Invoice 

 
 
This form is used for various stock adjustments, like – adjustment after physical stock, item expiry, 
destruction of expired items and return from facility. This form is used to enter Adjustment 
Invoices, edit, and print or delete old invoices. 
 

Open Adjustment Invoice Form 

 Run UIMSv4. 

 Select Invoice > Adjustment Invoice… from Invoice menu. 

 The Adjustment Invoice form is displayed. 
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General Description of Adjustment Invoice Form 

 
 
This form is used to edit, create, delete, and print Adjustment Invoices. The form are grouped into 4 
(four) blocks – 
 
A. Invoice List:  

Invoices can be listed grouped by  

 Invoice No. 

 Invoice Date. 

 Adjustment Type or  

 Prepared By 
 

B. Invoice Entry Fields:  
To describe an invoice, following fields are required. 

 Invoice No* – A unique sequence to represent the invoice. 

 Adjustment Type* – a list of adjustment types to select from. Possible adjustment types are: 
1. Add to Stock: If after physical inventory or any instance, it is found that an item is shown 

less than actual qty in stock 
2. Deduct from Stock: If after physical inventory or any instance, it is found that an item is 

shown excess than actual qty in stock 
3. Receive from Another Upazila: If Upazila receive goods from ther Upazila 
4. Return from SDP (Unusable): When an unusable item is returned from a facility 
5. Return from SDP (Usable): When an usable item is returned from a facility 
6. Return to Warehouse: When item is returned to RWH from where regularly good received 
7. Transfer to Another Upazila: When items need to transfer to Other Upazila 
8. Transfer to Unusable: Expired or Damage items transfer to Usable to Unusable Stock 
9. Unusable Destroy: When expired items are destroyed 
 

 To/From* – Warehouse/Upazila/SDP combo is enabled/disabled based on above which 
Adjustment Type is selected. 

 

 

 

          A 

 

                                                           B 

 

                                                           C 

                                                            D 
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 Prepared By*, Approved By* and Issued By – Name of employees who are responsible for 
adjustment of items. 

 Prepared by Date, Approved by Date and Issued by Date – Relevant dates of the preparation, 
approval and issue of adjustment invoice. 

 Remarks – Comments about the adjustment reasons, outcome etc. 

 Update - Check box to update an Invoice which filled automatically. 

 Cancel - Check box to cancel any Invoice. 
 

C. Invoice Items Entry Fields:  
Invoices consist of line items. There is one line for every item received. Every line has the following 
fields: 

 Item* – Name of item adjusted. 

 Unit – unit of measurement of item. 

 Stock Qty – Current stock quantity in facility performing the adjustment. 

 Qty* – Quantity of goods adjusted. 

 Lot No/Description – Lot no. of the item adjusted. 

 Mfg. Date – Manufacturing date of the item lot adjusted. 

 Expiry Date – Expiry date of goods in the lot. 
 
D. Command buttons:  
A number of buttons to manipulate the Invoices. 
 

View information about a specific Adjustment Invoice 

 
 

 Select the invoice to view from the tree list in Block A. Using the Group By combo box – invoices 
can be grouped in four ways – Invoice No, Invoice Date, Adj. Type or Prepared by. 

 After an Invoice no. is selected – corresponding information is shown in Block B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press "Filter" button 
to list less or more invoice. 
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Enter a new Adjustment Invoice 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 The Invoice No. will be generated automatically. 

 Date fields will be filled with current date. You can change if necessary. 

 Select any Adjustment Type from list. 

 If require select the To/From of Warehouse/Upazila/SDP list. 

 Select the name of employees preparing and approving the invoice. Also mention preparation 
approval and issued dates. 
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 Press  button. 

 Your new Invoice no. will be visible in the Invoice list. 

 
 

 If you want to cancel the new invoice entry, press Esc during editing to undo. 
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Adjustment Invoice Items Entry 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 

 Select an item from Item Name combo box. 

 Unit and Stock Qty will be filled in automatically. 

 Enter Qty. 

 The Lot No./Description, Mfg. Date and Expiry Date fields may be available for editing. If 
available fill up these fields if necessary. 

 
 

 Press <Enter> button to save Adjustment line items. 
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Updating the Stock 
Entry of a new invoice does not update current stock position automatically. After the invoice entry is 
complete, press "Update" button to recalculate the balance of items from the current invoice. 
Note: After the invoice figures are updated to stock, the invoice will be locked – you will not be allowed to 
change any figure. 

 Press "Update" button. 

 A confirmation dialog will appear. 

  
 

 
 Press “Yes” if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of items for which stock was updated. 
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Edit an existing Adjustment Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press “Save” button. 

 If you want to cancel the current editing, press Esc to undo the changes. 
 

Edit an existing Adjustment Invoice Item 

 
 

 Select the Adjustment Invoice item you want to edit from the items list in Block C. 

 
 

 Press F2 or click on any field to start editing. 

 Change the fields as necessary. 

 When done with editing, press “Save” button. 

 If you want to cancel the current editing, press Esc to undo the changes. 
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Delete an existing Adjustment Invoice 

 Select the invoice you want to remove from invoices list. 

 Press "Delete" button. 

 A confirmation dialog will be shown. 

  
 Press “Yes” if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 
 

Delete an Adjustment Invoice Item 

 Select the invoice item you want to edit from the items list in Block-C. 

 Press "Delete" button. 

 A confirmation dialog will be shown. 

  
 

 Press “Yes” if you really want to delete the Adjustment Invoice item. 
 

Search a Adjustment Invoice 

 Press  tab for expanding Receive Invoices form and to find an Adjustment Invoice  
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 Enter the Invoice no. you want to find in ‘Adj. Invoice No, date, adj. type’ in search box 

 filter row header just  
writing Invoice no. and following window will appear: 

 If the Invoice is found then it will be shown selected. 

 
 

Print Adjustment Invoice 

 Press  button to preview the invoice. 

 Press on the printer icon. The print dialog box will appear. 
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5.5. Indent 

 
 

This form is used for various product indent, like – indent before physical stock items not in available in 
upazila stock. This form is used to enter Indent Invoices, edit, update and print or delete not updated 
invoice invoices. 
 
Open Adjustment Invoice Form 

 Run UIMSv4 

 Select Invoice > Indent… from Invoice menu. 

 The Indent form is displayed. 
 

General Description of Indent Form 

 
 
This form is used to edit, create, delete, and print Adjustment Invoices. The form are grouped into 4 
(four) blocks – 
 

 

 

 

          A 

 

                                                           B 

 

                                                           C 

                                                            D 
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A. Invoice List:  
Invoices can be listed grouped by  

 Invoice No. 

 Invoice Date. 

 Prepared By 
 

B. Invoice Entry Fields:  
To describe an invoice, following fields are required. 

 Indent No* – A unique sequence to represent the invoice. 

 Warehouse*– Select a warehouse which will send to indent. 

 Prepared By* and Approved By*– Name of employees who are responsible for indent of items. 

 Prepared By Designation* and Approved By Designation*– Relevant designation of the 
preparation, approval and issue of indent. 

 Prepared by Date and Approved by Date– Relevant dates of the preparation, approval and issue 
of indent. 

 Remarks – Comments about the adjustment reasons, outcome etc. 

 Update - Check box to update an Invoice which filled automatically. 

 Cancel - Check box to cancel any Invoice. 
 

C. Invoice Items Entry Fields:  
Invoices consist of line items. There is one line for every item received. Every line has the following 
fields: 

 Item* – Name of item adjusted. 

 Stock Qty – Current stock quantity in facility. 

 Indent Qty* – Quantity of goods indent. 

 Unit – unit of measurement of item. 
 
D. Command buttons:  
A number of buttons to manipulate the Invoices. 
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View information about a specific Indent Invoice 

 
 

 Select the indent to view from the tree list in Block A. Using the Group By combo box – invoices 
can be grouped in four ways – Invoice No, Invoice Date, and Indent Prepared by. 

 After an Invoice no. is selected – corresponding information is shown in Block B and C. 

 At any time a partial list of invoices are shown based on the Filter Criteria. Only invoices that fall 
between Start Date and End Date are listed. You can change the dates and press "Filter" button 
to list less or more invoice. 
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Enter a new Indent 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 The indent No. will be generated automatically. 

 Warehouse automatically selected which supply to you. 

 Select the name of employees preparing and approving the indent. Also mention preparation 
approval and issued dates. 

 Select designation of prepared by and approve by. 

 Date fields will be filled with current date. You can change if necessary. 

 
 

 Press  button. 

 Your new Invoice no. will be visible in the Invoice list. 
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 If you want to cancel the new invoice entry, press Esc during editing to undo. 

 
Indent Items Entry 

 Press  button from the command buttons block. The form will look like the following screen: 

 
 

 Select an item from Item Name combo box. 

 Unit and Stock Qty will be filled in automatically. 

 Enter Indent Qty. 
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 Press <Enter> button to save indent line items. 

 
 

Updating the Stock 
Entry of a new invoice does not upload to web automatically. After the invoice entry is complete, press 
"Update" button to upload to SCMBD for warehouse download in available internet. 
Note: After the invoice figures are updated, the invoice will be locked – you will not be allowed to change any 
figure. 

 Press "Update" button. 

 A confirmation dialog will appear. 
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 Press Yes if you are sure that the invoice figures are correct. 

 A confirmation dialog will show the number of items for which stock was updated. 

 
Press on ‘OK’ 

 
 

Edit an existing indent Invoice 

 Select the invoice you want to edit from the list of invoices. 

 Change the fields as necessary. 

 When done with editing, press “Save” button. 

 If you want to cancel the current editing, press “Esc” to undo the changes. 
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Edit an existing Indent Item 

 
 

 Select the Indent item you want to edit from the items list in Block C. 

 
 

 Press F2 or click on any field to start editing. 

 Change the fields as necessary. 

 When done with editing, press “Save” button. 

 If you want to cancel the current editing, press “Esc” to undo the changes. 
 

Delete an existing Indent 

 Select the invoice you want to remove from invoices list. 

 Press "Delete" button. 

 A confirmation dialog will be shown. 
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 Press “Yes” if you really want to delete the invoice. 

 You will not be able to delete an invoice that has items under it. First delete the items and then 
delete the invoice. 
 

Delete an Adjustment Invoice Item 

 Select the invoice item you want to edit from the items list in Block-C. 

 Press "Delete" button. 

 A confirmation dialog will be shown. 

  
 

 Press “Yes” if you really want to delete the Adjustment Invoice item. 
 

Search an Indent Invoice 

 Press  tab for expanding Receive Invoices form and to find an indent Invoice  

 
 

 Enter the Invoice no. you want to find in ‘ Invoice No, date, in search box  

 filter row header just  
writing Invoice no. and following window will appear: 

 If the Invoice is found then it will be shown selected. 
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Print Indent  

 Press  button to preview the invoice. 

 Press on the printer icon. The print dialog box will appear. 
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Chapter-6: Field 
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6.1. LMIS Form 2 
 LMIS Form 2 is used to enter union-wise FWAs monthly LMIS report for each commodity.  

 
 

Open LMIS Form 2  

 Run UIMSv4.  

 Select Field > LMIS Form 2… from Field menu.  

 The LMIS Form 2 is displayed.  
 

General Description of LMIS Form 2 

 
 

This form is used for entering FWAs monthly LMIS reporting data of push items. Controls in the 
form are grouped into 4 (four) blocks – 
A. List of SDPs: The LMIS Form 2 grouped by - 

 By Month Year: Month Year wise show the SDP data 

 Union Name: Union wise SDP data. 

 

 

 

          A 

                                                           B 

 

                                                           C 

                                              D 
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 Entry Date: Date wise show SDP data 
 

B. Form 2 Entry Option: Shows various options for selecting the following fields for which Form 
2 is need to be submitted - 

 ID: Automatically filled in this field 

 Union: Automatically filled in this field 

 Entry Date: Need to select in this field 

 Reported Month: Reporting Month of Form 2 data 

 Reported Year: Reporting Year of Form 2 data 

 Total SDPs: Total SDP of that Unions 

 Reports Submitted: Total SDP report submitted of that Unions 
 

C. Details of FWAs:  

 Opening Balance & Received automatically fill-up.  

 Need to be entered Distribution & if any Adjustment (+/-) for that month. Distribution 
and adjustment minus (-) quantity not to be entered more than closing balance.  

 Closing Balance will be calculated automatically. When calculated closing balance is zero 
(0) this field color displaying red. 

 Stock Out Reason Code: Need to enter if any 

 Days Stock-out: Need to enter if any 

 Eligible: Without ticking this field data cannot be enter for that month 

 Eligibility Reason: Need to select from Reasons combo 
 

D. Command buttons: A number of buttons to manipulate the Form 2.  
 
Features of LMIS Form 2 Reporting 

 Only Active SDPs are allowed to give LMIS Form 2 entry. 

 No change can be made in master data (SDP Group, SDP, Reported Month, Reported Year, 

Entry Date) if that form has many records (Opening/receive/distribution/Adjustment) exists. 

 SDP Product Map Active and Deactivate options with reason need to set for each 

commodities for each SDP. User need to set this to eliminating to show Stock-out in Form 7B 

and SCMP. For only first month it need to set and after that it will automatically come to 

next month and if any change require user can change accordingly. 

 Validation on closing balance not possible to entry (-) Negative and showing Red color if 

user try to enter negative entry. 

 MOS calculation on AMD on basis of last 6 months non-zero distribution. 

 If any SDP not eligible for to receive product in that case “Eligible” (Tick). Only who have Tick 

on Eligible can entry Form 2.  

 If any SDP have Stock in hand (Closing Balance) cannot be un-tick the Eligible check box. 
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Enter a new LMIS Form 2  
 

 Press  button from the command buttons block. The form will look like the 
following screen. 

 
 

 The “ID” will be generated automatically 

 Select “Union” from Union combo 

 Entry Date field will be filled with current date. You can’t change the date 

 Select the “Reported Month” and “Reported Year” for which Form 2 is being entered 

 Enter Total number of SDPs and Reports Submitted (both are optional)  

 Press “Save” button and the form will look like the following screen. 

 
 

  



UIMSv4 User’s Guide 

Page 113 of 195 
 

LMIS Form 2 Details Entry  

 Press button from the command buttons block. A dialogue box will appear as like the 
following screen. 

 
 

 Click “Yes” to continue and the following form will appear. 
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 Name of the FWAs of the selected Union will appear automatically.  

 Opening balance & received will appear automatically and by default balance, total and closing 
balance of this month would be equal to opening balance.  

 Enter the distribution of this month, make adjustment (if any). Distribution and adjustment 
minus (-) quantity not to be entered more than closing balance. 

 Closing balance will be calculated automatically. When calculated closing balance is zero (0) this 
field color displaying red. 

 If there any stock out then select the Stock out reason from selection box in the Stock out 
Reason Code field.  

 Without ticking "Eligible" check box you cannot enter data for that SDP. If any SDP have stock 
cannot un-tick the "Eligible" checkbox.  

 Also who have "Zero Closing Balance" they only can deactivate "Eligible" putting "Eligibility 
Reason" from Reasons combo as follows: 
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 Same procedures have to be followed for all contraceptives i.e. Shukhi, Shukhi(3rd Gen), Apon, 
Condom, Injectables, Disposable Syringe, ECP, Tab. Misoprostol (Dose), 7% Chlorohexadine,  
MNP (Susset) and Iron-folic acid pill (Nos). 

 
 

How to edit LMIS Form 2  

 Select the Union you want to edit from the list of unions (block A).  

 Change the fields as necessary.  

 When done with editing, press “Save”.  

 If you want to cancel the current editing, press Esc to undo the changes.  
 

How to delete LMIS Form 2  

 Select the union you want to remove from union list.  

 Press Delete button.  

 A confirmation dialog will be shown. 

  
 

 Press “Yes” if you really want to delete the Form 2.  
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 You will not be able to delete a Form 2 that has items under it. First delete the items and then 
delete the Form 2. (see below how to delete items from Form 2) 
 

How to edit LMIS Form 2 Items  

 Select the invoice item you want to edit from the items list in block C. 

 
 

 Press F2 or click on any field to start editing. 

 
 

 Change the fields as necessary.  

 When done with editing, press “Save”.  

 If you want to cancel the current editing, press “Esc” to undo the changes. 
 

How to delete LMIS Form 2 Items  

 Select the union you want from where you want to delete from the union list in block A.  

 Select the item i.e. Pill, Condom, Injectable, ECP and Misoprostol  

 Press “Delete” button.  

 A confirmation dialog will be shown. 

  
 Press “Yes” if you really want to delete the invoice item. You have to repeat the same 

procedure to delete each item from LMIS Form 2. 
How to filter month-wise LMIS Form 2 Reports  

 Click the tab “Filter Criteria”, select the start and end month, year.  

 Then click the Filter button as shown in the following figure. 
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 Only the filtered months will be shown in the union list at block A 

 
6.2. LMIS Form 3 

 

 LMIS Form 3 is used to enter FWV, SACMO, NGO and Multi-sectoral’s data for each commodity. 

Open LMIS Form 3 

 Run UIMSv4 

 Select Field > LMIS Form 3… from Field menu.  

 The LMIS Form 3 is displayed. 
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General Description of LMIS Form 3 

 
This form is used to edit, create, delete and print LMIS Form 3. The form are grouped into 4 (four) 
blocks – 
 
A. List of SDPs: SDP list grouped by - 

 By Month Year: Month Year wise show the SDP list. 

 Facility Name: SDP name wise list of SDP. 

 Entry Date: Date wise show the SDP list 
 

B. Form 3 Entry Option: Shows various options for selecting the following fields for which Form 3 is 
need to be submitted - 

 SDP Group: Automatically filled in this field 

 Reported Moth: Automatically filled in this field 

 Reported Year: Automatically filled in this field 

 Entry Date: Automatically filled in this field 

 SDP: Need to select SDP from SDP list combo 
 

C. Details of Item: The Form 3 after entering block B user need to fill following fields: 

 Opening Balance and Received this month automatically fill-up.  

 Need to be entered Distribution & if any Adjustment (+/-) for that month.  Distribution and 
adjustment minus (-) cannot be entered more than closing balance. 

 Closing Balance will be calculated automatically. When closing balance zero (0) then the 
closing balance field color will be red. 

 Stock Out Reason Code: Need to enter if any 

 Days Stock-out: Need to enter if any 

 Eligible: Without ticking this field data cannot be enter for that month 

 Eligibility Reason: Need to select from Reasons combo 
 
D. Command buttons: A number of buttons to manipulate the Form 3. 

 
 

 

 

 

          A 

                                                           B 
 

                                                           C 

                                              D 
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Features of Form 3 Reporting 

 Only Active SDPs are allowed to give LMIS Form 3 entry. 

 No change can be made in master data (SDP Group, SDP, Reported Month, Reported Year, Entry 

Date) if that form has many records (Opening/receive/distribution/Adjustment) exists. 

 SDP Product Map Active and Deactivate options with reason need to set for each commodities 

for each SDP. User need to set this to eliminating to show Stock-out in Form 7B and SCMP. For 

only first month it need to set and after that it will automatically come to next month and if any 

change require user can change accordingly. 

 Validation on closing balance not possible to entry (-) Negative and showing massage closing 

balance can’t be less than zero. Please enter correct value.  If user try to enter more than 

closing balance the entered data will not to be saved. 

 MOS calculation on AMD on basis of last 6 months non zero distribution. 

 If any SDP not eligible for to receive product in that case “Eligible” (Tick). Only who have Tick on 

Eligible can entry Form 3.  

 If any SDP have Stock in hand (Closing Balance) cannot be un-tick the Eligible check box. 

 
Enter a new LMIS Form 3 
 

 Press  button from the command buttons block. The form will look like the 
following figure. 

 
 

 The ID will be generated automatically. 

 Entry Date field will be filled with current date. You can’t change the date.  

 Select SDP Group and then the name of the SDP  

 Select the reported month and year for which Form 3 is being entered.  

 Press “Save” button. 

 The form will look like the following figure. 
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LMIS Form 3 Details Entry 

 Press button from the command buttons block. A dialogue box will appear as like the 
following figure. 

 
 

 Click "Yes" to continue and the following form will appear. 
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 Opening balance and received of this month will appear automatically and by default balance, 

total and closing balance of this month would be equal to opening balance.  

 Enter the distribution of this month make adjustment (if any). Distribution and adjustment 

minus (-) cannot be entered more than closing balance. 

 Closing balance will be calculated automatically. When closing balance zero (0) then the closing 

balance field color will be red. 

 If there any stock out then select the Stock out reason from select box in the Stock out Reason 

Code field.  

 Without ticking "Eligible" check box you cannot enter data for that SDP. If any SDP have stock 

cannot un-tick the "Eligible" checkbox.  

 Also who have "Zero Closing Balance" they only can deactivate "Eligible" putting "Eligibility 

Reason" from Reasons combo as follows: 
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How to edit LMIS Form 3  

 Select the SDP you want to edit from the list of SDPs (block A). Change the fields as necessary.  

 When done with editing, press “Save”.  

 If you want to cancel the current editing, press Esc to undo the changes. 
 

How to delete LMIS Form 3  

 Select the SDP you want to remove from SDP list.  

 Press “Delete” button.  

 A confirmation dialog will be shown. 
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 Press “Yes” if you really want to delete the Form 3.  

 You will not be able to delete a Form 3 that has items under it. First delete the items and then 
delete the Form 3 (see below how to delete items from Form 3). 
 

How to edit LMIS Form 3 Item 

 Select the SDP you want to edit from the list in block C. 

 
 

 

 Press F2 or click on Distribution this Month field to start editing.  

 Change the fields as necessary.  

 When done with editing, press Enter or click outer box.  

 If you want to cancel the current editing, press Esc to undo the changes. 
 

How to delete LMIS Form 3 Items  

 Select the SDP you want to delete from the SDP list in block A.  

  Press “Delete” button.  

 A confirmation dialog will be shown. 
 

  
 Press “Yes” if you really want to delete the invoice item. 
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How to filter month-wise LMIS Form 3 Reports 

 
 

6.3. LMIS Form 7B 
Based on the inputs given by various SDPs and items received and issued by the Upazila LMIS Form 
7B will be generated automatically by this module.  

 

 
Open LMIS Form 7B  

 Run UIMSV4 

 Select Field > LMIS Form 7B… from Fields menu.  

 The LMIS Form 7B screen is displayed.  
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General Description of LMIS Form 7B 

 
 
Controls in the form are grouped into 5 (Five) blocks –  
 
A. List of Months:  
 Shows the months for which LMIS Form 7B will be generated with group by - 

 Reported Month 

 Reported Year 

 Uploaded 

 Upazila.  
 
B. LMIS Form 7B Entry Option:  
 Shows options for selecting -  

 ID, Upazila & District field automatically generated 

 Reported Month & Reported Year need to select from combo for which Form 7B will be 
generated. 

 
C. Details of Items:  

 Details of all 28 commodities i.e. Opening balance, how much have been received, issued 
and adjusted, Closing Balance. MOS etc. will be shown here. 

 
D. Command buttons:  

 A number of buttons to manipulate the Form 7B.  
 

E. Upload LMIS Form 7B:  

 It’s a new feature. By connecting into internet Upazila now can upload their monthly 
Form7B report directly into LIMS web site. 

 
Features of LMIS Form 7B 

 Create Form 7B master. 

 

 

 

          A 

                                                           B 

 

                                                           C 

          E                             

E 

                                                         D  
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 Create Form 7B Items for this Month receive, issue and adjustment invoice create & update 
status show. 

 After press "Post" button for this month receive, issue and adjustment invoice can’t be update. 
 

Generate a new LMIS Form 7B  

 Press  button from the command buttons block and the form look like as follows: 

 
 

 Each option except Month and Year will be generated automatically.  

 Select the month and year for which Form 7B will be generated.  

 Press “Save” button the form will look like the following screen: 
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Generation of Form 7B Details 

 Press  button from the command buttons block. If you incomplete any works in this 
month (issue, receive, form 2 and form 3) A dialogue box will appear as like the following screen. 

 
 

 Or if you have missing entry any MIS form 2 or 3 in this month. A dialogue box will appear as like 
the following screen. 

 
 

 Or if you have entry Ad syringe (1ML) dispense Qty less than Injectable (Vials) dispense qty in MIS 
form 2 or 3 in this month. A dialogue box will appear as like the following screen. 
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 Else the following form will appear: 

 
 

 Click “Yes” to continue and the following form will appear: 
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 No can changed master data if it have many records exists. No change can be made in master 

data (Upazila, District, Reported Month, Reported Year etc.) if that form has many records 
(Upazila Stock, Field Stock etc.) exists. 

 Message showing how many invoices not yet updated for a specific month. User cannot 
Generate Form 7B if any non-updated vouchers (Receive, Issue/Adjustment) and any pending 
entry of Form 2 & 3 for that month. After updating all vouchers and entered all SDP’s reports 
user only can be generate Form 7B for that month. 

 Validation on last month closing balance this month opening balance mismatch and store issue 
and field receive mismatch showing Red color, in that case not possible to post Form 7B. 

 Not possible to enter (-) Negative value and showing Red color if user try to enter negative 
entry. 

 If there any mismatch in F7B user could not post the F7B 

 After Posted Form 7B no update/create/edit any Invoices for that month. 

 Only allowed to upload Posted Form 7B data in SCMP. 

 MOS calculation on Average Month Distribution (AMD) on basis of last 6 Months Non Zero 
Distribution. 
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 All data will be generated automatically.  
 

Preview and Print LMIS Form 7B  

 Press Preview button to preview the supply plan which will be like the following figure. 

 
 Press on the printer icon. The print dialog box will appear.  

 
Post LMIS Form 7B Report 

 After generating LMIS F7B Report correctly then press Post button. 
 NB. Before post F7B report check correctly. Posted F7B could not Regenerate. 
 After pressing “Post” (if any record mismatch) the dialog will appeared  

 
 

Else the following screen will appear: 
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 Press “Yes”, After post the following screen will appeared: 

 
 
 

 Press “OK” and following window will appear: 
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Upload LMIS Form 7B Report 

 After Posting F7B then press "Upload Form 7B" button 

 
(Note: Make sure your computer have internet connected) 
 

Message shown (Do you really want to Upload form 7B Data to SCMP Report) 
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Press “Yes” button then after uploading look like following screen: 

 

Press on “Ok” then data Upload and download start automatically.  
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6.4. Supply Plan 
Based on the inputs given by various SDPs a Supply Plan will be generated automatically as 
follows. 

 
 

Open Supply Plan  

 Run UIMSv4 

 Select Field > Supply Plan… from Field menu.  

 The Supply Plan screen is displayed. 

 

General Description of Supply Plan Form 

 
 

This Supply Plan Form is grouped into 5 (five) blocks – 
 

A. List of Month-Year:  

 Showing the Reported Month & Year lists for which Supply Plan will be generated. 
 

 

 

 

            A 

                                                           B 

 

                                                                C 

                                    E 

D 
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B. Supply Plan Entry Option:  
Show options for selecting following fields for which Supply Plan will be generated - 

 Reported Month: This is a Month combo field 

 Reported Year: This is a Year combo field 

 Upazila & District: These fields are automatically comes from the system   
 

C. Details of SDPs:  
The following field’s information is required to generate Supply Plan - 

 SDP: List of FWAs, FWVs, Multisectoral, NGOs  

 AMD: Average of last 6 months Distributed based on data availability 

 Max Quantity: Based on Calculation (AMD multiply by 3) 

 Closing Balance: Field Closing balance of last month of SDP 

 Allotted Quantity: Based on calculation (Max Qty – Closing Balance) 

 Actual Supply Quantity: Quantity which need to be distributed for this month 

 Updated Invoice No: Update status of Issue Invoices which generated from Supply Plan 

 AMD Month: How many no of months used to calculate AMD. 
 

D. Commodity Selection & Rationing: 

 Normally Supply Plan is done at the start of every month to calculate issue quantity.  

 This block contains the items which are normally issued based on Supply Plan –  
1) Condom, 2) Pill, 3) IUD &, Injectables & Ad syringe (1ML) 

 Under all of above four Item Tab, total planned quantity and current stock quantity as on 
supply plan of the current date is shown.  

 When the plan quantity is less than or equal to current stock quantity – the Supply Quantity 
box is GREEN. When the supply quantity is more than stock quantity, it shows as RED.  

 There are 4 (four) boxes below every item. When there is scarcity of items, then putting a 
certain percentage in any box – then pressing the "Recalculate" button will reduce that 
item’s Actual Supply Quantity for all SDPs. 

 Actual Supply Quantity fields are editable. As per users decision they could 
increase/decrease actual quantity fields manually.  
(AD Syringe closing balance should be in Supply Plan, and based on current stock, 10% 
additional added with Depo quantity and checked with closing balance) 

E. Command Buttons:  
A number of buttons to manipulate the Supply Plan. 
 

Common Features of Supply Plan  

 Create Supply Plan Master first then go for generation of Supply Plan Items and Issue Voucher 

without that it will not work; 

 After creating Supply Plan Master then create Supply Plan Items; 

 To edit/update/delete Supply Plan Items+ 

 Only can update Supply Plan Item for which issue vouchers yet not update; 

 Only can delete Supply Plan Item for which is not generated issue vouchers; 

 Delete Supply Plan Item not possible if those Issue Vouchers are already created. 
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Generate a new Supply Plan 
 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 The ID will be generated automatically. 

 Select the “Month” and “Year” for which Supply Plan will be generated. 

 Press “Save” button. The form will look like the following screen: 
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Generation of Supply Plan Details 

 Press  button from the command buttons block. A dialogue box will appear as like the 
following screen: 

 
 

 Only Active SDPs allowed to create Supply Plan with Max 6 Months AMD. 

 No blank Issue Vouchers are generated from Supply Plan in UIMSv4. User can view Issue 
Vouchers Number and Update status which generated from Supply Plan. 

 After updating any Issue Vouchers which generated from Supply Plan cannot regenerate/delete  
issue vouchers. Only previously generated non-updated Issue Vouchers can be 
regenerated/deleted and recreated keeping same Issue Invoice Number. 

 Click “Yes” to continue and the following form will appear. 

 All data will be generated and shown click “Yes” to continue and the following screen will 
appear. No one can changed master data if it have many records exists. No change can be made 
in master data (Upazila, District, Reported Month, Reported Year etc.) if that form has many 
records (Condom, Shukhi, IUD, Injectables and Ad syringe (1ML)) exists. 
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 Showing the following successful message:  
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Rationing of Supply Plan 

 Sometime Upazila required rationing of commodities based on Stock availability. The system 
can rationing of all Push Item using this Supply Plan.  

 
 

 After putting the rationing percentage at the above "Rationing %" boxes and press 
"Recalculate" button, all the "Actual Supply Quantity" fields will be recalculated based on 
percentage assigned for respective items. For example we put 10% rationing on Condom and 
following screen show the effect: 

 
 

 Actual Supply Quantity fields are editable. As per UFPO's decision they could increase/decrease 
actual quantity fields manually. 

 
 

 Note that the edited Actual Supply Quantity fields will be overwrite if you click "Recalculate" 
button so make sure to take note on those manual editing before clicking "Recalculate" button 
if you did any manual correction on Actual Supply Quantity fields. 
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Preview and Print the Supply Plan 

 Press “Preview” button to preview the Supply Plan which will be like the following screen. 

 
 

 Press on the printer icon. The print dialog box will appear. 
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Generate Issue Voucher using Supply Plan 
After Supply Plan generation has been completed, need to generate Issue Voucher automatically 
from Supply Plan:  

 
 

 Press “Generate Issue Voucher” button on Supply Plan. 

 
 

 After pressing “Generate Issue Voucher” the massage will shown 

 Press “Yes” the massage will shown 



UIMSv4 User’s Guide 

Page 142 of 195 
 

 
 

 
 

 Press “OK” 
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 Then you see the Voucher No. will be shown on “Supply Plan” and vouchers also shown in the 
“Issue Voucher” entry form. 

 If any Supply Plan generated Issue Vouchers has been updated the status also will be shown on 
Supply Plan screen as Lock icon. 

 
 

N.B: Updated SDP’s issue voucher cannot be re-generate issue voucher. But un-updated SDP’s Issue 
voucher can be re-generated. 
 

Issue Voucher Generate from Supply Plan based on Stock Availability 

 To generate Issue Voucher for all SDPs from Supply Plan of a specific item will be generated 

based on that item's Stock balance availability i.e. Issue Voucher for SDPs will be generate until 

available Stock in hand.  

 For example if Condom in hand 10,000 at upazila store but based on Supply Plan total 

requirement of Condom is 12,000. In that case when you generate Issue Voucher from Supply 

Plan the system will generate Issue Vouchers from beginning of the SDP list as per their 

required quantity until 10,000 quantity allocated to SDPs rest of 2,000 could not be allocated to 

remaining SDPs. Which will be generate later on after Stock received or rationing of quantity 

allocation in Supply Plan. 
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6.5. Custom Supply Plan 
To access Field Reports follow the following steps- 

 Run UIMSv4 

 Select Field > Custom Supply Plan from Field menu. 

 The Custom Supply Plan form is displayed. 

 

For issuing particular item to several facilities – custom supply plan for selective items. Select multiple 

facilities and select multiple products then generate issue vouchers. With editing option as variable 

editable quantity. 

Generate Custom Supply Plan 

 

 Select products from left side product list and press on “>>” button to creating Custom Supply Plan 
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 Enter your custom supply plan profile name and press on ‘Save’ button. After pressing see the 

following screen - 

 

 Press on “Next”. After pressing next will see the following screen. 
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 Enter the product quantity which will be issued against SDP’s. Press on “Next” after pressing will 

see the following massage. 

 

 Press on “Yes”. After pressing custom supply plan products will saved and displaying following 

screen for select SDP. 

 

 Select SDP’s from left side SDP’s list and press on “>>” button to transfer right side for creating 

custom supply plan. See the following screen. 
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 Press on “Next”. After pressing will see the following massage.  

 

 Press on “Yes”. After pressing will see the following screen - 
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 Press on “Next”. After pressing will see the following massage - 

 

 Press on “Yes”. After pressing massage displayed ‘Issue voucher Generate successfully’ like 

following screen - 

 

 Press on ‘Ok’. After pressing generated issue voucher form will be displayed like following screen - 
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6.6. Field Reports 
To access Field Reports follow the following steps- 

 Run UIMSv4 

 Select Field > Field Reports from Field menu. 

 The Field Reports form is displayed. 
 
This form contains 5 (five) reports related to field/SDPs. 

 

SDP Stock Out Report  
The first report presents information about SDPs who are stock out in any specific item.  

 Select the Reported Month & Reported Year for which you want to see the report.  

 Item Group, Item Name & Facility (SDP) selection is not mandatory.  

 Select the Preview button to view the report. A snapshot of "SDP Stock Out Report"  
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Form 2/3 Submission Report  
The second report presents information about SDP report submission status for any month.  

 Select the Reported Month & Reported Year for which you want to see the report.  

 Select the Preview button to view the report. 
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SDP Distribution Report 
The third report presents information about commodity distribution/consumption by SDPs.  

 Select the Month-Year range and optionally Item Group, Item Name & Facility.  

 Select the Preview button to view the report. 
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SDP Distribution Summary 
The forth report presents information about commodity distribution/consumption by SDPs.  

 Select the Month-Year range and optionally Item Group, Item Name & Facility.  

 Select the “Preview” button to view the report. 

 
 



UIMSv4 User’s Guide 

Page 153 of 195 
 

 
 

SDP Closing Summary 
The fifth report presents information about commodity distribution/consumption by SDPs.  

 Select the Month-Year range and optionally Item Group, Item Name & Facility.  

 Select the “Preview” button to view the report. 
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SDP Ledger Report 
The fifth report presents information about commodity distribution/consumption by SDPs.  

 Select the Month-Year range and optionally Item Group, Item Name & Facility.  

 Select the “Preview” button to view the report. 
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6.7. DDS Kits Reporting 
 The DDS Kits Reporting is used to enter 28 Items DDS Kit to distribute to FWV. 

 

 
Open DDS Kits Reporting Form 

 Run UIMSv4 

 Select Field > DDS Kits Reporting… from Field menu.  

 The DDS Kits Reporting Form is displayed. 
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General Description of DDS Kits Reporting 

 
 
This form is used for entering reporting of 28 DDS Kits items consumption data to FWV. Controls in 
the form are grouped into 4 (four) blocks –  
 
A. List of SDPs by Month Year: Shows month wise list of the FWVs.  
 
B. DDS Kits Form Entry Option: Shows various options for selecting  

 ID: Id automatically generate 

 SDP Group: Default group FWV always selected 

 SDP: Need to select the SDP under FWV group 

 Reporting Month: Select from Month combo 

 Reporting Year: Select from Year combo for which DDS Kits Report is submitted. 
  
C. Details of Item:  

 Sl No: Number comes automatically 

 Name of Medicine: Name of 28 DDS Kits Medicine list 

 Opening Balance: Automatically comes 

 Received: Need to enter 

 Total: Opening plus Received 

 Distribution: Need to enter 

 Adjustment (+): Need to enter if any 

 Adjustment (-): Need to enter if any 

 Closing Balance: Closing balance will be calculated.  
 

D. Command buttons: A number of buttons to manipulate the DDS Kits. 
 
Features of DDS Kits Reporting 

 Only Active SDPs are allowed to give DDS Kit entry. 

 For first month user allowed to give entry the opening balance only then for next month 
opening balance automatically came from previous month closing balance. 

 

 

 

          A 

B 

 

                                                            

C 

D 
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 Validation on closing balance not possible to entry (-) Negative and showing Red color if 
user try to enter negative entry. 

 DDS kit (28) items entry on SCMP with multiple factor downloaded in UIMSv4. User can not 
add/edit any DDS kit items in UIMSv4. 

 
Enter a new DDS Kits Report 

 Press  button from the command buttons block. The form will look like the following 
screen: 

 
 

 The ID will be generated automatically. 

 You can’t change the date.  

 Select SDP Group and then the name of the SDP  

 Select the reported month and year for which form 3 is being entered.  

 Press “Save” button. 
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DDS Kits Details Entry  

 Press  button from the command buttons block. A dialogue box will appear as like the 
following screen: 

 
 

 Click “Yes” to continue and the following form will appear. 
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 Opening balance will appear automatically with a default balance, before enter receive and 

distribution the Total and Closing balance of this month would be equal to Opening balance.  

 Enter the received of this month, make adjustment (if any), distribution of this month. Closing 
balance will be calculated automatically.  

 
 

How to edit DDS Kits Report  

 Select the SDP you want to edit from the list of SDPs (block A). Change the fields as necessary.  

 When done with editing, press “Save”.  

 If you want to cancel the current editing, press Esc to undo the changes. 

 Select the SDP you want to edit from the list in block C. 
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 Press F2 or click on any field to start editing.  

 Change the fields as necessary.  

 When done with editing, press “Save”.  

 If you want to cancel the current editing, press Esc to undo the changes. 
 

How to delete DDS Kits Report  
Select the SDP you want to remove from SDP list.  

 Press “Delete” button.  

 A confirmation dialog will be shown. 

 
 

 Press “Yes” if you really want to delete the DDS Kits Report.  

 You will not be able to delete DDS Kits Report that has items under it. First delete the items and 
then delete the DDS Kits Report. 
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How to filter month-wise SDP list 
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Chapter-7: Stock 
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7.1. Stock Balance 
Stock Balance form presents the current status of stock items at any time. Initially the form shows 
stock balance of all the stock items up o current date. Stock balance of any date can be viewed by 
changing the Balance Date. 

 
 
View Stock Balance 

 Run UIMSv4 

 Select Stock > Stock Balance… from Stock menu. 

 The Stock Balance form is displayed. 

 
 

This form presents current stock position of all the items. Controls in the form are grouped into 3 
(three) blocks – 
A. Item Group & Balance Date:  
Shows a list of current item groups in database. A label below shows the total number of items 
under the selected group. Balance Date is used to give a filter date for which stock position is 
shown. 
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B. List of Items:  
Shows status of every item under the selected group. To describe an item, 5 (five) fields are 
required. 

 Item Code – Unique Item Code. 

 Item Name – Name of the item. 

 Usable Qty – Usable stock quantity of the item on balance data. 

 Unusable Qty – Unusable quantity of item on balance date. 

 Unit – Unit of measurement of the item. 
 
C. Command buttons:  
A number of buttons to manipulate the stock status. 
 

View Stock Balance of a specific Date 

 If you want to view stock status of all items, select ‘(All)’ from Item Group combo in block A. If 
you want to view a specific group, select the group name from the combo. 

 Initially Balance Date is filled with today’s date and stock status for that date is presented. 

 Type in the desired date in Balance Date field and press <Enter> to get the stock status of that 
date. 

 To exclude the items that are out of stock, select ‘Show Only Non-Zero Stock’. 
 

Search and find an Item 

 Type you provide the item name in search box. 

 Items which match with the search text will be shown in the list. 

 
 To see all of the items again, remove you provide the item name from search box. 
 

View lot-wise information about a specific item 

 Select the item for which you want to view lot-wise information. 

 Press Lot-wise button from the command button block 

 A dialog like the following screen will appear: 
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Print Stock Balance 

 Press “Preview” button to view a printable list of Stock Balance. 

 
 Press on the printer icon. The print dialog box will appear. 
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7.2. Stock Reports 
The Stock Reports Form is used to view stock reports based on specific criteria. Both summary and 
detailed stock information can be viewed and printed. A typical view of the form shown in below: 

 
 

The controls in the Stock Reports Form is grouped in 4 (four) blocks – 
A. Tab of Reports: Currently there are 6 (Six) reports – first one is a summary report and others are 

transaction details. 

B. Filter Dates: Provide the date(s) which will be used to filter the report data. 

C. Group/Item and Facility Criteria: A number of optional filter criteria that control the output of 

the report. 

D. Command Buttons: Export, Preview and Close button. 

 
How to Print a Report 

 Select a report from the "List of Reports" menu. 

 Provide date(s) in the "Filter Date(s)" block. 

 Optionally select options from "Group/Item and Facility Criteria" block. 

 Press button to preview the Invoice. 

 Press on the printer icon. The print dialog box will appear. 

 Optionally provide Print Range, Copies and press OK. If you want to print only one copy of 

the whole report, then just press OK. 

 After printing, press the leftmost  button to close the preview window. 

 
How to Export a Report 

 If you need to export select export format and press  button  

 After pressing windows dialog will be shown save the export document. 
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7.2.1. Stock Summary 
This report shows the stock status at a certain date. To print the report follow the following steps: 

 Select 'Stock Summary' tab from ‘Stock Reports’ menu. 

 
The ‘Summary Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on button now, stock summary of all the items on current date will be printed. 

 If you want to know the stock status of a previous date, type in the date in ‘Summary Date’ box. 

 To print stock status of a specific group select the group from ’Item Group’ box. The form 
appear as follows: 

 
 

 Press  button to continue. 

 

 If you need to export select export format and press  button. 
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7.2.2. Stock Summary by Lot 
This report shows the lot-wise stock status at a certain date. To print the report, follow the 
following steps:  

 Select ‘Stock Summary by Lot’ tab from ‘Stock Reports’ block. The form will look like the 
following screen: 

 
 The "Summary Date" box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ 

box. If you click on “Preview” button now, stock summary of all the items on current date will 
be printed. 

 If you want to know the stock status of a previous date, type in the date in ‘Summary Date’ box. 

 To print stock status of a specific group select the group from ’Item Group’ box. The form 
appear as follows: 

 
 

 Press “Preview” button to continue. 

 

 If you need to export select export format and press  button. 
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7.2.3. Digital ICR 
This report shows the details transaction of items between specific dates. To print the report, 
follow the following steps: 

 Select ‘Digital ICR tab from ‘List of Reports’ block. The form will look like the following screen: 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on button now, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select Item Group, Item Name and the form appear as follows: 

 
 

 Press  button to continue. 

 

 If you need to export select export format and press  button. 
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7.2.4. Receive Report 
This report shows the details of issued items by facility between the specific dates. To print the 
report, follow the steps - 

 Select ‘Stock Details by Facility’ option in ‘List of Reports’ block.  

 
 

 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. 

If you click on button now, stock details of all the items on current date will be 
printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group and then an Item Name & Facility (optional).  

 The form have extra 3 (three) radio button 1) All, 2) National Receive and 3) Receive from 
Warehouse. Details are given below: 

 
All Receive: 
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7.2.5. Issue Details by Item 

 
This report shows the details of issued items by Item between the specific date ranges. To print the 
report, follow the steps - 

 Select ‘Stock Details by Item’ option in ‘List of Reports’ block.  

 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 
you click on “Preview” button now, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select Item Group, Item Name & Facility (all are optional). The form appear as follows: 

 
 

 Press “Preview” button to continue 

 
 

 If you need to export select export format and press  button. 
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7.2.6. Issue Details by Facility 

 
This report shows the details of issued items by facility between the specific dates. To print the 
report, follow the following steps:  

 Select ‘Stock Details by Facility’ option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on “Preview” button now, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group, Item Name & Facility (all are optional). The form appear as follows: 

 Press “Preview” button to continue. 
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7.2.7. Stock Expiry by Lot 

 
 

This report shows the details of Stock expiry by lot between specific dates. To print the report, 
follow the steps: 

 Select ‘Stock Expiry by Lot’ option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group and then an Item Name & Facility (Optional). The form may appear as 
follows: 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button  
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7.2.8. Adjustment Report 

 
 

This report shows the details of Stock adjustment between specific dates. To print the report, 
follow the steps: 

 Select ‘Adjustment report option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group and then an Item Name & Facility (Optional). The form may appear as 
follows: 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button  
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7.2.9. Stock Transaction by Lot 

 
 

This report shows the details of Stock Transaction by lot between specific dates. To print the report, 
follow the steps: 

 Select ‘Stock transaction by Lot’ option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group and then an Item Name & Facility (Optional). The form may appear as 
follows: 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button  
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7.2.10. Physical Inventory 

 
 

This report shows the details of Physical Inventory between specific dates. To print the report, 
follow the steps: 

 Select ‘Physical Inventory’ option in ‘List of Reports’ block. 

 
 The ‘End Date’ box is filled with current date, and ‘(ALL)’ is selected in the ‘Item Group’ box. If 

you click on  button, stock details of all the items on current date will be printed. 

 To view report between two dates – provide the dates in ‘Start Date’ and ‘End Date’ box. 

 Select an Item Group. The form may appear as follows: 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button  
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7.3. Slow Moving Item list 
This report shows the details of Slow Moving item List specific dates. To print the report, follow the 
steps: 

 Select ‘Slow Moving item List’ option in ‘List of Reports’ block. The form will look like the 
following screen: 

 
 

 Press  button to continue. 

 
 

 If you need to export select export format and press  button  
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Chapter-8: Administrator 
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8.1. Options 
 Go to Administrator > Options from Administration menu 

 
 

 After pressing "Options" the following screen will be appeared: 

 
When an employee transfer or join in an UFPO/UFPAs who signatories in the UIMS software 
then you have to add his/her name in UIMS software. For this you need to update options for 
signatory assign. 

 
Update Options 

 The set of “Prepared By, Approved By & Issued By” of Issue Invoice are come from Options 
menu. When any of these three signatories will change you need to edit.  

 
 From the prelisted Employee list you have to select/edit the name for Prepared By, Approved 

By and Issued By if any change require.  

 To set Store type from ‘Store Type’ combo where you found all type of stores available in DGFP. 
The list of stores are given below -  
1. One Storied Store 
2. Two Stories Office Cum Store 
3. Three Storied Building 
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4. In DDFP Office Building 
5. In Divisional Director Office Building 
6. In UHC Office Building 
7. In Upazila Parishad 
8. In Rental House, In MCWC and  
9. Others 

 
   

 If you need to cancel settings Press  button before save. 

 After setting “Prepared By, Approved By & Issued By” and “Store type” then press  
button. 

 
 

 Press  button. 
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8.2. Data Download 
 Run UIMSv4 

 Select Administrator > Data Download from Administrator menu. 

 The Data Download form is displayed. 

 
 After showing data download press "Start Data Download" button.  

(N.B. Make sure your computer have internet connected) 
 

8.3. Data Upload 
 Run UIMSv4 

 Select Administrator > Data Upload from Administrator menu. 

 The Data Upload form is displayed. 

 
 

 After showing Data Upload press "Start Data Upload" button. 
(N.B. Make sure your computer have internet connected) 
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8.4. Backup Database 
From this form, you can take backup of the entire database. The backup will be generated as a 

computer-generated file in a pre-defined directory. The file can be copied and or moved to another 

folder in the same computer, remote another computer or e-mail to CWH. If the computer crashes 

or data becomes corrupt this backup can be used to get all data backup.  

How Backup database: 

 Run UIMSv4 

 Select Administrator > Backup Database from Administrator menu. 

 The Backup Database form is displayed. 

 
 

 Press button  from the command buttons block. The form will look like following: 

 
 

After completing the backup generation the following screen will appear: 
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 To make a copy of the file or email it, you have to find the file from its location which is 

normally the Backup folder under the software installation folder. 

 To make a copy of the file to pen drive, locate the file from its location, and then copy to pen 
drive. 

 After backup is complete, you can close the form using Close button. 
 

8.5. Unit 
 Run UIMSv4 

 Select Administrator > Unit from Administrator menu. 

 The Unit form is displayed - 

 
 

This form is used to edit, create, delete, print Unit. The form are grouped into one block – 
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View Fields: Unit Id and Unit  
 
Print Unit List: 

 Press  button to view a printable list of Item Groups. 

 
 

8.6. Adjustment Type 
 Run UIMSv4 

 Select Administrator > Adjustment Type from Administrator menu. 

 The Adjustment Type form is displayed. 

 
 
View Fields: Adjustment type, Adjustment name, Usable In, Usable Out, Unusable In and Unusable 
Out.  
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Print Adjustment Type list: 

 Press “Preview” button to view a printable list of Adjustment Type: 

 
 Press on the printer icon. The print dialog box will appear. 
 

8.7. Employee Designation 
Store Commodities are used by designated Employee in every Store as like (Store Keeper, Store 
Manager) 

 Run UIMSv4 

 Select Administrator > Employee Designation from Administrator menu. 

 The Employee Designation entry form is displayed. 

 
 
This form is used to edit, create, delete, export and print Designation. The form are grouped into 2 
blocks – 
View Fields: Designation Code and Designation 
Print Designation list: 

 Press “Preview” button to view a printable list of Designation. 
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 Press on the printer icon. The print dialog box will appear. 
 

8.8. Indentors Designation 
 Run UIMSv4 

 Select Administrator > Indentors Designation from Administrator menu. 

 The Indentors Designation form is displayed. 

 
 

 This form is used to edit, create, delete and print Indentors Designation.  

 The form are grouped into 2 fields: Designation Code and Designation. 

 Press “Preview” button to view a printable list of Indentors Designation. 
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 Press on the printer icon. The print dialog box will appear. 

 

8.9. Facility Group 
 Run UIMSv4 

 Select Administrator > Facility Group from Administrator menu. 

 The Facility Group Entry form is displayed. 

 
 

 This form is used to edit, create, delete, export and Print Facility Group Unit.  

 The form is grouped into 2 View Fields: Facility Group Code and Facility Group Name.  

 Press  button to view a printable list of Facility Group. 
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 Press on the printer icon. The print dialog box will appear. 

 

8.10. Form Item Settings 
 Run UIMSv4 

 Select Administrator > Form Item Settings from Administrator menu. 

 The Form Item Settings form is displayed as follows: 

 
 This form is used to view and print Month List and this have two Tabs: 1) Form2 2) Forn3 and 3) 

Form7B 

 The form is grouped into 4 fields 1) Set, 2) From Date, 3) To Date and 4) Set Items (Item Code, 
Item Name, Linked Item, Print). 
 

8.11. Supply Plan Item Serial 
 Run UIMSv4 

 Select Administrator > Supply Plan Item Serial from Administrator menu. 

 The Supply Plan Item Serial form is displayed. 
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 This form is used to edit, create, delete and print Supply Plan item serial.  

 The form is grouped into 2 View Fields: Item Code, Item Name, Rounding Factor and Multiplying 
Factor.  
 

8.12. DDS Kits Item Serial 
 Run UIMSv4 

 Select Administrator > DDS Kits Item Serial from Administrator menu. 

 The DDS Kits Item Serial form is displayed. 
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8.13. How to change UIMSv4 Themes 
 Run UIMSv4 

 Select Administrator >  from Administrator menu. 

 Click on the available “Themes” icon and select your favorite theme for displaying UIMS screen. 
Look like the following screen: 

 

 The “Office 2010 Blue” theme has changed to “Office 2010 Black” theme - 
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Chapter-9: Help 
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9.1. Audit Log 
Audit Log keeps track of all the User Actions of Data Entry (i.e., Insert, Update and Delete) in a 
specific Table of the UIMSv4 Database. If a user adds a new record into the system, each field value 
of this record treated as new value to the system. In this case the old value of that field is empty. If 
user removes a record then the audit log will record the old value only. Because already existing 
value i.e., old value can be deleted or removed. Otherwise if user edit a record and save it, the old 
and new values are saved to the audit log at that time. In other words, all the changes made by a 
user to the system are logged automatically to avoid the unauthorized changes to the system. 

 Run UIMSv4 

 Select Help > Audit Log from Help menu. 

 
There are two panels in this page: a left panel and a right panel. The left panel shows the user 
action of insert, update and delete command. The fields in the left side table -  

 Log Seq: It is the serial number of the records viewing in the page, latest records first. 

 User: Name of the user who is responsible to execute a command. 

 Create Time: It is the date and time of a command executed by the user. 

 Terminal: IP address of the user PC in the network. 

 Table: Name of the table on which the user command is being executed. 

 Query Type: Command type executing by the user – INSERT/UPDATE/DELETE. 

 SQL Text: Standard query language text that is being executed to the database but this a short 
notation of the command. When you click on the ‘more’ button you will be able to see the full 
text of the command.  
 

When you select a record from the left side table, the right side table will show the list of values 
based on command executed. The fields are - field name, old value and new value. If the command 
is INSERT, it will show only new values. The old values are empty in this case. If the command is 
DELETE, it will show only old values new values are empty. It is only the case where both the old 
and new values are encountered when user edit a record. These are the changes the system will 
keep track.  
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9.2. Error Log 
When a user tries to Add, Edit and Remove a record and if any error occurs during database 
operations, i.e., a user is trying to add a record that alreay exists in the database, that will raise an 
error. Again, if a user is trying to delete a record that has a relavent record(s) or reference with 
other table(s) may raise an error. For clarification to the System Administrator an Error Log is 
implemented as per previous user experience. 

 Run UIMSv4 

 Select Help > Error Log from Help menu. 

 
The above image shows the errors which occurred during data entry in UIMSv4. The columns in the 
table are – 

 Remote IP: IP address of the computer where the error initiated 

 User: UIMSv4 User ID 

 Date: It is the date and time of a command executed by the user. 

 Type: Command type executing by the user – INSERT/UPDATE/DELETE. 

 Query: The SQL command which is the source of error 

 Error No: SQL Error number if available 

 Error Message: Error message that explains more about the error. 
 

This error messages can be used by the Administrators to find out what exact errors that happens 
in UIMSv4 and try to solve those. 
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9.3. Data Upload Information 
 Run UIMSv4 

 To view data upload information Select Help > Data upload Information from Help menu. See 
the following screen. 

 
 

 User Id, Terminal, Start Time, End Time, Facility Code, Time to Sync, Status of success. 
 

 

 

 

- END - 

 

 

  


